Outbound calls over PRI aren't working. "Cause No. 44 - requested circuit/channel not available."

Answered Question
May 10th, 2010

Configured a 2650XM for outbound calling over a PRI.  This router has been used for voice before.

Created a dialpeer for a SIP trunk to a Mitel call control server.  Also created a dialpeer for the analog PRI trunk.

When a call is placed outbound, it hits the Mitel, then is sent to the router.  I see this happening in logs, and the correct dialpeers are selected.  When the router attempts to send the call to the PRI, though, I get the following error:

*May  1 03:44:29.247: //19/355048E1801E/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x8441D278, Tag=0x0, Call Id=19,

   Call Entry(Disconnect Cause=44, Voice Class Cause Code=0, Retry Count=0)

I called the provider and verified that the circuit is functional.  They said it is, but I'm still not 100% sure.
I'm fairly new to telephony config, so its very possible I am forgetting some very obvious step.  Config below:
Building configuration...
Current configuration : 2079 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2600-PRI-GTY
!
boot-start-marker
boot-end-marker
!
logging buffered 999999 debugging
no logging console
no logging monitor
XXXXXXXXXXXX
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
network-clock-participate wic 0
network-clock-select 1 T1 0/0
voice-card 0
dspfarm
no local-bypass
!
ip cef
!
!
!
!
no ip domain lookup
ip domain name XXX
isdn switch-type primary-ni
!
!
voice call carrier capacity active
!
voice service voip
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /116057154920/ /16057154920/
!
!
voice translation-profile XLATE
translate called 1
!
!
XXXXXXXXXXXX
!
!
controller T1 0/0
framing esf
fdl both
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
!
!
!
interface FastEthernet0/0
ip address 10.250.0.10 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.250.0.1
!
no ip http server
!
!
!
control-plane
!
!
!
voice-port 0/0:23
!
no ccm-manager fax protocol cisco
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
!
dial-peer cor custom
!
!
!
dial-peer voice 98 voip
description FROM MITEL
signaling forward unconditional
session protocol sipv2
session target sip-server
session transport tcp
incoming called-number .
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 99 pots
translation-profile outgoing XLATE
destination-pattern .T
incoming called-number .
direct-inward-dial
port 0/0:23
forward-digits all
!
sip-ua
sip-server ipv4:10.0.2.16
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
logging synchronous
transport input telnet
!
!
end
As a side note: This was configured to use a Cisco Call Manager previously - maybe there is some residual config messing me up?
Correct Answer by Aaron Harrison about 6 years 9 months ago

Hi

You have the T1 bound to MGCP, but MGCP not running. That could be confusing things.

Assuming CCM is dead and gone, do this:

Conf t

Voice-port 0/0:23

shut

Int ser 0/0:23

Shut

Controller e1 0/0

Shut

No pri-group timeslots 1-24 service mgcp Pri-group timeslots 1-24 No shut

Then reapply the port to the dial-peer, usually it's deleted by the above actions..

Dial-peer voice 99 pots

Port 0/0:23

Check the status of the circuit:

Sh controllers t1

Show isdn status

Also, you sometimes see that channel/circuit error if the trunk is up, but all the B channels are unavailable (i.e. SP has them disabled). If you still have problems after the above, you may need to go back to them.

Regards

Aaron

Please rate helpful posts...

Correct Answer by bmcghee about 6 years 9 months ago

pri-group timeslots 1-24 service mgcp

you need to remove the "service mgcp"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
tylerlucas Mon, 05/10/2010 - 10:24

2600-PRI-GTY#sh int s0/0:23

Serial0/0:23 is up, line protocol is up

  Hardware is DSX1

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation HDLC, loopback not set

  Last input 00:00:01, output never, output hang never

  Last clearing of "show interface" counters 2d18h

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 48 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     10624 packets input, 31872 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

2600-PRI-GTY#sh controller t1

T1 0/0 is up.

  Applique type is Channelized T1

  Cablelength is long gain36 0db

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20090113, FPGA: 20, spm_count = 0

  Framing is ESF, FDL is ansi & att, Line Code is B8ZS, Clock Source is Line.

  CRC Threshold is 320. Reported from firmware  is 320.

  Data in current interval (883 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 24 hours)

     0 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

2600-PRI-GTY#

Correct Answer
Aaron Harrison Mon, 05/10/2010 - 12:33

Hi

You have the T1 bound to MGCP, but MGCP not running. That could be confusing things.

Assuming CCM is dead and gone, do this:

Conf t

Voice-port 0/0:23

shut

Int ser 0/0:23

Shut

Controller e1 0/0

Shut

No pri-group timeslots 1-24 service mgcp Pri-group timeslots 1-24 No shut

Then reapply the port to the dial-peer, usually it's deleted by the above actions..

Dial-peer voice 99 pots

Port 0/0:23

Check the status of the circuit:

Sh controllers t1

Show isdn status

Also, you sometimes see that channel/circuit error if the trunk is up, but all the B channels are unavailable (i.e. SP has them disabled). If you still have problems after the above, you may need to go back to them.

Regards

Aaron

Please rate helpful posts...

Correct Answer
bmcghee Mon, 05/10/2010 - 12:11

pri-group timeslots 1-24 service mgcp

you need to remove the "service mgcp"

Actions

This Discussion