Virtual memory creep CUCM 7.1.3

Unanswered Question
May 10th, 2010
User Badges:
  • Silver, 250 points or more

yesterday we got the "LowAvailableVirtualMemory" alarm on our CUCM 7.1.3 Publisher( been running about three weeks) as the memory usage went over 70%

we reloaded the publisher, and it went down to 35% now 24 hours later it is back up to 55%. The Subscriber UCMs stay at about 48%

from previous posts I see there were problems with earlier versions 5.1 and 6.1 with this problem, but I could not find anything about the problem on 7.1.3

I suspect its something to do with the TomCat service, is this a known problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
David Hailey Mon, 05/10/2010 - 18:08
User Badges:
  • Purple, 4500 points or more

What version of 7.1(3) are you running? (i.e., 7.1.3a, 7.1.3b, 7.1.3bSU1, etc).

Richard Bradfield Mon, 05/10/2010 - 18:19
User Badges:
  • Silver, 250 points or more

I think it is 7.1.3b, under

Cisco Unified CM administration it says

System version: 7.1.3.30000-1

David Hailey Mon, 05/10/2010 - 18:33
User Badges:
  • Purple, 4500 points or more

OK.  I do know of at least one bug that causes memory leaks in CUCM prior to 7.1(3b)SU1; however, it is related to SIP.  Not sure if you're running SIP or not.  Here is the bug - take a look.  CSCte50152 : Memory leak in CCM due to Transient SIP Connections.


In any case, my professional recommendation would be to upgrade your cluster to 7.1(3b)SU2 which has proven to be very stable for us and is our standard recommendation at this time.


Hailey


Please rate helpful posts!

Richard Bradfield Tue, 05/11/2010 - 15:01
User Badges:
  • Silver, 250 points or more

David,

thanks for your input,

We are just starting to play around with SIP and only have a couple of SIP phones at the moment.

However after another 24 hours the Virtual memeory usage has not gone up anymore still at 55%

But we will upgrade to 7.1.3bSU2 in the near future.

David Hailey Tue, 05/11/2010 - 16:17
User Badges:
  • Purple, 4500 points or more

Thanks for following up.  I didn't think you were necessarily hitting that bug...but you never know, which is why I passed it along.  It sounds like you had a little fluke scenario and unfortunately, it happens.  When it does, the only recourse is to reboot anyway.  I'd keep an eye on it (like you have been) and if it stablizes then just consider it a little bump in the road.


Hailey

gogasca Tue, 05/11/2010 - 16:30
User Badges:
  • Green, 3000 points or more

hi, can you please upload the following:


show process load cpu
show process load memory
show hardware
show status
utils diagnose module tomcat
show perf query class "Cisco Tomcat JVM"

Most of the times Tomcat" issues are caused by Cisco created webapps and processes, rather than Tomcat itself.

Any webapps or CTI apps you are using?
CUE, IPCC, IPMA, CDR ?

if you restart Tomcat issue goes away ?
utils service restart Cisco Tomcat



bsugamele1 Thu, 09/16/2010 - 06:56
User Badges:

I received this same error on 7.1.5 which we just upgraded to on Tuesday from 7.1.3. We are running UCCX with about 75 agents all using Ext. Mobility.


Error Message:

Call Manager Error Available virtual memory below 30 Percent. tomcat (875 MB) uses most of the memory.



admin:show process load memory
top - 08:48:44 up 1 day, 10:15,  1 user,  load average: 0.60, 0.26, 0.19
Tasks: 962 total,   2 running, 960 sleeping,   0 stopped,   0 zombie
Cpu(s):  4.2% us,  2.5% sy,  0.1% ni, 92.2% id,  1.0% wa,  0.0% hi,  0.0% si
Mem:   2074636k total,  2047560k used,    27076k free,    33448k buffers
Swap:  2048248k total,  1052048k used,   996200k free,   282264k cached
  STIME   UTIME    TIME+  GROUP    RUSER      PID USER      PR  NI  VIRT  RES
  0:13   0:18   0:31.73 tomcat   tomcat   15684 tomcat    15   0  920m 368m
  0:00   1:58   1:58.69 tomcat   tomcat   15749 tomcat    16   0  920m 368m
  0:00   1:58   1:58.91 tomcat   tomcat   15750 tomcat    16   0  920m 368m
  0:02   2:10   2:13.14 tomcat   tomcat   15754 tomcat    16   0  920m 368m
  0:00   0:00   0:00.34 tomcat   tomcat   15790 tomcat    16   0  920m 368m
  0:00   0:01   0:01.50 tomcat   tomcat   15795 tomcat    16   0  920m 368m
  0:00   0:00   0:00.00 tomcat   tomcat   15813 tomcat    16   0  920m 368m
  0:00   0:19   0:19.81 tomcat   tomcat   15856 tomcat    15   0  920m 368m
  0:00   0:16   0:16.64 tomcat   tomcat   15897 tomcat    15   0  920m 368m
  0:00   0:00   0:00.00 tomcat   tomcat   15958 tomcat    16   0  920m 368m

jason.loomans Wed, 01/26/2011 - 09:30
User Badges:

Has anyone found a resolution.  I am experiencing this after an upgrade to 7.1.5?

shane.orr Wed, 06/01/2011 - 12:49
User Badges:
  • Silver, 250 points or more

Is there any update on this issue?  Pretty much having identical problems with my 7.1.5.32019-1.

iptuser55 Thu, 06/02/2011 - 03:24
User Badges:
  • Silver, 250 points or more

Hi

We`re about to upgrade to 7.1.5.30000 this weekend, is the error common and you are just unlucky ?

jason.loomans Thu, 06/02/2011 - 05:33
User Badges:

The error is common, but ultimately depends on what and how many services are running on your CM servers.


I am not pursuing fixing this, but am upgrading to 8.5.1 in the near future.

cristian.munoz Fri, 06/24/2011 - 14:33
User Badges:

Hi


I have the same problem. The memory is 70% used for Tomcat.The CUCM version is 7.1.3.20000-2.

I restarted Tomcat service.


Someone have idea?

TIA


Cristian.

michellpoulina Mon, 09/22/2014 - 23:53
User Badges:

This is an old post, but we are experiencing the same issue right now. I want to restart the tomcat process but I have no idea what the impact is on a live system. Live as in I got people making and receiving calls and I cannot have any downtime now.

 

Please anyone?

Actions

This Discussion