SPA525G: No alphanumeric in PAB?

Unanswered Question
May 11th, 2010

I have one of the lines of my SPA525G registered to a 3CX extension that I dedicated to a Skype gateway. I created an outbound rule in 3CX where ALL numbers starting with "#" are stripped of the first character and then sent to the Skype route. That way I can use Skype IDs by prepending them with "#". This worked great with a Cisco 7945G. But the SPA525G does not seem to accept alphanumeric characters in its Personal Address Book. So now I have a create a separate outbound rule for every person I call via Skype.

Is there no way for the Personal Address Book to accept a number like "#skypeuserid"?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nseto Wed, 05/19/2010 - 17:06

Could you explain in more detail?

I was able to go to personal address book in the browser and put a # with numbers appended after it into the Work No.

awesterink Wed, 05/19/2010 - 18:34

Try to enter this as a "number": #someskypid

The browser interface does not accept that, at least not for me. I CAN however enter alphanumeric characters through the UI on the phone itself, and the characters get passed on nicely to the PBX and on to the Skype Gateway in 3CX (after stripping off the "#" character).  So I can dial these numbers just fine from the phone...even though it then says "Invalid number" for the active line once I am connected. Weird. BTW I am on firmware version 7.4.4.

nseto Thu, 05/20/2010 - 08:37

Yes the browser only accepts # and numbers and not # and letters.

awesterink Thu, 05/20/2010 - 09:56

Right. Here's hoping that will be changed in a future software update. Some people may be using this phone with SIP for Skype, or some other gateway to Skype (such as 3CX), and in that case you'd want to be able to dial Skype user IDs.