IP Communicator default http port - can it be modified?

Unanswered Question
May 11th, 2010
User Badges:

When running the CIPC (IP Communicator) client (version 7.0.3.0), the device information for the client is available by http port 80 at the ip address of the pc the client is running on (in the same fashion as the ip phones). However we have need to reserve this address for an in house requirement.


Is it possible to modify the port the IP Communicator responds to http request?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
William Bell Tue, 05/11/2010 - 10:41
User Badges:
  • Purple, 4500 points or more

Last time I looked into this I found that you could disable the HTTP server on CIPC but you could not change the port.  The process for disabling was captured in a release note I believe.  Also captured in this netpro doc:


https://supportforums.cisco.com/docs/DOC-3820


I checked the CIPC 7.0 release notes and I do not see mention of any new features which would allow port customization.


Sorry to say, it looks like your choices are to disable it or use TCP 80.


HTH.


Regards,
Bill

Please remember to rate helpful posts.

Chris Tolley Tue, 05/11/2010 - 10:44
User Badges:

That will work. We don't use the local web port much.


Thanks!

Chris Tolley Tue, 05/11/2010 - 11:33
User Badges:

Unfortunatly it does not work on my client (7.0.3 on Windows 7). However the procedure comes from the 1.2 release notes. I did not see anything about this in the 7.x release notes. Perhaps this "feature" is no longer available.

Jonathan Schulenberg Tue, 05/11/2010 - 11:39
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

A model-specific option has been added within the device configuration page on UCM to control this. I'm not sure exactly what version; this is probably what has caused the registry manipulation workaround to stop functioning.

Chris Tolley Tue, 05/11/2010 - 12:20
User Badges:

Found the entry under CUCM Administration>Device>Phone>Product Specific Configuration Layout>Web Access


Disabled, applied and reset and I can no longer get to my CIPC device via http port 80. I've set the user in question up with this so hopefully this will resolve.


Thanks all for the help!

Actions

This Discussion