SPA3102 Keep rebooting after some uptime with code H73720168

Unanswered Question
May 12th, 2010
User Badges:


I'm using SPA3102 for almost a year and since the beginning of my experience with this product I keep having annoying reboots of the unit every hour or so. The reboots are not predictable, they happen randomly. Of course, connections get broken.

After reboot I can see the mysterious "reboot reason:H73720168" in the logs. Can this be fixed?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
nseto Thu, 05/13/2010 - 15:14
User Badges:
  • Silver, 250 points or more

I'm assuming that you've upgrading to the latest available code.

Have you tried factory resetting and making minimal changes to get phone registration and is that stable?

The reboot reason code that you have indicates some kind of corruption in software.

longname112 Fri, 05/14/2010 - 01:48
User Badges:

I haven't upgraded the firmware, because the unit came with the latest fw available. However, I had done factory reset couple times, and it never was helpful for the issue described. What does this code mean exactly?

nseto Fri, 05/14/2010 - 08:47
User Badges:
  • Silver, 250 points or more

That reboot code means the software got corrupted.  You can narrow this down by factory reset, then make just the minimal changes to config and see if it runs ok.  It's possible that a certain combo of config changes may be causing this.  But also could be something from the network, receiving a particular message that could cause this software corrupt issue as well.

longname112 Fri, 05/14/2010 - 09:40
User Badges:

Got corrupted as in "corrupted after upload" or as in "software memory stack gets corrupted"? Should I reupload the firmware and use the same settings first?   If it's the second, that is the code is buggy – it would be extremely time-consuming to try every "option combination in the settings", and it's obvious that it'd be a bad business to pass this job to the end-consumer. That is not something I am paying my $140 to Cisco for, and in fact, that work would make the value of the product negative.

However, I'm willing to follow exact instructions from Cisco people and provide the feedback. Who can take care of this issue?

nseto Fri, 05/14/2010 - 10:09
User Badges:
  • Silver, 250 points or more

The code is a generic message.  What I would do is factory reset and just a minimal amount of changes or none at all and see how it runs for a few days.  If you still get the same code, it could be bad internal flash.  If that's the case, I'd RMA the unit.  If you need to do that, the phone number is located at the following link.

lukasz_naumowicz Mon, 05/09/2011 - 06:13
User Badges:


We got into the same issue.

After changing parametrs like transport layer to TCP or TLS (no matter on which line of SPA3102) and unplugging device from power source then connecting power back, gateway starts to reboot continously. Some times after 5-10 reboots gateway starts to function normally, but usually one has to get to gui interface(you have to do that before gateway reboots again and disable TCP and/or TLS transport to UDP), then gateway starts to function normally.

We have tried to reset gateway to factory default, then set only transport to TLS or TCP, unplug power, connect power back and issue comes back.

Gateway had software flashed multiple times, software in the gateway 5.1.10. the same was observed on 5.1.7.

When gateway reboots in the syslog we get reboot reason: H73720168

I've attached syslog file as well as config file from gateway on which issue was observed.

The same thing was tested by our customer on two different gateways, this is the third one on which we have observed it.

Is it possible that it;s hw issue of these units,  if on three different SPAs changing the same parametrs generates the same issue?



nseto Mon, 05/09/2011 - 10:09
User Badges:
  • Silver, 250 points or more

Can you get me a test account to your server?  I want to try this with my 3102 connected to your server via TCP or TLS.  Please send account info to nseto at  Thanks.

lukasz_naumowicz Mon, 05/09/2011 - 23:48
User Badges:

Please check the attached config, you don;t need to configure SIP account on gateway itself, spa3102 reboots automatically even if sip account details server, user, pass are blank. The only thing which you need to do to try to recreate this is:

- turn on TLS transport on one of the accounts (you can try also with TCP on one of the accounts and TLS on the other simultaneously)

- save settings, wait till gateway reboots automatically

- plug out the power cord (wait around 1 minute)

- turn gateway back on

try to do this multiple times, gateway sometimes reboots only few times 5-10 and sometimes stays in such condition.

The other thing which will let you know that gateway will reboot is setting syslog and turning debug on the gateway, then you will see how many times gateway rebooted due to reason H73720168



nseto Tue, 05/10/2011 - 09:23
User Badges:
  • Silver, 250 points or more

Hi, I don't see an attachment.

You mention not having to set up an account.   So do I just use the default settings and just turn on TCP or TLS for SIP transport and I'll see the problem?

nseto Tue, 05/10/2011 - 09:26
User Badges:
  • Silver, 250 points or more

Oops, you meant the original attachment.  I looked and see nothing for proxy, userID or pw.  I'll try that.  Thanks.

nseto Tue, 05/10/2011 - 10:02
User Badges:
  • Silver, 250 points or more

Your log shows offhook and calling fallback and then it reboots with that reboot code.

So I offhooked my phone and i saw this same instance happen once on my unit.

Does this reboot code happen when you don't do an offhook?

Also does this reboot code happen when you do an offhook and when the unit is connected to a proxy?

perezalvarezhi Tue, 06/16/2015 - 14:16
User Badges:

Hello everyone I know this post is like 5 years old but I just started using this device with the latest firmware version and Im getting the same behaviour.  I can confirm that every time I receive a call trough my VOIP service the device restarts but also I notice that it reboots every time it rings I can hear that every time the VOIP call rings the device restarts.  After I end a call the device restarts like 5 to 6 times and then goes back to normal.


When I make calls using VOIP everything is normal but sometimes when I hang up the device resets again several times, then goes back to normal.

I have not tried making PSTN calls and receiving since I don't have a PSTN outlet close by but i will come back as soon as I try that too. 


Thank you!