CiscoWorks RME Compliance Check - Has any body seen a DCMA0038 error?

Unanswered Question
May 12th, 2010


We are currently running:

NameVersionLicense StatusSize
CiscoWorks Common  Services3.3.0LicensedNot applicable
Campus Manager5.2.1Purchased1500
CiscoView6.1.9LicensedNot applicable
CiscoWorks  Assistant1.2.0LicensedNot applicable
Device Fault  Manager3.2.0Purchased1500
Internetwork Performance  Monitor4.2.0Purchased1500
LMS Portal1.2.0LicensedNot applicable
Resource Manager  Essentials4.3.1Purchased1500

I am trying to run a compliance check, but am receiving this error:

     DCMA0038: No device found for the selected Baseline Template.

I am unable to select the devices that I want to check.

Does anyone know what service is not running or what I need to to do get Cisco Works working?

I have also tried with the other base templates but all return the same error.

It seems that direct deploy is also having the same trouble.

This did work a week ago and nothing has changed that I know of.

I could not find the appropriate log to attach - will post when notified of which log to post :-)

Any ideas are gratefully received.

Kind regards


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 05/12/2010 - 11:59

Export this template to an XML file, then post it.  Also, post the dcmaclient.log and NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log.

Russell Bovaird Wed, 05/12/2010 - 16:15


Thanks for your prompt reply.

I have attached a zip file with the requested information in it.  I had rebooted the server so the logs are not very big.  Larger ones can be supplied if needed.

Kind regards


Joe Clarke Wed, 05/12/2010 - 19:00

I'm not seeing any obvious errors here.  It looks like you created this template only for 3750G-24PS switches, and I'm guessing you don't actually have any in your network.  By default, all 3750 switches show up as 3750 Stack devices.  Perhaps you need to change the template device family to "Cisco 3750 Stack".

Russell Bovaird Wed, 05/12/2010 - 19:07

Thanks for you reply Joe.

This particular compliance template successfully ran last week.

There are 3750G-24PS switches in the network. 

I don't get to choose which devices to run the test against - which is the problem.

Here is a sample from the output from last week - truncated somewhat.

Name:Archive Mgmt Job Work OrderSummary:General Info 
JobId:  1258
Owner: russ
Description: Check for voice vlan on interfaces 
Schedule Type: Immediate
Job Type: Compliance Check
Baseline  Template Name: rb_change_voice_vlan
Attachment Option: Disabled
Report  Type: NA

Job  Policies

E-mail  Notification:
Job Based Password: Disabled

Device  Details

location-3750s-1  interface GigabitEthernet1/0/1
     switchport voice vlan  473
  interface GigabitEthernet1/0/2
     switchport voice vlan  473
  interface GigabitEthernet1/0/3
     switchport voice vlan  473
  interface GigabitEthernet1/0/4
     switchport voice vlan  473
  interface GigabitEthernet1/0/5
     switchport voice vlan  473
  interface GigabitEthernet1/0/6
     switchport voice vlan  473
  interface GigabitEthernet1/0/7
     switchport voice vlan  473
  interface GigabitEthernet1/0/8
     switchport voice vlan  473
  interface GigabitEthernet1/0/9
     switchport voice vlan  473
  interface GigabitEthernet1/0/10
     switchport voice vlan  473
  interface GigabitEthernet1/0/11
     switchport voice vlan  473
  interface GigabitEthernet1/0/12
     switchport voice vlan  473
  interface GigabitEthernet1/0/13
     switchport voice vlan  473
  interface GigabitEthernet1/0/14
     switchport voice vlan  473
  interface GigabitEthernet1/0/15
     switchport voice vlan  473
  interface GigabitEthernet1/0/16
     switchport voice vlan  473
  interface GigabitEthernet1/0/17
     switchport voice vlan  473
  interface GigabitEthernet1/0/18
     switchport voice vlan  473
  interface GigabitEthernet1/0/19
     switchport voice vlan  473
  interface GigabitEthernet1/0/20
     switchport voice vlan  473
  interface GigabitEthernet1/0/21
     switchport voice vlan  473
  interface GigabitEthernet1/0/22
     switchport voice vlan  473
  interface GigabitEthernet1/0/23
     switchport voice vlan  473
  interface GigabitEthernet2/0/1
     switchport voice vlan 473
Russell Bovaird Wed, 05/12/2010 - 19:38


I have just created another template with exactly the same details and Compliance Check has allowed me to choose the devices and run the check.

I then tried to run the initial template but still had an error DCMA0038 - and still no device selection.

Quite weird.

Any thoughts or suggestions?

Also in RME NetConfig Jobs

It would seem that selecting individual devices is also a problem.  The "All devices" tick box can be selected, however the individual selections under it they are not available - it could be the same issue?

Joe Clarke Wed, 05/12/2010 - 23:07

The Netconfig issue looks like a package problem.  While that could be affecting baseline as well, the fact that a new template works leads me to believe something else is broken in baseline.  Start a new thread for the Netconfig problem.

Joe Clarke Thu, 05/13/2010 - 08:15

This looks fine.  Is it only this one template that is being problematic?

Russell Bovaird Sun, 05/16/2010 - 18:10


thanks for your reply.  There is one other template - the C3750 template which is having the same problem.

All others including the default ones are working as required and the device selection works.


Joe Clarke Sun, 05/16/2010 - 21:37

Try deleting the problematic templates, then reimport them from the exported XML files.  Do they work?

Russell Bovaird Mon, 05/17/2010 - 16:40


I have exported both the templates to an xml file.

Deleted the problem templates and reimported them from the xml files.

When going to run them as a compliance check I still get:

     DCMA0038: No device found for the selected Baseline Template.

as I am unable to select the device - the select device screen still does not appear.



Joe Clarke Mon, 05/17/2010 - 17:24

Part of me is starting to think the package map issue might be causing this problem as well.  Post the export of a working template.  This may help clarify if this really could be part of the package issue.

Joe Clarke Tue, 05/18/2010 - 09:45

This template works because it points to the superset of all 3750 switches.  There does appear to be some corruption in your package map related to 3750s, so perhaps fixing the map will also fix this problem.  Can you confirm that changing the device type for the non-working script to be all 3750s works?

Russell Bovaird Tue, 05/18/2010 - 16:08


I changed the DeviceFamily from:


This is the 3750-24PS



This is all 3750 switches

From one of the working templates which selected all the 3750s

Running this ammended template worked.

Does this look like a corruption of files problem?



Russell Bovaird Tue, 05/18/2010 - 16:32

Thanks Joe,

I'll talk with TAC and see if everything is working again once the new packages are rebuilt.

I'll report back once this has been done.

Thanks for your help.




This Discussion

Related Content