Vlans and DHCP ?

Unanswered Question
May 12th, 2010
User Badges:

Hi,


I have a network which has recently been subject to a power failure.


Upon re-powering switch (3560G), ap (1252), router (netgear), and servers (Windows 2k3, 2k8), I am unable to get a DHCP ip address on any except the native vlan (wired and wireless). I am able to assign an ip address manually in both wired and wireless modes on my test laptop, but if the laptop is set to retrieve an address using DHCP, it times out and gets an address in 169.254.x.x (APIPA).


The 3560G switch has 3 vlans:

Native: 192.168.5.0/24

VLAN15: 192.168.15.0/24

VLAN25: 192.168.25.0/24


The Vlans as defined on the switch include the command ip helper-address (see below):


interface Vlan1
ip address 192.168.5.16 255.255.255.0
ntp broadcast
!
interface Vlan15
ip address 192.168.15.2 255.255.255.0
ip helper-address 192.168.5.5
ntp broadcast
!
interface Vlan25
ip address 192.168.25.2 255.255.255.0
ip helper-address 192.168.5.5
ntp broadcast
!
ip default-gateway 192.168.5.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.1

The server at 192.168.5.5 has multiple DHCP scopes defined (one for each vlan). The default gateway at 192.168.5.1 is a netgear router


This was working prior to a power failure.


Any Ideas?


TIA

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Wed, 05/12/2010 - 22:54
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi,


I have a network which has recently been subject to a power failure.


Upon re-powering switch (3560G), ap (1252), router (netgear), and servers (Windows 2k3, 2k8), I am unable to get a DHCP ip address on any except the native vlan (wired and wireless). I am able to assign an ip address manually in both wired and wireless modes on my test laptop, but if the laptop is set to retrieve an address using DHCP, it times out and gets an address in 169.254.x.x (APIPA).


The 3560G switch has 3 vlans:

Native: 192.168.5.0/24

VLAN15: 192.168.15.0/24

VLAN25: 192.168.25.0/24


The Vlans as defined on the switch include the command ip helper-address (see below):


interface Vlan1
ip address 192.168.5.16 255.255.255.0
ntp broadcast
!
interface Vlan15
ip address 192.168.15.2 255.255.255.0
ip helper-address 192.168.5.5
ntp broadcast
!
interface Vlan25
ip address 192.168.25.2 255.255.255.0
ip helper-address 192.168.5.5
ntp broadcast
!
ip default-gateway 192.168.5.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.1

The server at 192.168.5.5 has multiple DHCP scopes defined (one for each vlan). The default gateway at 192.168.5.1 is a netgear router


This was working prior to a power failure.


Any Ideas?


TIA

After Power failure DHCP server is reachable from vlan subnet (switch)  or not ? If they are not reachable then it wont get the ip address from DHCP server.


Hope to Help !!


Ganesh.H

IM-Design Thu, 05/13/2010 - 09:50
User Badges:

Hi. Thanks for the reply.


I found the solution. The router (netgear) was unable to know what to do with the DHCP traffic that it was receiving (it being the default gateway). Once I set up DHCP relay on that device my vlans began to receive ip addresses correctly.


What is not clear to me is whether this was configured before the power failure. If it was then why dod the power failure cause it to lose this setting. If not, then why was it working previously?


Thanks Again.

Ganesh Hariharan Fri, 05/14/2010 - 03:58
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi. Thanks for the reply.


I found the solution. The router (netgear) was unable to know what to do with the DHCP traffic that it was receiving (it being the default gateway). Once I set up DHCP relay on that device my vlans began to receive ip addresses correctly.


What is not clear to me is whether this was configured before the power failure. If it was then why dod the power failure cause it to lose this setting. If not, then why was it working previously?


Thanks Again.

It should be configured before as the DHCP relay feature relays a request from a remote client to a DHCP server for an IP address. When the router receives a DHCP request from an IP client, it forwards the request to the DHCP server and passes the response back to the IP client.


Hope to Help !!


Ganesh.H

Actions

This Discussion