SPA8000 - "Display Name" is not working

Unanswered Question


In my SPA8000. when I change the "Display Name" (aka: Caller ID name) found under each line configuration (L1, L2, L...etc), when making an outbound call, the Display Name seems not to be working, that is, the "Display Name" I specified is not displayed.

I followed the instructions found at:

But nothing seems to work.  My goal is that when making outbound calls via the SPA8000 the CID displayed at the recieving end is consistent with the CID name I defined via the Display Name attribute.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jonathan Schulenberg Thu, 05/13/2010 - 03:11
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Where are you making the call to (PSTN, an IP phone, an analog device, etc) and what is your call agent (CME, UCM, etc)?

I am making the calls to PSTN and mobile units (where the CID is displayed by default).

Rearding the call agent, I am not using none of Cisco's solutions, I am using a 3rd party telephony layer, my telephony hardware is a Dialogic 120jct connected to the Linksys SPA8000, and the outbound calls are successfully placed, but with the odd CID.

After chatting with my VOIP provider, they mentioned that the setting resides in the SPA8000, that said, I can see the currently displayed number registered in the SPA 8000 (See attached image) but regardless my changes from the existing CID to a number such as 7877992010 and following the additional steps found at:

The Display Name, remains unchanged..

I am beginning to wonder if this is a bug in the unit.

Jonathan Schulenberg Thu, 05/13/2010 - 07:36
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Caller ID Name (CNAM) is not customer-controllable across the PSTN. There is no field for it within the SS7 data header that carriers use to route calls across one another. In some cases, carriers do alow this inside their own network (i.e. you call a phone number that uses the same carrier you are using). You would need to check with your carrier if they are will allow this.  Otherwise the best you can do is specify the ANI (Caller ID Number). The carrier has a separate database where they specify the CNAM data for the destination carrier to lookup the name to display and this is not accessible by subscribers.


I spoke to my VOIP carrier, their stance is that they will flow forward the CID that I provide via my SIP adapter configuration, which right now the CID is my account number at my VOIP carrier, so I need to change the configuration setting in my SIP adapter.

What I need to know is how do I tell the SPA8000 to pass the telephone number I am registering in the Display Name field, instead of my account number?  From the instructions provided by Cisco (link sent earlier), it seems that this is doable but the SPA8000 refuses to display the updated information.




This Discussion