IP Communicator Over VPN

Unanswered Question
May 13th, 2010

Hi Guys,

We have just installed a Sonicwall on our network and users want to use the VPN and soft phone from home.

when we take laptops home and connect over VPN the IP Communicator just says registering all the time and nothing happens do i need to configure something on order for this to work?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Hailey Thu, 05/13/2010 - 07:27

Sonicwall is pretty notorious (in my experience) for not being very application friendly.  I'd start there and make sure that TFTP, SCCP, and all of the various UDP ports for RTP are open.  First step of course is the registration part which would be DHCP, TFTP, etc.


Please rate helpful posts!

marksie1988 Thu, 05/13/2010 - 07:40

but users are using a VPN so i shouldnt need to open any ports as it is basically on the network. wouldnt this be something to do with the route between network and our network?

James Hawkins Thu, 05/13/2010 - 10:19

Hi Steve,

The first thing to check is whether the Sonicwall complies with this restriction from the IPC 7.0 release notes.

Cisco IP Communicator only works with the VPN Software that creates a virtual interface and has an IP Address allocated to it.

Assuming that it does then you could try manually specifying the IP address used by CIPC in the Network Audio Settings window (right-click > Audio tab > Network button).

I am not sure whether this will resolve the problem as I have only used CIPC over IPSEC VPNs and I think SonicWall uses SSL.

Let us know if this helps.

marksie1988 Thu, 05/20/2010 - 07:25

Hi James,

the Sonicwall that we are using does have the virtual network adapter, and is over IPSec.

on the phone system do i need to assign the phone to the mac address of the virtual adapter or of the physical adapter?



marksie1988 Thu, 05/20/2010 - 16:20

i have managed to figure our that i cannot access the cisco uc560 at all over the VPN so i think this is causing my issues! i have logged the call with sonicwall hopefully they will have an answer as to why i can access all the network other than switches and phone system!

malberttoo Thu, 09/30/2010 - 02:00

I'm having the same problem, did you ever get your issue resolved?

marksie1988 Fri, 07/29/2011 - 06:29

yes you need to add a static route into the router to the network that your phones work on e.g. 10.1.1.x

emresumengen Mon, 08/01/2011 - 17:54

Are you using DHCP option to advertise TFTP address on your office network?

If the answer iS yes, that can be the source of your problem? As DHCP is usually not relayed over to VPN. Have you tried setting TFTP manually on IP Communicator clients? (Just guessing)

Sent from Cisco Technical Support iPad App


This Discussion