Upgrade CallManager-Does DMA Require Win2K OS Patch?

Unanswered Question
May 13th, 2010
User Badges:

Upgrading a 4.1(3) cluster to version 7.1(3),  using new servers and importing a DMA TAR file to restore db.  I ran the Upgrade Assistant and it complained about memory (ok, I've got new servers), and the OS version on the old CallManager.  It's OS version 2000.4.2 and the Upgrade Assistant wants version 2000.4.6.


My question is, does it matter?  I'm just going to pull off the TAR file and use it during the new Communications Manager installation on the new appliance servers.  Will DMA run ok on the current OS version?


I hate to have to upgrade the old servers, so if anyone has experience with this, please share.


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
David Hailey Thu, 05/13/2010 - 13:43
User Badges:
  • Purple, 4500 points or more

DMA and Upgrade Assistant are 2 separate tools with independent purposes.  The Upgrade Assistant is used to determine if the hardware/software on your system is ready to be upgraded...in other words, it's a currency (that is, is everything current) and health check.


DMA is the tool used to prepare the export file for upgrade.  If you moving to Linux, I don't know of any interdependencies with OS and if you're using new servers for migration - then the hardware check doesn't really matter.


Hailey


Please rate helpful posts!

mwheinz Thu, 05/13/2010 - 13:58
User Badges:

True, the hardware check is irrelevant, but does the Upgrade Assistant "know" that DMA requires a certain OS version in order to run on the current Windows CallManager?  That's the question.  Release notes for the DMA tool, nor the readme, indicate any required OS version to run this tool.


Thanks!

David Hailey Thu, 05/13/2010 - 14:01
User Badges:
  • Purple, 4500 points or more

Sorry if my answer was vague, the Upgrade Assistant isn't checking anything as a pre-req for DMA.  It is checking readiness for an upgrade on the specific server it's being run on. 


I don't see any reason why you can't install DMA and run it on your server as-is.


Hailey

mwheinz Thu, 05/13/2010 - 14:18
User Badges:

Not knowing any better, I do tend to agree with you.  But, the question does a

rise, why does the Upgrade Assistant even care about OS version?  After the UA, the next st

ep is install and run DMA, isn't it?  If you were upgrading to a newer Windows version of CallManager, the UA would be checking OS requirements for that version application, right?  I'm hoping that someone who actually ran DMA after the UA OS warning will answer so I'd get the real "skinny" on this.


Thanks for helping out!

Jaime Valencia Thu, 05/13/2010 - 14:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

Because the assistant is not exclusively for Linux appliances migrations.



CCMUpgdAsstInstall.4-3-13.exe
Release Date: 19/Apr/2010
UA 4.3(13), is a universal version of non-intrusive upgrade tool that can detect the health of your servers before you upgrade to 3.3(5),4.0(2a),4.1(x),,4.2(x),4.3(x),5.0(x),5.1(x),6.0(x),6.1(x),7.0(x), & 7.1(x)


As long as you don't get errors in DMA which is the real important part of the upgrade you're good to go.


DMA doesn't care what CIPTOS version you're running, it only cares you're running 4.1(3) to migrate the data.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

mwheinz Thu, 05/13/2010 - 14:51
User Badges:

Yeah, I just read the DMA User Guide and I now tend to agree with you.

  Thanks for your input.  You gotta wonder, thought, why the UA checks the OS on a linux upgrade

, when the only thing that's gonna happen is that someone will ins

tall DMA.

David Hailey Thu, 05/13/2010 - 15:01
User Badges:
  • Purple, 4500 points or more

Wait if you wish, I take no offense.  But, you can install DMA.  The Upgrade Assistant is not related in any way, shape, or form to DMA and is not checking for any pre-requisites related to DMA.  It is a generic application for both Windows and Linux upgrades.  The Windows OS is of no consequence when you are migrating to Linux.  The system will get wiped out anyway.  It is running pre-canned checks as they relate to CUCM upgrades.  For 4x servers, the release notes state that one of the checks is for the following:



Software Version Validation

This check occurs on the publisher database and subscriber servers.

The utility validates the Cisco-provided operating system/related service releases and SQL Server/related service releases.

For information on minimum software requirements, refer to the Cisco Unified Communications Manager Software Compatibility Guide. To obtain the most recent version of this document, see Table 1.

The Upgrade Utility checks only for software applications that this document lists. If you run other applications in the cluster or other applications on the servers, verify that compatibility exists between Cisco Unified CallManager and the application before you upgrade. Failing to do so may cause applications to not work as expected.


It also points out that the UA is related to the actual upgrade on each server individually...not the installation of DMA.  Installing DMA also does not have any pre-requisite for UA.


Good luck.


Hailey

David Hailey Thu, 05/13/2010 - 15:06
User Badges:
  • Purple, 4500 points or more

I see Java summed up what I've been saying all along.  So, there it is.

Actions

This Discussion