CiscoWorks LMS 3.2 Java 1.0.6_11 will not run on Windows 2003 server

Unanswered Question
May 13th, 2010
User Badges:

On a server running Windows 2003, the required version of Java bundled with LMS 3.2 will not run.  A persistent standard message is received requesting that Java 1.6.0_11 be installed.  The Java has been uninstalled (via Control Panel) with the Daemon Manager halted, and Java re-installed,  on the C: or D: drive, yet the page requesting installation of the Java is still received.  {Currently, the Java is installed on the D: drive, which also hosts the CSCOpx files----the application itself}.  Could it be a permissions problem?  I will work with a remote Systems Administrator to find out if the installation requires higher level permissions than the server administrator tomorrow, if possible to attempt to resolve this.   I am an administrator on my laptop PC, from which I can download, install and run the desired Java above successfully, and all Campus Manager functions work fine.  The most recent available upgrades to CM and to RME were installed in the past few weeks, and bugs with those were resolved, as well as installation of UTU 2.0, all of which work fine with the exception of Topology Services.  An attachement cannot upload due to "forbidden content"---probably HTML links.  The Java console is enabled on the server, but the console window does not open and thereby provide error messages.  JRM.log was checked for errors and problems, and none have been found so far.  A TAC case will be opened if advisable.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 05/13/2010 - 16:03
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What other versions of Java are installed on the server?  What browser are you using on the server?  Have you tried using LMS from a different (perhaps fresh) account on the server?

DOUG REISS Fri, 05/14/2010 - 08:20
User Badges:

Joe: 1) All other version of Java were removed from the server (un-uploadable file contained t

hat information, sorry it could not be posted).  2)  IE 6 is being used on the server, specifically,

6.0.3790.3959.  3)  LMS has been accessed both by my own account, with nearly full privileges (only export lacking) and the administrative account.

Joe Clarke Fri, 05/14/2010 - 09:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Exactly what page are you seeing which tells you Java is required?  Can you try Firefox 3 to see if it works?

DOUG REISS Fri, 05/14/2010 - 10:06
User Badges:

Unfortunately, I cannot try any alternate browser on our system, due to corporate policy restrictions (verified with server staff).  The page that displays is: https://JSP/CAMPUS/help/cmf/jplug_install_ns_windows.html in which the server name has been removed.   The page title and first line is:  "Installation of Java Plug-in on Windows You should use the supported Java Plug-in version 1.6.0_11 for accessing CiscoWorks Applications. We recommend that you uninstall other Java Plug-in versions from the client machine." etc.  I worked with our server staff this morning, to attempt to have them install the required Java, with no luck or change to the situation.  I examined our IE 6 browser settings, and made some changes, with no improvement at all.  I noted that no System Java was present (Control Panel>Java) and so downloaded and installed from www.java.com 1.6.0_20, then noted that 1.6.0_11 was no longer in the system and re-installed it.  Still no luck or ability to run Topology Services on the server.

Joe Clarke Fri, 05/14/2010 - 14:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You shouldn't be downloading anything from Sun.  You should take the 1.6.0_11 installer from the LMS server, and install it.  You should then see a Java Control Panel.  Running "java -version" from a DOS prompt should report 1.6.0_11.  When you go to IE > Tools > Internet Options > Advanced, you should see a section for Java with the box next to Use JRE 1.6.0_11 for checked.

DOUG REISS Fri, 05/14/2010 - 14:28
User Badges:

I apparently became overly concerned when I didn't see a System Java, just the Java 1.6.011 for User on the Control Panel>Java>Java tab.  Once I finish defragmenting (which will take a while yet) I will remove 1.6.0_20 and investigate the check box issue.  Meanwhile, I have also taken snapshots of every IE setting to compare between my laptop and the server, although there may be some differences between the server and a laptop.  I realized that there should only be 1.6.0_11 in IE Options a little while ago, myself.  I will post a status update before I leave.

DOUG REISS Mon, 05/17/2010 - 14:52
User Badges:

Have removed all Java except 1.0.6_11.  Could not post during weekend or by departure on Friday.  Situation has not changed.   Will be making detailed comparison of Internet Options between server and laptop, to find out if they can be made as similar as possible, if not identical.  Any further suggestions are welcome!

Joe Clarke Mon, 05/17/2010 - 17:26
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I would highly suggest you to persuade your server people to let you install Firefox just for troubleshooting purposes.  If Firefox works, this will tell us that the problem is IE, and thus could point to an IE setting or security policy.  If Firefox doesn't work, then the problem is probably still Java-based.  It may still point to an issue with a server software policy preventing proper plug-in installation, but at least we'll have another piece of the puzzle.

DOUG REISS Tue, 05/25/2010 - 15:00
User Badges:

No response has been received from our server staff to the suggestion proposed, which basically means the suggestion cannot even be considered.  This server is not a test device which can be maniuplated at will or for troubleshooting purposes---in fact, we no longer have such a device in our network.  Our network policy most likely will also block downloads from the Firefox site as well.  If there are any suggestions on how to check server software policy restrictions or how to work around them, please let me know.

Joe Clarke Wed, 05/26/2010 - 21:12
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your server admin team would be the best ones to answer that.  I don't know all of the specifics.  As I said before, I would check the IE Advanced settings to make sure the plugin has been enabled for tags.  If that option isn't appearing, then something is blocking the proper installation of the plug-in component.

DOUG REISS Tue, 05/25/2010 - 15:10
User Badges:

Checked Control Panel>Add-Remove Programs and there is every indication that Java Update 6

version 11 is installed on the server.

DOUG REISS Fri, 11/26/2010 - 10:18
User Badges:

I finally found from our Security staff that I may request a variance and download and install Firefox.  When the opportu

nity to do so presents itself, I will be able to pursue this further.

Actions

This Discussion

Related Content