ICM Central controller not working in duplex mode

Answered Question
May 14th, 2010

Hi,

I installed ICM 7.5 as sprawler in duplex mode. But router's mdsproc process always displaying message as "Synchronizer switching to non-duplex operation". But I can able to ping all the private ip address from both the ends.

Thanks

Suresh

I have this problem too.
0 votes

This is the method to validate duplex behaviour.

1. Start LoggerA

2. Start RouterA.

Examine the trace in the router process window. It should say "synchronization hold off disabled".

3. Start RouterB and watch the router A window. When it handshakes to its peer, you should see router A start to download the config from logger A. If this does not happen, you have an error in the configuration.

Run ICMSetup.exe from the icm\bin directory. Carefully compare routerA and routerB. You have an error and you must find it.

Regards,

Geoff

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer

This is the method to validate duplex behaviour.

1. Start LoggerA

2. Start RouterA.

Examine the trace in the router process window. It should say "synchronization hold off disabled".

3. Start RouterB and watch the router A window. When it handshakes to its peer, you should see router A start to download the config from logger A. If this does not happen, you have an error in the configuration.

Run ICMSetup.exe from the icm\bin directory. Carefully compare routerA and routerB. You have an error and you must find it.

Regards,

Geoff

usasanth1 Sat, 05/15/2010 - 08:26

Thanks for all your replies. Issue identified as side-b sprawler's instance number configured as 1 instead of 0. Now it changed to duplex mode and working fine. Once again thanks to all.

Regards

Suresh

Excellent. I should have thought of that - I mentioned it in the thread "Logger and AW Database Replication issue":

"Make sure you have not installed the Logger with instance number 1. If you have installed and removed, then reinstalled, the number may have shifted from 0 to 1, and so all the port numbers have changed."

In that thread, Cisco TAC helped the original poster and they identified that the private and public NIC binding order was incorrect (public should be first).

NIC binding order and instance number alignment are two things we need to keep in mind.

Regards,

Geoff

Abu Hadee Fri, 05/14/2010 - 04:48

Hi Suresh,

the MDS Process communicate the via the private links. So you have to make sure private ip address/hostname are properly configured.

On A side check what is local Private address you've defined, B side must use same address to refer to A side. Same goes to B to A.

If you use host name, make sure it does a proper resolution to ip address. try ping to make sure.

Do you have seperate Private interface?If so, are both Routers private interfaces in same subnet?

If not, do you have static route defined?

you can use "netstat -a" to see which ports MDS process is listening. This ports are depenand on instance number. But you can check the registry setting. This will be under RouterA, MDS high/low/mediup registry setting

Check these settings and let me know how it goes.

Actions

This Discussion