I can't get my pix 515 working correctly

Unanswered Question
May 15th, 2010
User Badges:

Hey i hope some wone can help me ....


I have a fix ip range  form 92.67.197.96 to 92.67.197.103 mask 255.255.255.248

92.67.197.97 router
92.67.197.98 pix
92.67.197.100 web-server


I can browes the internet from the insdei and from the dmz.

And i can ping the local dmz ip 172.16.1.10 and 172.16.1.11


But im not anable to browes to my own web-server.


Thise is my pix config.


PIX Version 7.0(1)
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 92.67.197.98 255.255.255.248
!
interface Ethernet1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2
nameif dmz
security-level 10
ip address 172.16.1.1 255.255.255.0
!
enable password ********* encrypted
passwd ********* encrypted
hostname pixpirewall
domain-name sikkie.nl
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00


object-group network www_services
description All servers providing WWW services to the outside
network-object host 92.67.197.100
object-group network https_services
description All servers providing https services to the outside
network-object host 92.67.197.100
object-group network mysql_services
description All servers providing MySql services to the outside


access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any host 92.67.197.100 eq www
access-list outside_access_in extended permit tcp any host 92.67.197.100 eq https
access-list outside_access_in extended permit tcp any host 92.67.197.100 eq ftp
access-list outside_access_in extended permit tcp any host 92.67.197.101 eq 3306


pager lines 24
logging enable
logging timestamp
logging standby
logging console critical
logging monitor debugging
logging buffered debugging
logging trap informational
logging history informational
logging asdm informational
logging queue 3000
mtu outside 1500
mtu inside 1500
mtu dmz 1500
monitor-interface outside
monitor-interface inside
monitor-interface dmz
asdm image flash:/asdm.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.1.0 255.255.255.0
nat (dmz) 1 172.16.1.0 255.255.255.0
static (dmz,outside) 92.67.197.100 172.16.1.10 netmask 255.255.255.255
static (dmz,outside) 92.67.197.101 172.16.1.11 netmask 255.255.255.255
static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
static (dmz,inside) 172.16.1.0 172.16.1.0 netmask 255.255.255.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 92.67.197.97 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps snmp
telnet timeout 5
ssh timeout 5
console timeout 0
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
Cryptochecksum:*********
: end


Greets,

Marcel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jennifer Halim Sat, 05/15/2010 - 17:15
User Badges:
  • Cisco Employee,

Where can't you browse your web server from? I tested browsing it from the internet, it works just fine.


If you are trying to browse from your inside network, you would need to configure the following static statement:


static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0


Then issue "clear xlate" to clear the existing translation.


Lastly, from the inside, you would need to browse to the private ip address of the server as follows:

http://172.16.1.10


Hope that helps.

msikkema Sat, 05/15/2010 - 18:25
User Badges:

uhm i can access my webserver from outside my netwerk bv from my perrents home.

From my perrents home i can browes my website (www.sikkie.nl).

But whane im at home, its not working form inside my network.

And im opening www.sikkie.nl its not working.

Federico Coto F... Sat, 05/15/2010 - 18:28
User Badges:
  • Green, 3000 points or more

Marcel,


The problem is at your home then....

Can you browse other pages correctly from the Internet?


Federico.

Jennifer Halim Sat, 05/15/2010 - 18:53
User Badges:
  • Cisco Employee,

If you are from the internal network, the dns resolution for"www.sikkie.nl" probably resolves to the public ip address instead of the private ip address.


You can try browsing the website via its private ip address as suggested earlier.

So instead of "http://www.sikkie.nl", try "http://172.16.1.10" when you are from the internal network.


If the dns entry for "www.sikkie.nl" is hosted on the Internet dns server, then you can configure dns doctoring as follows:

Change the following static statement from:


static (dmz,outside) 92.67.197.100 172.16.1.10 netmask 255.255.255.255


TO:

static (dmz,outside) 92.67.197.100 172.16.1.10 netmask 255.255.255.255 dns


DNS doctoring will only work if the dns entry for www.sikkie.nl is hosted on the outside.

To test, you would need to flush the dns entry on your PC, so it triggers dns request through the ASA, and the reply will change the dns entry for www.sikkie.nl from 92.67.197.100 to 172.16.1.10 so you can access the website internally using its private ip address.


Hope that helps.

Actions

This Discussion