Jtapigw-jgw1 not getting active

Unanswered Question
May 16th, 2010

ICM 7.5

Patch 7.5.8

CUCM 7.1.3.32900-4

I am facing problem to register the Jtapi with the CallManager. It is throwing the below mentioned error.

***********************************************************************************************************************************

18:27:40 Trace: Message: Unable to create provider -- User connected on an invalid port

18:27:55 Trace: OnNodeManagerPing()

18:28:00 Trace: Configuring JTAPI Object

18:28:00 Trace: Calling getJtapiPeer for peer: com.cisco.jtapi.CiscoJtapiPeerImpl

18:28:00 Trace: getJtapiPeer returned successfully.  JTapiPeer class name: com.cisco.jtapi.CiscoJtapiPeerImpl

18:28:00 Trace: JTapiObj:initializeJTapi: Values for UseProgressAsDisconnectedCauses are: 0

18:28:00 Trace: CiscoJtapiVersion: Cisco Jtapi version 7.1(2.10000)-3 Release

18:28:00 Trace: BuildDescription: Release BuildNumber: 10000 RevisionNumber: 2 MajorVersion: 7 MinorVersion: 1 ExtendedBuildNumber: 3

18:28:00 Trace: Use icmJavaLib.jar to support CallManager 5.0 or higher release.

18:28:00 Trace: Not using CiscoSynchronousObserver interface.

18:28:00 Trace: disableAll() TraceManager for CTICLIENT

18:28:00 Trace: Calling getProvider() 172.16.81.10;login=ipccucmaster;passwd=<***edited***>

18:28:05 Trace: JtapiPeer.getProvider(): caught PlatformException(com.cisco.jtapi.PlatformExceptionImpl: Unable to create provider -- User connected on an invalid port)  Provider could not be created.

18:28:05 Trace: Message: Unable to create provider -- User connected on an invalid port

**************************************************************************************************************************************
Regards,
Sandeep
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sandeep pokhriyal Sun, 05/16/2010 - 23:43

Thxx for the reply!

The CTI Manager service is activated!

The setup was working fine till recently we applied service release for CUCM. I doubt that will make the JTAPI not to work. We have applied the new JTAPI in the PG server.

It is a Progger design.

Regards

Sandeep

Gergely Szabo Mon, 05/17/2010 - 01:06

Did you restart the PG server after applying the JTAPI upgrade?

Did you try to uninstall, reboot, install JTAPI?

By the way, from which version did you upgrade from? (I mean CUCM)

G.

david.macias Mon, 05/17/2010 - 04:44

Was there an upgrade on the JTAPI client version?  Have you tried reinstalling JTAPI on the PG?

david

sandeep pokhriyal Mon, 05/17/2010 - 06:11

Old Version CUCM- 7.1.3.10000-11

New Version CUCM- 7.1.3.32900-4

I have Downloaded the new Jtapi and installed on the PG server. Restart, installation, uninstallation everything possible has been done!!

Installed a New PG pointing to another CCM 7.1.3.20000-2, but still the same issue.

The Jtapi version was also changed. I could see the new version while installing.

Regards,

Sandeep

sandeep pokhriyal Mon, 05/17/2010 - 07:03

Update..working with the CUCM 7.1.3.20000-2.

Running the setup again and restarting the CTI Manager worked.

CUCM- 7.1.3.32900-4..the issue is persistent.

Regards,

Sandeep

sandeep pokhriyal Tue, 05/18/2010 - 01:14

The Rollback to the previous version of CallManager worked!!

1) Added a new user

2) Applied to CTI groups (Previously i added the Jtapi user to all the Groups in CUCM..for testing..i wonder that was the case, if so, it should have worked before)

3) Re-run the PG setup

We are planning to try once more with the new release, hope it will  work this time.

Regards,

Sandeep

CHRISTIAN SCHREINER Mon, 10/22/2012 - 05:08

i am getting the exact same error while connecting to a secured CUCM.

i guess i am missing sth. in configuration of my CAPF profile.

.jar executable (connecting via JTAPI) with correct jtapi.ini in same working-dir and Certificates in separate Dir -> works fine.

.jsp in tomcat-6 with correct jtapi.ini in lib-directory and Certificates in separate Dir -> results in errormessage:

Unable to create provider -- User connected on an invalid port

Actions

This Discussion