Agent ReSkilling Tool Error

Unanswered Question
May 17th, 2010
User Badges:

Hi,


I am facing error while saving changes on agent re-skilling tool. I am unable to open the web interface (https://ServerIPAddress/reskill) and can do changes as well. But below mentioned error is coming when we press save button.


Unable to establish database connection for update operations. Make sure the Central Controller and Administration & WebView Reporting machines (Router, Logger and Distributor processes) are configured and running properly. If you have recently performed an upgrade, make sure configuration changes are turned back on in the Router registries. (Check the logs for more information. Logs are located on this Administration & WebView Reporting machine under /icm/tomcat/logs and /icm/tomcat/webapps/uiroot/WEB-INF/logs.)


Please advise I think its a common error.


Regards,

Hammad.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Gergely Szabo Mon, 05/17/2010 - 03:43
User Badges:
  • Green, 3000 points or more
  • Community Spotlight Award,

    Member's Choice, December 2015

Hi again, on the server where the agent reskilling tool is supposed to be installed, is there a windows service called Apache Tomcat with the following path to application: C:\icm\tomcat\bin\tomcat5.exe //RS//Tomcat5 ?

haouaswajih Tue, 01/15/2013 - 03:23
User Badges:

HI,


I faced the same issue a post from Kris Lambrechts helped me to solve it (https://supportforums.cisco.com/thread/2091364)


Couple of things to check :

  • Have a look through the Tomcat logs that it suggests just after you attempt a re-skill, you'll likely see a failure to conects to the ConAPI port of 2099;
  • Make sure your ConAPI and CMS_JServer process are running on this ADS, if not you need to enable them through Web Setup;
  • If they are running, one of the Windows is likely to say something along the lines of 'IPCCAdminClient down', if so, open CMS Control and make sure that you have an entry that is letter-for-letter identical to this one, also make sure you have no other entries that also use port 2099 !



Hope This Helps.



Actions

This Discussion