Cisco Unity 7 - Auto answer

Unanswered Question
May 17th, 2010

I have a office number that is getting regular calls that are "wrong numbers".

To combat this I plan to forward calls to 24000 to call Unity play a greeting of " Thank you for calling company X a receptionist will answer your call" then transfer to the shared line 30000, for a receptionist to pickup

The forward I have done using a CTI port.

How can I do the rest.

I don't want the Cisco woman saying please wait whilst I transfer your call.

Thanks for taking the time to read this post.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (5 ratings)
Brandon Buffin Mon, 05/17/2010 - 05:50

Create a call handler in Unity. Record your greeting and set the after greeting action on the Greeting page to "Send caller to:" Choose Call Handler from the drop down menu. Choose Select Call Handler. Choose your call handler and then "Attempt transfer for" from the drop down menu. On the Call Transfer page of the call handler, choose the destination to transfer calls and check the box that says "Do not play the "Wait while I transfer your call" prompt".

Hope this helps.


David Hailey Mon, 05/17/2010 - 05:52

1) I would use a CTI route point to forward calls to Unity - personal preference, it's just cleaner.  Up to you here.

2) You need to forward calls to a Call Handler and assign the primary extension as 24000 directly on the CH (my preference) or use a routing rule to associate that extension with the Call Handler.

3) Set up Cisco Unity Greetings Administrator and record the greeting for the Call Handler.

4) On the CH, you'll want the after-call action to be transfer to and then specify an extension - in your case, it would be 30000.

5) You can disable the "please wait" transfer notification on the Call Handler.  Callers won't hear that notification.


Please rate helpful posts!

martinbuffleo Mon, 05/17/2010 - 06:00

Thanks for the replys.

CTI is configured for 24000. Forward allways to voicemail.

I have then created a System call handler.

Active all hours Extension 24000

On greetings -> standard I have record my "welcome" message.

Set to ignore call input.

After greeting "user with mailbox" "reception" attempt transfer.

This appears to work but still get "wait whist I transfer your call"

I have enabled the "alternative" Transfer rule because I can modify the standard rule and disabled "wait whilst transfer" but yet she still speaks.

Brandon Buffin Mon, 05/17/2010 - 06:02

You would need to disable "Wait while I transfer your call. . ." on the Call Transfer page of the subscriber (reception) in instead of the call handler in this scenario.


martinbuffleo Mon, 05/17/2010 - 06:03

Sorry I was being silly on the standard rule I need ed to set it to transfer to extension.

martinbuffleo Mon, 05/17/2010 - 06:10

I don't think I have a full understanding of Unity,

I set the After greetng Call handler to itself.

I assumed that would make a loop.

How wrong was I.

Thanks for your help guys.

William Bell Mon, 05/17/2010 - 06:12

Just to clarify my original reply.  I am assuming two call handlers.  One that plays the greeting and one that does the transfer the way you want.  On the one that plays the greeting the "After Greeting" action would be the call handler that executes the transfer.  The "After Greeting" action on the "transferring" call handler is moot.



William Bell Mon, 05/17/2010 - 06:07

On the Call Handler in question, go to the Transfer Rule (Standard/Alternate/whatever).  Under the Transfer Action you will find the location where you placed your Extension (30000).  Ensure that the transfer type is "Release to Switch" and that "Play 'Wait while I transfer your call' prompt" is unchecked.

If, you have chosen an existing subscriber mailbox for the transfer (i.e. 30000 is a mailbox on the system).  You may want to check the Transfer Rules for that mailbox as well.



Please remember to rate helpful posts.


This Discussion