SR520 - ADSL over POTS - Config Help!

Unanswered Question
May 17th, 2010
User Badges:

Hi there,


I am new to the Cisco command line and IOS so please bear with me. I have a SR520 with ADSL over POTS. I am trying to get the connection with my ISP up and running but have got stuck. I think my "ATM0" looks ok as does my "Dialer0" but my Virtual-Access never changes from "Line protocol is down". I want to use it as a NON-NAT device to simply forward all packets to and from the device behind it.


I know I am nearly there ans I can see I have a sync'd speed from the DSL line. Please help.


----------------------------------------------------------------


Here is my current config:


Building configuration...


Current configuration : 1330 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lcih03-adsl
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$d5yJ$/xAP0kNpbLIoolkwWK0wa/
enable password ********
!
no aaa new-model
!
dot11 syslog
ip source-route
no ip routing
!
!
no ip cef
!
no ipv6 cef
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Dialer0
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname ******
ppp chap password ******
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
password *******
login
!
scheduler max-task-time 5000
end


---------------------------------------------------------------


here is my "sh ip int br":


Interface                  IP-Address      OK? Method Status                Prot
ocol
ATM0                       unassigned      YES NVRAM  up                    up


Dialer0                    unassigned      YES NVRAM  up                    up


FastEthernet0              unassigned      YES unset  up                    down


FastEthernet1              unassigned      YES unset  administratively down down


FastEthernet2              unassigned      YES unset  administratively down down


FastEthernet3              unassigned      YES unset  administratively down down


Virtual-Access1            unassigned      YES unset  up                    up


Virtual-Access2            unassigned      YES unset  up                    down


Vlan1                      unassigned      YES NVRAM  administratively down down


-----------------------------------------------------------------



Should I have two Virtual-Access interfaces? The second one is bound to the Dialer as shown here:


Dialer0 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using IPCP
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:34:16
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     0 packets output, 0 bytes
Bound to:
Virtual-Access2 is up, line protocol is down
  Hardware is Virtual Access interface
  MTU 1492 bytes, BW 971 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Listen
  PPPoATM vaccess, cloned from Dialer0
  Vaccess status 0x44
  Bound to ATM0 VCD: 1, VPI: 0, VCI: 38, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di0 (Encapsulation PPP)
  Last input 00:02:25, output never, output hang never
  Last clearing of "show interface" counters 00:33:19
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     90 packets input, 1116 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     488 packets output, 9982 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions


---------------------------------------------------------------


Regards,

Chris Snape (UK)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Snape Tue, 05/18/2010 - 01:38
User Badges:

Can anyone help please. I think and hope I have missed something obvious.


Regards,

Chris Snape (UK)

Chris Snape Tue, 05/18/2010 - 07:33
User Badges:

I figured it out!


ppp authentication chap CALLIN


"callin" - one word missing meant that both ends were trying to initialise the process.



Doh!



Regards,

Chris Snape (UK)

Actions

This Discussion