Routing issue on WAN

Answered Question
May 17th, 2010

I am currently working for a client and helping them redesign part of their network.  The client has a pretty nice network scheme in that they have their Headquarters connected to their Disaster Recovery site with an MPLS circuit, and then also a Frame Relay which was the legacy circuit prior to the MPLS.

Last week I configured a new Cisco Switch for them at the Disaster Recover site.  We are configuring a new WAN network with IP address 192.168.36.0.  I have a management address configured on the new switch of 192.168.36.5.  Currently this switch connects to the ASA which has an address of 192.168.36.1.  I have eigrp configured on the WAN switch.  When I check the ASA it shows that it has the network 192.168.36.0 directly connected.  From there is where everything seems strange.

I need for the Headquarters site to use the MPLS circuit to route to the new switch.  For whatever reason, the path is taking the Frame Relay network.  Eigrp is configured on most devices.  In some places, RIP is used.  I think EIGRP is distrubuted into RIP at some point.  What I do know is that I wish I could stop the network 192.168.36.0 from being advertised over the Frame so It would choose the MPLS circuit on the Headquarters side.

I made one change on the Headquarters side last week thinking that it would have the effect of forcing the route to traverse the MPLS circuit.  But instead what happened was the traceroute from headquarters to the 192.168.36.0 network showed the packet hit the Headquarters MPLS router, but instead of taking the MPLS over, the MPLS router then shipped the packet to the Frame router and sent it over the Frame Relay network.

Jon or Guiseppe if you get this I could really use your guys help!

I am including a diagram of the network...

Thanks

Kevin

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 6 years 8 months ago

Kevin

Thanks for this. Yes i missed that from your previous post and was actually thinking along those lines ie. it had not been advertised from the DR site under the BGP config.

The config is a bit confusing and i need to lab something up to test. I looked at the DR config and noticed there is no network statement under EIGRP for 192.168.36.0 hence when you redsitribute EIGRP into BGP it won't add that one. But then for some reason there is also a network statement under the address-family for 172.16.132.0/30 even though there is a network statement under EIGRP for that. Bit confusing.

However your solution is valid, it's just that with EIGRP redistribution you shouldn't need that network statement under the address-family. However if you didn't want EIGRP to start on that interface so it wasn't advertised out, possibly via the frame-relay network then your solution is a better one.

As for the loopback, how does the loopback appear in the routing table ie. if you do a "sh ip route" on the DR MPLS router does it show

192.168.38.1 255.255.255.255

or

192.168.38.0 255.255.255.0

Whatever it shows in the routing table must match your network statement so if it says 192.168.38.0 255.255.255.0 in the routing table the network statement needs to be -

network 192.168.38.0 mask 255.255.255.0

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Jon Marshall Mon, 05/17/2010 - 08:47

Kevin

Can you post as .jpg instead of .vsd.

When you do a "sh ip route" for that subnet on the HQ router where does it point to ?

Jon

Kevin Melton Mon, 05/17/2010 - 10:10

Jon

Did you mean the MPLS router or the Frame Router at HQ??

Also notice the ASA at Headquarters Network.  I placed a static route on it to ship the 192.168.36 network to the MPLS router.  But the MPLS router then ships it to the Frame router...

Jpg is attached Jon.

Thanks

Kevin

Jon Marshall Mon, 05/17/2010 - 11:14

Kevin

On the MPLS router at HQ can you post the output of -

1) sh ip route 192.168.36.0 255.255.255.0

2) sh ip eigrp topology 192.168.36.0/24  <-- note this may not be exact syntax but you should be able to work it out

Jon

Kevin Melton Mon, 05/17/2010 - 11:47

GAMPLSRTR01#sh ip route 192.168.36.0 255.255.255.0
Routing entry for 192.168.36.0/24
  Known via "eigrp 13", distance 90, metric 5259264, type internal
  Redistributing via eigrp 13
  Last update from 192.168.15.4 on GigabitEthernet0/0, 4d04h ago
  Routing Descriptor Blocks:
  * 192.168.15.4, from 192.168.15.4, 4d04h ago, via GigabitEthernet0/0
      Route metric is 5259264, traffic share count is 1
      Total delay is 10130 microseconds, minimum bandwidth is 512 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 6/255, Hops 4

GAMPLSRTR01#sho ip eigrp topo 192.168.36.0/24
IP-EIGRP (AS 13): Topology entry for 192.168.36.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 5259264
  Routing Descriptor Blocks:
  192.168.15.4 (GigabitEthernet0/0), from 192.168.15.4, Send flag is 0x0
      Composite metric is (5259264/5259008), Route is Internal
      Vector metric:
        Minimum bandwidth is 512 Kbit
        Total delay is 10130 microseconds
        Reliability is 255/255
        Load is 6/255
        Minimum MTU is 1500
        Hop count is 4

15.4 is the address of the Frame Router Jon

thx

Jon Marshall Mon, 05/17/2010 - 12:13

Kevin

How is routing working across the MPLS cloud ? Are you exchanging EIGRP routes directly over the MPLS cloud or is BGP involved somewhere.

Can you -

1) verify that the router in the DR site that connects to the MPLS cloud has a route for 192.168.36.0/24

2) How do your MPLS routers exhange routes between each other

Jon

Kevin Melton Mon, 05/17/2010 - 12:33

1)  he does.. here is the output:

Routing entry for 192.168.36.0/24
  Known via "eigrp 13", distance 90, metric 3328, type internal
  Redistributing via eigrp 13, bgp 65002
  Last update from 172.16.132.9 on GigabitEthernet0/0, 4d05h ago
  Routing Descriptor Blocks:
  * 172.16.132.9, from 172.16.132.9, 4d05h ago, via GigabitEthernet0/0
      Route metric is 3328, traffic share count is 1
      Total delay is 30 microseconds, minimum bandwidth is 1000000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

2) Let me send you what I think are the relevant parts of the config and you can see how they are exchanging the routes:

Looks to me like bgp and eigrp:

Headquarters:

router rip
version 2
redistribute bgp 65001 metric 2 route-map bgp-rip-rm
passive-interface default
no passive-interface GigabitEthernet0/0
network 192.168.15.0
neighbor 192.168.15.1
neighbor 192.168.15.5
neighbor 192.168.15.4
distribute-list RIP-FILTER in
no auto-summary
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 0.0.0.0
network 172.31.100.0 mask 255.255.255.0
network 192.168.5.0
network 192.168.15.0
redistribute static metric 30 route-map static-bgp-rm
neighbor 12.115.94.169 remote-as 7018
neighbor 12.115.94.169 send-community
neighbor 12.115.94.169 soft-reconfiguration inbound
no auto-summary

Disaster Recovery Site:

router eigrp 13
redistribute bgp 65002 metric 3000 20 100 255 1500 route-map bgp-eigrp-rm
passive-interface default
no passive-interface GigabitEthernet0/0
network 172.16.132.8 0.0.0.3
network 172.31.0.0
no auto-summary
!
router bgp 65002
bgp log-neighbor-changes
neighbor 12.115.94.165 remote-as 7018
neighbor 12.115.94.165 timers 60 180
!
address-family ipv4
  redistribute eigrp 13 metric 100 route-map eigrp-bgp-rm
  neighbor 12.115.94.165 activate
  no auto-summary
  no synchronization
  network 172.16.132.8 mask 255.255.255.252
  network 172.31.200.0 mask 255.255.255.0
  network 192.168.105.0
exit-address-family

I am not sure why but it does not seem like the DR router on the MPLs could is advertising the route to 192.168.36.0.  I tried adding the route to the access-list called eigrp-bgp-rm but so far the MPLS router at Headquarters is still getting its route from the Frame...

Thanks Jon

Kevin

Jon Marshall Mon, 05/17/2010 - 13:34

Kevin

You are redsitributing BGP into EIGRP at HQ. So the HQ router receives a BGP route for 192.168.36.0/24 and redistributes it into EIGRP. This is now an external EIGRP route with an AD of 170. But you are also receiving the same EIGRP route via the frame-relay network but that is an internal EIGRP route with an AD of 90 so that route will be preferred over the EIGRP external route.

In fact with the setup you have i would expect all EIGRP routes to go via the frame-relay network. Can you confirm this is the case ?

Jon

Kevin Melton Mon, 05/17/2010 - 13:51

Actually Jon most use the MPLS.  Here is the routing table from the HQ MPLS router:

GAMPLSRTR01#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.15.1 to network 0.0.0.0

D    192.168.12.0/24 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D    200.100.4.0/24 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
B    192.168.104.0/24 [20/0] via 12.115.94.169, 3w2d
B    192.168.31.0/24 [20/0] via 12.115.94.169, 3w2d
     138.39.0.0/24 is subnetted, 3 subnets
D EX    138.39.73.0 [115/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D EX    138.39.72.0 [115/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       138.39.86.0 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
B    192.168.105.0/24 [20/0] via 12.115.94.169, 3w2d
     192.168.15.0/24 is variably subnetted, 2 subnets, 2 masks
S       192.168.15.51/32 is directly connected, Analysis-Module1/0
C       192.168.15.0/24 is directly connected, GigabitEthernet0/0
D    192.168.25.0/24 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D    192.168.9.0/24 [90/5768192] via 192.168.15.4, 4d23h, GigabitEthernet0/0
     192.168.10.0/30 is subnetted, 16 subnets
D       192.168.10.64 [90/5256192] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.68
           [90/20512256] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.32
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.36
           [90/46226432] via 192.168.15.4, 3d14h, GigabitEthernet0/0
D       192.168.10.40
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.44
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.52
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.60
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.0 [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.4 [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.8 [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.12
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.16
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.20
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.24
           [90/46226432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.10.28
           [90/46226432] via 192.168.15.4, 2d13h, GigabitEthernet0/0
D EX 172.17.0.0/16 [115/5793792] via 192.168.15.4, 2d19h, GigabitEthernet0/0
     172.16.0.0/16 is variably subnetted, 12 subnets, 3 masks
D       172.16.144.4/30
           [90/20514816] via 192.168.15.4, 4d23h, GigabitEthernet0/0
B       172.16.132.8/30 [20/0] via 12.115.94.169, 3w2d
B       172.16.132.12/30 [20/0] via 12.115.94.169, 3w2d
B       172.16.132.0/29 [20/0] via 12.115.94.169, 3w2d
B       172.16.133.0/24 [20/0] via 12.115.94.169, 3w2d
B       172.16.44.0/24 [20/0] via 12.115.94.169, 2d19h
B       172.16.45.0/24 [20/0] via 12.115.94.169, 2d19h
B       172.16.47.0/24 [20/0] via 12.115.94.169, 2d19h
D       172.16.43.0/24
           [90/46228992] via 192.168.15.4, 4d23h, GigabitEthernet0/0
B       172.16.32.0/24 [20/0] via 12.115.94.169, 3w2d
B       172.16.33.0/24 [20/0] via 12.115.94.169, 3w2d
D       172.16.34.0/24
           [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
     172.21.0.0/24 is subnetted, 1 subnets
D EX    172.21.1.0 [115/5793792] via 192.168.15.4, 2d19h, GigabitEthernet0/0
     172.27.0.0/28 is subnetted, 2 subnets
B       172.27.5.32 [20/0] via 12.115.94.169, 2d19h
B       172.27.4.32 [20/0] via 12.115.94.169, 3w2d
     172.31.0.0/24 is subnetted, 2 subnets
B       172.31.200.0 [20/0] via 12.115.94.169, 3w2d
C       172.31.100.0 is directly connected, Loopback0
S    192.168.11.0/24 [1/0] via 192.168.15.5
D    192.168.41.0/24 [90/20515072] via 192.168.15.4, 4d23h, GigabitEthernet0/0
S    192.168.176.0/24 [1/0] via 192.168.15.1
     192.168.251.0/32 is subnetted, 3 subnets
D       192.168.251.254 [90/130816] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.251.253 [90/130816] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.251.38
           [90/5896192] via 192.168.15.4, 3d14h, GigabitEthernet0/0
D    192.168.200.0/24 [90/5793792] via 192.168.15.4, 2d19h, GigabitEthernet0/0
D    192.6.21.0/24 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D    192.168.38.0/24
           [90/5387264] via 192.168.15.4, 00:04:43, GigabitEthernet0/0
S    192.168.4.0/24 [1/0] via 192.168.15.1
D    192.168.21.0/24 [90/5770752] via 192.168.15.4, 4d23h, GigabitEthernet0/0
     192.168.250.0/24 is variably subnetted, 33 subnets, 2 masks
D       192.168.250.152/32
           [90/46354432] via 192.168.15.4, 3d14h, GigabitEthernet0/0
D       192.168.250.166/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.250/32
           [90/130816] via 192.168.15.4, 7w0d, GigabitEthernet0/0
D       192.168.250.251/32
           [90/5386752] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.252/30
           [90/130816] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.16/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.20/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.24/30
           [90/53346304] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.28/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.4/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.8/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.12/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.52/30
           [90/46482432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.56/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.32/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.36/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.40/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.44/30
           [90/54613504] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.64/30
           [90/46994432] via 192.168.15.5, 7w0d, GigabitEthernet0/0
D       192.168.250.114/32
           [90/5384192] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.115/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.112/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.116/32
           [90/20640256] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.102/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.103/32
           [90/46354432] via 192.168.15.4, 1d11h, GigabitEthernet0/0
D       192.168.250.106/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.107/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.104/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.105/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.110/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.111/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       192.168.250.108/32
           [90/46354432] via 192.168.15.4, 2d19h, GigabitEthernet0/0
D       192.168.250.109/32
           [90/46354432] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D    194.49.37.0/24 [90/5793792] via 192.168.15.4, 3d14h, GigabitEthernet0/0
C    192.168.5.0/24 is directly connected, GigabitEthernet0/1
     10.0.0.0/24 is subnetted, 9 subnets
D       10.20.31.0 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
S       10.254.242.0 [1/0] via 192.168.15.1
S       10.254.243.0 [1/0] via 192.168.15.1
S       10.254.252.0 [1/0] via 192.168.15.1
S       10.254.254.0 [1/0] via 192.168.15.1
D       10.10.20.0 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
D       10.49.39.0 [90/5793792] via 192.168.15.4, 03:10:53, GigabitEthernet0/0
D       10.49.36.0 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
B       10.254.32.0 [20/0] via 12.115.94.169, 5d03h
B    192.168.36.0/24 [20/0] via 12.115.94.169, 00:50:26
S    192.168.7.0/24 [1/0] via 192.168.15.1
B    192.168.34.0/24 [20/0] via 12.115.94.169, 3w2d
D    192.168.0.0/24 [90/5793792] via 192.168.15.4, 4d23h, GigabitEthernet0/0
     12.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
B       12.113.82.104/30 [20/0] via 12.115.94.169, 2d19h
B       12.38.168.0/24 [20/0] via 12.115.94.169, 3w2d
B       12.115.94.164/30 [20/0] via 12.115.94.169, 3w2d
C       12.115.94.169/32 is directly connected, Multilink1
C       12.115.94.168/30 is directly connected, Multilink1
B    192.168.102.0/24 [20/0] via 12.115.94.169, 3w2d
S    192.168.254.0/24 [1/0] via 192.168.15.1
     207.239.121.0/32 is subnetted, 2 subnets
S       207.239.121.3 [1/0] via 192.168.15.1
S       207.239.121.2 [1/0] via 192.168.15.1
     192.168.16.0/30 is subnetted, 1 subnets
D       192.168.16.0 [90/294656] via 192.168.15.5, 7w0d, GigabitEthernet0/0
                     [90/294656] via 192.168.15.4, 7w0d, GigabitEthernet0/0
S    192.168.1.0/24 [1/0] via 192.168.15.1
B    192.168.103.0/24 [20/0] via 12.115.94.169, 3w2d
     192.168.253.0/32 is subnetted, 1 subnets
S       192.168.253.5 [1/0] via 192.168.15.1
S    192.168.2.0/24 [1/0] via 192.168.15.1
B    192.168.32.0/24 [20/0] via 12.115.94.169, 3w2d
B    192.168.154.0/24 [20/0] via 12.115.94.169, 5d03h
     135.89.0.0/16 is variably subnetted, 4 subnets, 2 masks
B       135.89.152.56/29 [20/0] via 12.115.94.169, 3w1d
B       135.89.152.128/28 [20/0] via 12.115.94.169, 3w1d
B       135.89.154.152/29 [20/0] via 12.115.94.169, 3w2d
B       135.89.157.160/28 [20/0] via 12.115.94.169, 3w2d
S    192.168.3.0/24 [1/0] via 192.168.15.1
B    192.168.33.0/24 [20/0] via 12.115.94.169, 3w2d
B    192.168.101.0/24 [20/0] via 12.115.94.169, 3w2d
S*   0.0.0.0/0 [1/0] via 192.168.15.1
GAMPLSRTR01#

All of our disaster recovery networks are learned from the 12.115.94.169 address which is the DR MPLS router...

Kevin

Jon Marshall Mon, 05/17/2010 - 14:00

Kevin

Just to make things clearer -

pick a DR network that is advertised by EIGRP to HQ and then do a "sh ip route" for it on the HQ router.

Also for a DR network that is routed via MPLS does it actually get advertised by EIGRP via the frame-relay network ?

If you look at the routing table all your EIGRP networks are pointing to either 192.168.15.4 or 192.168.15.5 (what is .5 ?).

Jon

Kevin Melton Tue, 05/18/2010 - 10:01

Jon

To answer your questions

pick a DR network that is advertised by EIGRP to HQ and then do a "sh ip route" for it on the HQ router.

I am picking the DR network 192.168.101.0/24.

Routing entry for 192.168.101.0/24
  Known via "bgp 65001", distance 20, metric 0
  Tag 7018, type external
  Redistributing via eigrp 13, rip
  Advertised by eigrp 13 metric 10000 100 255 1 1500
                rip metric 2 route-map bgp-rip-rm
  Last update from 12.115.94.169 3w3d ago
  Routing Descriptor Blocks:
  * 12.115.94.169, from 12.115.94.169, 3w3d ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 7018

Also for a DR network that is routed via MPLS does it actually get advertised by EIGRP via the frame-relay network ?

we want it to be in case of failure of the MPLS network and vice versa

If you look at the routing table all your EIGRP networks are pointing to either 192.168.15.4 or 192.168.15.5 (what is .5 ?).

I can see where you are correct about the EIGRP.  But I also think that what we see is that BGP is advertising most of the DR site routes, and I think we saw yesterday on the MPLS router on the DR side that EIGRP is distributed into BGP for delivery across the MPLS cloud to the HQ site.  Is this correct?

The 15.5 address is our ISDN backup for the Frame Relay.  All of our member sites are connected via Frame (remote areas) and have ISDN backup as well.

NOTE:

I added the network 192.168.36.0/24 to the following yesterday on the DR site MPLS router.  See below:

router bgp 65002
bgp log-neighbor-changes
neighbor 12.115.94.165 remote-as 7018
neighbor 12.115.94.165 timers 60 180
!
address-family ipv4
  redistribute eigrp 13 metric 100 route-map eigrp-bgp-rm
  neighbor 12.115.94.165 activate
  no auto-summary
  no synchronization
  network 172.16.132.8 mask 255.255.255.252
  network 172.31.200.0 mask 255.255.255.0
  network 192.168.36.0
  network 192.168.38.1 mask 255.255.255.255
  network 192.168.105.0
exit-address-family

Please notice that I also added the 192.168.38.1 address to the "address-family ipv4" component of the bgp configuration.  192.168.38.X was what I want to use for loopback addresses at the DR site.  For some reason, though, I cannot get to 38.1 which is the loopback configured on the switch.

I saw the 36 network advertised across the MPLS once I added the network in this configuration , but I cannot get it to work for the 38.1 network.

let me know what you think Jon (as always)

Kevin

15.5 is our ISDN backup router.  this was the backup to the Frame prior to MPLS being implemented.

Jon Marshall Tue, 05/18/2010 - 10:11

Kevin

Also for a DR network that is routed via MPLS does it actually get advertised by EIGRP via the frame-relay network ?

we want it to be in case of failure of the MPLS network and vice versa

That's the thing though. Because you are redistributing BGP into EIGRP then the EIGRP routes will always be AD 170 and if you then advertise the same routes from DR to HQ via the frame-relay network they will AD 90 and will always be preferred. Reason i asked you to check a route was to make sure nothing else was happening.

So is it safe to assume that an network advertised via the MPLS cloud and redistributed into EIGRP is not being advertised via the frame-relay network as well. And if it is being advertised by the frame-relay network that it is going that way rather than via the MPLS cloud.

Is the frame-relay network only meant to act as a backup to the MPLS network or is it doing something else as well. I ask as you have quite a few routes on the HQ MPLS router that point to the frame-relay router so it looks like both MPLS and frame are being used.

I need to understand because we are dealing with one specific subnet but don't want to make changes that could break other things.

Jon

Kevin Melton Tue, 05/18/2010 - 10:26

I think the one quesiton I can answer correctly from the last exchange is this:

Is the frame-relay network only meant to act as a backup to the MPLS network or is it doing something else as well? I ask as you have quite a few routes on the HQ MPLS router that point to the frame-relay router so it looks like both MPLS and frame are being used.

Answer is that both are being used. The Frame Relay network is the PRIMARY network that allows our member sites to connect to us at HQ and at the DR site.  There is no Member site that is using MPLS (most are in rural locations in Virginia and do not have the facilities for MPLS yet).

As far as communication between HQ and DR, we prefer the MPLS due to the speed and bandwidth associated with it.  The Frame connections are mostly 128 or 256 or so, whereas the MPLS circuit is 3 MG (2 T1's bundled into multilink on each of the 3800 series MPLS routers at HQ and DR.

Thanks

Kevin

Jon Marshall Tue, 05/18/2010 - 10:32

k-melton wrote:

I think the one quesiton I can answer correctly from the last exchange is this:

Is the frame-relay network only meant to act as a backup to the MPLS network or is it doing something else as well? I ask as you have quite a few routes on the HQ MPLS router that point to the frame-relay router so it looks like both MPLS and frame are being used.

Answer is that both are being used. The Frame Relay network is the PRIMARY network that allows our member sites to connect to us at HQ and at the DR site.  There is no Member site that is using MPLS (most are in rural locations in Virginia and do not have the facilities for MPLS yet).

As far as communication between HQ and DR, we prefer the MPLS due to the speed and bandwidth associated with it.  The Frame connections are mostly 128 or 256 or so, whereas the MPLS circuit is 3 MG (2 T1's bundled into multilink on each of the 3800 series MPLS routers at HQ and DR.

Thanks

Kevin

Makes sense.

Could you see last post i did where i asked for some outputs.

There are a number of things we can do to get this working (always is more than one way !) but i'm not sure why your HQ router is not seeing the BGP route or if it is why it is not choosing it.

Jon

Jon Marshall Tue, 05/18/2010 - 10:19

Kevin

Actually something has just occured to me. The redistributed routes at AD 170 will apply within HQ but on the HQ router the BGP route should take precedence. Can you post the output of "sh ip bgp" on the HQ MPLS router and also can you post the BGP config from the DR MPLS router.

Jon

Kevin Melton Tue, 05/18/2010 - 13:16

Jon

here is the "sho ip bgp" from HQ router

GAMPLSRTR01#sho ip bgp
BGP table version is 866, local router ID is 172.31.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.15.1             0         32768 i
*> 10.254.32.0/24   12.115.94.169                          0 7018 65002 ?
*> 10.254.242.0/24  192.168.15.1            30         32768 ?
*> 10.254.243.0/24  192.168.15.1            30         32768 ?
*> 10.254.252.0/24  192.168.15.1            30         32768 ?
*> 10.254.254.0/24  192.168.15.1            30         32768 ?
*> 12.38.168.0/24   12.115.94.169                          0 7018 2386 i
*> 12.113.82.104/30 12.115.94.169            0             0 7018 ?
*> 12.115.94.164/30 12.115.94.169            0             0 7018 ?
r> 12.115.94.168/30 12.115.94.169            0             0 7018 ?
*> 135.89.152.56/29 12.115.94.169                          0 7018 2386 i
*> 135.89.152.128/28
                    12.115.94.169                          0 7018 2386 i
*> 135.89.154.152/29
                    12.115.94.169                          0 7018 2386 i
*> 135.89.157.160/28
                    12.115.94.169                          0 7018 2386 i
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.32.0/24   12.115.94.169                          0 7018 65002 ?
*> 172.16.33.0/24   12.115.94.169                          0 7018 65002 ?
*> 172.16.44.0/24   12.115.94.169                          0 7018 65002 i
*> 172.16.45.0/24   12.115.94.169                          0 7018 65002 i
*> 172.16.47.0/24   12.115.94.169                          0 7018 65002 i
*> 172.16.132.0/29  12.115.94.169                          0 7018 65002 ?
*> 172.16.132.8/30  12.115.94.169                          0 7018 65002 i
*> 172.16.132.12/30 12.115.94.169                          0 7018 65002 ?
*> 172.16.133.0/24  12.115.94.169                          0 7018 65002 ?
*> 172.27.4.32/28   12.115.94.169                          0 7018 65002 ?
*> 172.27.5.32/28   12.115.94.169                          0 7018 65002 i
*> 172.31.100.0/24  0.0.0.0                  0         32768 i
*> 172.31.200.0/24  12.115.94.169                          0 7018 65002 i
*> 192.168.1.0      192.168.15.1            30         32768 ?
*> 192.168.2.0      192.168.15.1            30         32768 ?
*> 192.168.3.0      192.168.15.1            30         32768 ?
*> 192.168.4.0      192.168.15.1            30         32768 ?
*> 192.168.5.0      0.0.0.0                  0         32768 i
*> 192.168.7.0      192.168.15.1            30         32768 ?
*> 192.168.11.0     192.168.15.5            30         32768 ?
*> 192.168.15.0     0.0.0.0                  0         32768 i
*> 192.168.31.0     12.115.94.169                          0 7018 65002 ?
   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.32.0     12.115.94.169                          0 7018 65002 ?
*> 192.168.33.0     12.115.94.169                          0 7018 65002 ?
*> 192.168.34.0     12.115.94.169                          0 7018 65002 ?
*> 192.168.36.0     12.115.94.169                          0 7018 65002 i
*> 192.168.101.0    12.115.94.169                          0 7018 65002 ?
*> 192.168.102.0    12.115.94.169                          0 7018 65002 ?
*> 192.168.103.0    12.115.94.169                          0 7018 65002 ?
*> 192.168.104.0    12.115.94.169                          0 7018 65002 ?
*> 192.168.105.0    12.115.94.169                          0 7018 65002 i
*> 192.168.154.0    12.115.94.169                          0 7018 65002 ?
*> 192.168.176.0    192.168.15.1            30         32768 ?
*> 192.168.253.5/32 192.168.15.1            30         32768 ?
*> 192.168.254.0    192.168.15.1            30         32768 ?
GAMPLSRTR01#
Here is the bgp config from the DR site router

router bgp 65002
bgp log-neighbor-changes
neighbor 12.115.94.165 remote-as 7018
neighbor 12.115.94.165 timers 60 180
!
address-family ipv4
  redistribute eigrp 13 metric 100 route-map eigrp-bgp-rm
  neighbor 12.115.94.165 activate
  no auto-summary
  no synchronization
  network 172.16.132.8 mask 255.255.255.252
  network 172.31.200.0 mask 255.255.255.0
  network 192.168.36.0
  network 192.168.38.1 mask 255.255.255.255
  network 192.168.105.0
exit-address-family

Perhaps you didnt see it but i had posted a couple of posts ago that I have at least "band-aided" the issue by adding the 192.168.36.0 network to the "address-family ipv4 subheading under the bgp configuration.  Prior to adding the network there it was not being advertised across the MPLS from DR to HQ.  Once the 36 network was added there it showed up, and now routes properly.  I am still having trouble with the Loopback network though (192.168.38.1/32) configured on the new switch at DR site.

Thanks!

Correct Answer
Jon Marshall Tue, 05/18/2010 - 13:28

Kevin

Thanks for this. Yes i missed that from your previous post and was actually thinking along those lines ie. it had not been advertised from the DR site under the BGP config.

The config is a bit confusing and i need to lab something up to test. I looked at the DR config and noticed there is no network statement under EIGRP for 192.168.36.0 hence when you redsitribute EIGRP into BGP it won't add that one. But then for some reason there is also a network statement under the address-family for 172.16.132.0/30 even though there is a network statement under EIGRP for that. Bit confusing.

However your solution is valid, it's just that with EIGRP redistribution you shouldn't need that network statement under the address-family. However if you didn't want EIGRP to start on that interface so it wasn't advertised out, possibly via the frame-relay network then your solution is a better one.

As for the loopback, how does the loopback appear in the routing table ie. if you do a "sh ip route" on the DR MPLS router does it show

192.168.38.1 255.255.255.255

or

192.168.38.0 255.255.255.0

Whatever it shows in the routing table must match your network statement so if it says 192.168.38.0 255.255.255.0 in the routing table the network statement needs to be -

network 192.168.38.0 mask 255.255.255.0

Jon

Kevin Melton Wed, 05/19/2010 - 05:27

Jon

Regarding the loopback address, you were correct about the network statement.  I had formerly used 192.168.38.1/32, but the DR router had it in its routing table as 192.168.38.0/24.  So I changed the statement in the bgp config under "address family ipv4" to be 192.168.38.0 vs. 192.168.38.1/32.  Once this change was made, then the MPLS router at HQ was receiving the update.

Funny thing is, at least on the network I am using at HQ, if I do a traceroute from a workstation at 192.168.7.0 (this network is the user network off of our Core Sw at HQ), the traceroute still takes me over the frame.  I will have to look at this a little closer.

Thanks and hope you are well

Kevin

Jon Marshall Wed, 05/19/2010 - 06:54

Kevin

Funny thing is, at least on the network I am using at HQ, if I do a traceroute from a workstation at 192.168.7.0 (this network is the user network off of our Core Sw at HQ), the traceroute still takes me over the frame.  I will have to look at this a little closer.

It will if you are advertising the same DR network both over the MPLS network and over the frame-relay network. Only on the MPLS HQ router will the BGP route take preference. Once the route has been redistributed into EIGRP it will have an AD of 170. This is fine but if the same route is advertised over the frame-relay network it will have AD of 90 because there is no redistribution going on.

This is what i meant when i said if you advertise the same DR route via MPLS and frame-relay it will always take the frame-relay route.

Jon

Actions

This Discussion