Can not login into Catalyst 2900 Series XL Switch

Unanswered Question
May 17th, 2010
User Badges:

I cannot login remotely with HyperTerminal or an internet browser to my Catalyst 2912 Series XL switch.  Any ideas?   I can get to the login screen in HyperTerminal .. but it will not accept my password.   I I tried HTTP using my web browser and I can't even get to the login screen --- I get an error message "Cannot download the information you requested".


What is the problem?  I tried power cycling the switch ... that did NOT solve the problem.  How can I logon and how can this be fixed?   Any ideas?


Thanks,

Gregg

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Mon, 05/17/2010 - 11:01
User Badges:
  • Red, 2250 points or more

Hi Gregg


You need to have HTTP services enabled to get onto the switch using the web browser.


Also make sure you have local username and password configured with privilege level 15 to access and start doing administration of your device.


For telnet access you need to have passwords under your line configs so that it can allow your telnet access.


Hyperterm access - are you talking about connection using serial port or using ip address ?


regds

greggsmithjr Mon, 05/17/2010 - 14:43
User Badges:

I was talking about HyperTerminal access using the IP address.   What I don't understand, is that it worked fine with HTTP or HyperTerminal access for a long time ... now it's not working and I've changed nothing.  Rebooting the 2900 switch did not fix it.


Let me know your thoughts.  What did you mean about about telnet access needing to have passwords under your line configs so that it can allow your telnet access?

Thanks,

Gregg

Jon Marshall Mon, 05/17/2010 - 14:46
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Gregg


To telnet into a switch you need to add a password under the vty lines ie.


switch(config)# line vty 0 4

switch(config-line)# password 0


If you cannot get into the switch remotely you are going to need to use the console cable and log into the switch that way then do a password recovery so you can access the switch.


Jon

Leo Laohoo Mon, 05/17/2010 - 17:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Sounds like your switch could be dead/dying.  Can you console into the switch and power reboot it?  I'm curious to know if there are any clues during the bootup and POST process.

Actions

This Discussion