AP 1252 Trunking Multiple VLANs

Unanswered Question
May 17th, 2010
User Badges:

Hey guys, I'm trying to set up a standalone access point (1252) with a few vlans and a trunk going to a 2960 switch.


I've also got my ssids attached to vlans, a radio sub-interface and gig sub-interface for each vlan, and a trunk going from the gigabit interface on the AP to my 2960


My problem is that I have no connectivity between associated clients on the AP, or between the AP (BVI1 interface) and a hard wired client on the 2960.


Here are the relevent portions of my running-config


dot11 vlan-name Houston vlan 11
dot11 vlan-name IT vlan 7
dot11 vlan-name nuaWireless vlan 70
!
dot11 ssid Houston
   vlan 11
   authentication open
   authentication key-management wpa version 1
   mbssid guest-mode
   wpa-psk ascii 7 0208115A59081A201E
!
dot11 ssid IT
   vlan 7
   authentication open
   authentication key-management wpa version 1
   guest-mode
   mbssid guest-mode
   wpa-psk ascii 7 0208115A58081A201F
!
dot11 ssid nuaWireless
   vlan 70
   authentication open
   authentication key-management wpa version 1
   mbssid guest-mode
   wpa-psk ascii 7 0701344D1F070C0446
!


interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers tkip
!
encryption vlan 70 mode ciphers tkip
!
encryption vlan 11 mode ciphers tkip
!
encryption vlan 7 mode ciphers tkip
!
ssid Houston
!
ssid IT
!
ssid nuaWireless
!
mbssid
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.7
encapsulation dot1Q 7
no ip route-cache
bridge-group 7
bridge-group 7 subscriber-loop-control
bridge-group 7 block-unknown-source
no bridge-group 7 source-learning
no bridge-group 7 unicast-flooding
bridge-group 7 spanning-disabled
!
interface Dot11Radio0.11
encapsulation dot1Q 11
no ip route-cache
bridge-group 11
bridge-group 11 subscriber-loop-control
bridge-group 11 block-unknown-source
no bridge-group 11 source-learning
no bridge-group 11 unicast-flooding
bridge-group 11 spanning-disabled
!
interface Dot11Radio0.70
encapsulation dot1Q 70
no ip route-cache
bridge-group 70
bridge-group 70 subscriber-loop-control
bridge-group 70 block-unknown-source
no bridge-group 70 source-learning
no bridge-group 70 unicast-flooding
bridge-group 70 spanning-disabled
!


interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.7
encapsulation dot1Q 7
no ip route-cache
bridge-group 7
no bridge-group 7 source-learning
bridge-group 7 spanning-disabled
!
interface GigabitEthernet0.11
encapsulation dot1Q 11
no ip route-cache
bridge-group 11
no bridge-group 11 source-learning
bridge-group 11 spanning-disabled
!
interface GigabitEthernet0.70
encapsulation dot1Q 70
no ip route-cache
bridge-group 70
no bridge-group 70 source-learning
bridge-group 70 spanning-disabled
!
interface BVI1
ip address 10.7.1.200 255.255.0.0
no ip route-cache
!


Any help would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dancampb Mon, 05/17/2010 - 12:38
User Badges:
  • Cisco Employee,

The section of the config you posted looks fine.  I assume that 10.7.1.200 is in the subnet for VLAN1?  What does the switchport config look like?

Lucas Phelps Mon, 05/17/2010 - 16:04
User Badges:

What vlan is your 'wired' client on and what IP address/subnet?

Actions

This Discussion