Cisco BRAS 7206 vxr problem.

Answered Question
May 18th, 2010

PPPoE BRAS: Cisco 7206 vxr.

VOIP gateways: Micronet SP5002

We have a periodic problems with pppoe connection from multiple Micronet voip gateways to Cisco BRAS.

The problem appears when Cisco 7206vxr is up about 20 days. But in the same time, pppoe connection passes with the same login from Windows XP.

After reboot Cisco 7206vxr, Micronet gateways connect to Cisco by pppoe.

I can't determine problem, because micronet voip gateways is in the different vlans, and they are get down synchronously.

I made wireshark dumps:

38    70.452619    Micronet_04:70:7b    Broadcast    PPPoED    Active Discovery Initiation (PADI)

39    70.471507    Cisco_64:06:1a    Micronet_04:70:7b    PPPoED    Active Discovery Offer (PADO) AC-Name='Router_PPPoE'

40    70.472433    Micronet_04:70:7b    Cisco_64:06:1a    PPPoED    Active Discovery Request (PADR) AC-Name='Router_PPPoE'

41    70.491187    Cisco_64:06:1a    Micronet_04:70:7b    PPPoED    Active Discovery Session-confirmation (PADS) AC-Name='Router_PPPoE'

42    70.501079    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Request

43    70.514853    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

44    70.514861    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Ack

45    70.516765    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Nak

47    72.504574    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

48    72.506177    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Nak

50    73.497205    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Request

51    73.512713    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Ack

52    74.520646    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

53    74.522356    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Nak

55    76.497523    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Request

56    76.512830    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Ack

57    76.536470    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

58    76.538138    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Nak

60    78.552634    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

61    78.554239    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Nak

63    79.497819    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Request

64    79.513658    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Ack

65    80.568411    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

66    80.570102    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Reject

68    82.498164    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Request

69    82.515001    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Ack

70    82.584484    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

71    82.586212    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Reject

72    82.602230    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

73    82.604031    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Configuration Reject

74    82.619716    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Configuration Request

88    82.755757    Cisco_64:06:1a    Micronet_04:70:7b    PPP LCP    Termination Request

89    82.756870    Micronet_04:70:7b    Cisco_64:06:1a    PPP LCP    Termination Ack

90    82.772974    Cisco_64:06:1a    Micronet_04:70:7b    PPPoED    Active Discovery Terminate (PADT)

-------------------------------

Cisco config:

Current configuration : 12976 bytes
!
! Last configuration change at 16:14:26 KGST Tue May 18 2010 by tuxper
! NVRAM config last updated at 16:25:21 KGST Tue May 18 2010 by tuxper
!
version 12.2
service timestamps debug uptime
service timestamps log datetime msec localtime
service password-encryption
service counters max age 5
!
hostname Router_PPPoE
!
boot-start-marker
boot system disk2:c7200-advipservicesk9-mz.122-33.SRD4.bin
boot-end-marker
!
logging buffered 64000
no logging console
enable password 7 071D294A4D101F1F1E140C061C382D74716B
!
aaa new-model

!
!
aaa group server radius PPPOE-RADIUS-SERVER
server-private xxx.x.x.x auth-port 3812 acct-port 3813 key 7 yyyyyyyyy
!
aaa group server radius ISG-RADIUS-SERVER
server-private xx.x.x.x auth-port 4812 acct-port 4813 key 7 yyyyyyyyyy
!
aaa group server radius CISCO-AAA-SERVER
server-private xxx.x.x.x auth-port 2812 acct-port 2813 key 7 yyyyyyyyyyyyyy
!
aaa group server tacacs+ ACCT-TACACS-SERVER
server-private xx.x.x.x key 7 yyyyyyyyyyyyyyyyy
!
aaa authentication login default local group CISCO-AAA-SERVER
aaa authentication enable default group CISCO-AAA-SERVER enable
aaa authentication ppp PPPoE group PPPOE-RADIUS-SERVER
aaa authorization network PPPoE group PPPOE-RADIUS-SERVER
aaa authorization subscriber-service default local group ISG-RADIUS-SERVER
aaa accounting update periodic 1440
aaa accounting exec default start-stop group CISCO-AAA-SERVER
aaa accounting commands 1 default stop-only group ACCT-TACACS-SERVER
aaa accounting commands 15 default stop-only group ACCT-TACACS-SERVER
aaa accounting network PPPoE start-stop group PPPOE-RADIUS-SERVER
aaa accounting network ISG start-stop group ISG-RADIUS-SERVER
!
!
!
!
aaa server radius dynamic-author
client xxx.x.x.x server-key 7 yyyyyyyyyyyyy
auth-type all
ignore session-key
ignore server-key
!
aaa session-id common
clock timezone KGST 6
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ip name-server xxxxxxxxx
ip name-server xxxxxxxxx
!
!
subscriber service password 7 xxxxxxxxxxxxxxxx
redirect server-group REDIR-SERVER
server ip xxx.xxx.xxx.xxx port 9999
!
multilink bundle-name authenticated
!
!
archive
log config
  logging enable
  notify syslog contenttype plaintext
  hidekeys
path ftp://xxxxxxxxxx@xxx.xxx.xxx.xxx.xx/bras7206-//xxxxxxxxxx@xxx.xxx.xxx.xxx.xx/bras7206-
write-memory
time-period 10080
username tuxper password 7 yyyyyyyyyyyy
username evrey password 7 yyyyyyyyyyyyy
!
!
!
!
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 8000
sessions per-vlan limit 4000
!
!
interface Loopback0
ip address xx.xxx.xx.xx 255.255.255.255
!
interface GigabitEthernet0/1
description 7600_Uplink
ip address yy.yy.yy.yy 255.255.255.252
ip ospf network point-to-point
media-type rj45
speed 1000
duplex full
no negotiation auto
no cdp enable
!
interface GigabitEthernet0/2
description 7600_Uplink_pppoe_vlan
mtu 9000
no ip address
media-type rj45
speed auto
duplex auto
no negotiation auto
vlan-range dot1q 25 26
  pppoe enable group global
  exit-vlan-config
!
vlan-range dot1q 300 399
  pppoe enable group global
  exit-vlan-config
!
vlan-range dot1q 401 461
  pppoe enable group global
  exit-vlan-config
!
vlan-range dot1q 600 620
  pppoe enable group global
  exit-vlan-config
!
vlan-id dot1q 20
  pppoe enable group global
  exit-vlan-config
!
!
interface GigabitEthernet0/3
no ip address
shutdown
media-type rj45
speed auto
duplex auto
no negotiation auto
!
interface Virtual-Template1
description PPPoE
mtu 1492
ip unnumbered Loopback0
ppp authentication chap pap PPPoE
ppp authorization PPPoE
ppp accounting PPPoE
ppp eap refuse
ppp ms-chap refuse
ppp ms-chap-v2 refuse
ppp ipcp dns zzz.zzz.zzz.zzz zzz.zzz.zzz.zzz
!
router ospf 1
router-id yyy.yy.yy.yy
log-adjacency-changes
summary-address ii.iii.ii.0 255.255.254.0
summary-address ttt.ttt.ttt.0 255.255.255.0
summary-address ttt.ttt.ttt.0 255.255.255.0
summary-address ttt.ttt.ttt.0 255.255.255.0
summary-address ttt.ttt.ttt.0 255.255.254.0
redistribute connected subnets
redistribute static subnets
network uuu.uuu.uuu.uuu 0.0.0.3 area 0
default-information originate
!
ip classless
!
!
no ip http server
no ip http secure-server
!line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
session-timeout 30
exec-timeout 60 0
length 0
international
line vty 5 15
!
ntp clock-period 17179974
ntp peer vvv.vvv.vvv.vvv
ntp peer vvv.vvvv.vvv.vvv
end

-------------

This problem has appeared twice, and was resolved reboot Cisco 7206vxr BRAS.

It's not good. I need help!

P.S. I'm ready to provide any needed information.

Correct Answer by Paolo Bevilacqua about 6 years 9 months ago

It would be useful to see the contect of thse PPP LCP,

Alos, which exact IOS are you using ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Paolo Bevilacqua Tue, 05/18/2010 - 10:38

It would be useful to see the contect of thse PPP LCP,

Alos, which exact IOS are you using ?

m.rabidinov Tue, 05/18/2010 - 20:04

I can attach wireshark dump.

Is it enough?

IOS: c7200-advipservicesk9-mz.122-33.SRD4.bin

Thank you for help!

P.S. I can send a wireshark dump when pppoe is up, it was made after reboot Cisco bras 7206.

Attachment: 

Actions

This Discussion

Related Content