LMS 3.1 process problem

Unanswered Question
May 18th, 2010

Hi expert team!
The CiscoWorks server was re-started on may 13, 10:20 am. for installation of security updates to S.O. Windows Server 2003. (see parches.jpg).
From that moment, the Daemon Manager (DM) does not start .The following message appeared: "The CiscoWorks Daemon Manager service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."
Then, I re-started the server, stopped the processes, and executed NMSROOT\setup\support\resetCasuser.exe to reset the casuser. I did a "net stop crmdmgtd" and a "net start crmdmgtd" Now, the Daemon Manager started, but the processes did not appeared in the Server > Admin > Process Management. Obviously, the AniServer can not be activated to open Topology Services, I tried to shutdown all the services to upload them again, but it does not work.
Attached you will find the syslog.log output, and pdshow.txt.

Thanks in advance!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 05/18/2010 - 13:38

What events do you see in the Windows Event Viewer related to Daemon Manager?

Joe Clarke Wed, 05/19/2010 - 08:55

Post a screenshot of the Service Control Panel showing all of the CiscoWorks services.

Joe Clarke Wed, 05/19/2010 - 12:05

This looks okay, but the pdshow indicates processes were started out of order.  Try rebooting this server.  If the problem persists, post the new pdshow output.  Do you have any services running which may be starting other services (i.e. a service which starts services which are set to Manual)?  WE have seen in the past that some customers have such services as part of a server management suite.  When they start the CiscoWorks services, that interferes with Daemon Manager.

jorgelina.abraham Thu, 05/20/2010 - 15:13

The server administrator commented me that there is no registered Windows's service affected to Daemon Manager.
I re-started the server again, executed pdshow command, and after the following message appeared: "Daemon Manager is processing other tasks in the queue. Please try again late"

I tried again, and the command began to run. Attached is the result of this procedure.

Thanks in advance!

Joe Clarke Fri, 05/21/2010 - 22:31

Did you restart Daemon Manager or did you reboot?  You really need to do a reboot as ANIDbEngine is still in an incorrect state (as are a lot of other processes).

jorgelina.abraham Wed, 05/26/2010 - 11:53

Hi Joe,..!

Each time that I restart the Daemon Manager or reboot, the Daemon Manager no start!
I must to run resetCasuser.exe to get Daemon Manager up !!
What can I do? Do you want that uninstall the Windows patches? after this patches, all run OK.

Thanks very much in advance!

Joe Clarke Wed, 05/26/2010 - 12:00

If resetCasuser is required to start dmgtd, someone or something is changing either the casuser password, the casuser account settings, or the casuser roles.  I am not familiar with what these Windows patches are doing, but if that was all that changed between when the server was working and now, then try uninstalling them.  If things start to work again, add one of the patches back in at a time to find which one is problematic.

jorgelina.abraham Wed, 05/26/2010 - 13:54

Hi Joe!

I uninstalled the Windows patches, rebooted the server, and Daemon Manager no start.
Then I do stop of process and run resetCasuser.exe, and do net stop crmdmgtd, then net start crmdmgtd I get Daemon Manager up., but the problem continue, the topology services no open, and the process missing in the process management.

Any idea?

Thans very much in advance!

Joe Clarke Wed, 05/26/2010 - 21:02

As I said, something must be changing relating to the casuser account.  Check with the server administrators to see what could be modifying casuser's account, password, and/or security policies.

jorgelina.abraham Thu, 05/27/2010 - 13:11

Hi Joe..!

The server administrator say that no change in security policies. He move to an OU "without policies" and reboot de server, but again the same situation.
I have to run resetcasuser.exe to get Daemon Manager up.

Thanks very much in advance..!

Joe Clarke Sat, 05/29/2010 - 22:49

After you run resetCasuser.exe, take a look at the server's Local Security Policy.  Note the settings.  Then reboot, and look at those settings again.  If they haven't change, then something must be changed the SAM for casuser.  Next, run resetCasuser.exe, then check the user settings for casuser (i.e. make sure the account is set such that it never expires).  Then reboot, and check those settings again.  If those settings haven't changed, then something must be resetting casuser's password.  For that, the only thing I can recommend is to bug your server admin again.

Actions

This Discussion