BAT Error No.

Answered Question
May 18th, 2010

I know it's a strange title but to be honest I'm getting a strange very vague error message. This is happening when trying to create a new Phone Template Configuration for either a 7941 or 7942 phone. I've tried with various settings from just the basic to putting in more info but get the same error message:

Error No.

System Info:

CM is 4.2.3(sr4b)

BAT 5.2(3)

Latest Device pack and phone firmware installed.

I know 4.2 is rather old and not many people are still using it but wondering if any of you guys had ever come across this before.

Thanks, Nick

I have this problem too.
0 votes
Correct Answer by Jaime Valencia about 6 years 5 months ago

Try to uninstall and reinstall BAT.



If this helps, please rate

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (5 ratings)
rob.huffman Wed, 05/19/2010 - 06:39

Hi Nick,

I'm going with my buddy Java on this one (+5 Java)

BAT ERROR - Error No.

Uninstalling BAT

Use the following steps to uninstall BAT or use Add/Remove Programs in the Control Panel.

The uninstall program for BAT 5.2(3) removes the BAT application and the BAT Excel spreadsheet that is stored in the C:\CiscoWebs\BAT\ExcelTemplate\ folder. The uninstall program does not remove any BAT data files or BAT templates that you created and saved to the C:\BATFiles or C:\CiscoWebs\BAT\Templates\ folders.

Note If you uninstall BAT and then install the newer version of BAT, none of your previous templates can migrate to the newer version. You must upgrade BAT to migrate templates to the new BAT release.

Use the following procedure to uninstall BAT.


Step 1 On the server that is running the publisher database for Cisco Unified CallManager, choose Start > Programs > Cisco Unified CallManager 4.2 > Bulk Admin Tool > Uninstall BAT.

A dialog box requests confirmation of the uninstall request.

Step 2 To uninstall BAT, click OK or Cancel to exit the uninstaller.

The IIS Admin service stops, files are deleted, and the IIS Admin service restarts.

Step 3 To exit the uninstaller, click OK.



Please support CSC Helps Haiti

nickpalmermorewood Fri, 05/21/2010 - 01:27

Thanks for the replies. The strange thing is that the error does not state Error No. Path not found, Error in Retrieving Phone Templates

It just throws up "Error. No."

The existing templates still work and I can create and insert a new template based on a 7940 phone. It's just our newer 7941 and 7942 phones that it won't let me insert?

Harmit Singh Fri, 05/21/2010 - 04:13

Hi Nick,

I've seen this one before.. Here are a couple of DDTS i came across that might be worth looking at:

Try the workaround of the 2nd DDTS.

Also, try using Sun Java instead of Microsoft VM in the Browser options. See it this helps out.



nickpalmermorewood Wed, 06/09/2010 - 01:30

After reinstalling the BAT version ended up as 5.2.3e, the old templates were upgraded and I was able to create templates for the 7941/7942 phones.

Thanks guys


This Discussion