CAD on UCCE 7.5.8 doesn't failover

Unanswered Question
May 19th, 2010

Hi,

I have a duplexed ICM setup with 2 Proggers.

CAD services are installed on both Proggers as well.

When I log in a CAD and set it ready, it doesn't switch to the other server when I pull the visible LAN of the active side. It does mention that the connection was lost and attempts to reconnect but never succeeds.

What I found so far is that the CTIsvr process on the idle side doesn't turn active when I pull the LAN cable from the initial active server.

I have double checked configuration for CG and PG. All looks ok.

Any idea how to troubleshoot this any further?

FYI, if I stop the active CG using ICM Service Control, the CAD fails over nicely.

Rgds,

Koen

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gergely Szabo Thu, 05/20/2010 - 04:00

Hi,

when you pull out the visible LAN cable, is the private LAN still connected?

Proggers usually prefer communicating over the private LAN. This might be the reason why CTI process won't go down on the inactive side: it still has got a path to the other server via the private LAN and it can see the active CTI server still active. However, the CAD cannot see it anymore, it can see only the other CTI server, which is inactive, and won't connect.

Try pulling out both the visible and the private LAN's and see what happens.

G.

Koen Van Impe Thu, 05/20/2010 - 06:35

Hi G.


Yes, private LAN is still up at that point.

If I break both visible and private LAN it switches over nicely.

I opened a TAC case this morning. As I was to show the issue to the TAC engineer in a WebEx session, it suddenly worked as expected.

I really puzzled.

Did some extra testing today and the failover worked every time.

It's really strange and there's no explanation for it.

Thanks for your input!

K

Actions

This Discussion

Related Content