Nexus 5k syslog issue

Unanswered Question
May 19th, 2010
User Badges:

Good Morning!   I'm having some difficulties regarding our new Nexus 5020 switches.   We have two of thse in which are connected to multiple

2k models (which are being used in the Top of Rack).    We are currently utilizing the 4.1(3)N1(1) version of code.   I am still very new to these switches

and I'm not sure if it's even considered IOS or if there is another name for it.   


Anyhow, here is my dilemma.   When we initially began setting these up, we noticed that there were two VRF's automatically set up (management

and default).   We are trying to set up logging to go to a remote syslog server, however....it keeps attempting to use the management vrf.    I removed the IP address from the management interface and am using VLAN 1 as my management interface (in-band management).     So....i believe this is where my

issue lies. I'm wanting to send my messages to a logging server, but use the default vrf instead of the management.    I tried using the following command:


logging server x.x.x.x 5 use-vrf default facility syslog


Unfortunately, the 'use-vrf' option doesn't show up for me.    I can't seem to figure out how to force the logging to use a certain vrf.   If anyone can help, i'd greatly be appreciated.   And once again, I'm sorry for my ignorance on this subject.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (4 ratings)
Loading.
Ganesh Hariharan Wed, 05/19/2010 - 23:17
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Good Morning!   I'm having some difficulties regarding our new Nexus 5020 switches.   We have two of thse in which are connected to multiple

2k models (which are being used in the Top of Rack).    We are currently utilizing the 4.1(3)N1(1) version of code.   I am still very new to these switches

and I'm not sure if it's even considered IOS or if there is another name for it.   


Anyhow, here is my dilemma.   When we initially began setting these up, we noticed that there were two VRF's automatically set up (management

and default).   We are trying to set up logging to go to a remote syslog server, however....it keeps attempting to use the management vrf.    I removed the IP address from the management interface and am using VLAN 1 as my management interface (in-band management).     So....i believe this is where my

issue lies. I'm wanting to send my messages to a logging server, but use the default vrf instead of the management.    I tried using the following command:


logging server x.x.x.x 5 use-vrf default facility syslog


Unfortunately, the 'use-vrf' option doesn't show up for me.    I can't seem to figure out how to force the logging to use a certain vrf.   If anyone can help, i'd greatly be appreciated.   And once again, I'm sorry for my ignorance on this subject.


Check out the below link for syslog configuration on nexus 5K


http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/sm_syslog.html#wp1088182


Hope to Help !!


Ganesh.H


If helpful do rate the post

Poliberte Tue, 06/03/2014 - 08:31
User Badges:

This was the weirdest thing. not sure if you fixed your problem but it wouldn't work for me until i hit Ctrl z after the config. Only ctrl Z worked, I still had the same issue when I typed "exit". It would always show "this server is temporarily unreachable" for me before the ctrl z. Weird!

RYBayramov Mon, 12/29/2014 - 02:46
User Badges:

@Poliberte

The same in my situation. Ctrl+Z is the solution :)

pezzulca Tue, 09/27/2016 - 16:09
User Badges:

I was having the same exact issue with "this server is temporarily unreachable" for all my logging servers, but on a Nexus 9372 version 7.0(3)I2(2d)

I had to hit ctrl+z after each logging server command instead of enter.

How did anyone figure that one out!

Poliberte Wed, 09/28/2016 - 06:41
User Badges:

Luck!! I used ctrl-z and exit depending on the mood i'm in lol. It just happened that I was working on 2 different nexus environemnt. One work and the other didn't. The only difference was that I used ctrl-z rather than exit, lol. Just a stroke of luck. 

camzipot1 Tue, 04/25/2017 - 08:49
User Badges:

I had the same problem but i resolve with the next steps:


Workaround:Run following commands:

(config)# no logging server x.x.x.x 5 use-vrf management facility local6
(config)# logging server x.x.x.x 5 facility local6
(config)# logging source-interface loopback 0
(config)# logging server x.x.x.x 5 use-vrf management facility local6
(config)# no logging source-interface loopback 0

Actions

This Discussion

 

 

Trending Topics: Other DC Subjects