CVP Comprehensive - Calls Droped when agent answer

Unanswered Question
May 19th, 2010
User Badges:

Hi,


Currently i have a CVP 7.0(2) es 22 and CUCM 7.5(8), I noticed that sometimes Calls routed to agent are getting dropped, and on the Ingress Gateway i'm watching disconnections because of User Busy (some show commands are attached).

Call flow is simple:

Ingress GW -> CallServer ->Agent if ready, if not then queue.


On CVP i'm getting this error very frequently

%CVP_7_0_SIP-3-SIP_CALL_ERROR: CALLGUID = 94573CAB628C11DF8EEB8D236821F970 LEGID = 9459ADE3-628C11DF-8EF08D23-6821F970 - [INBOUND] - DIALOGUE_FAILURE from ICM Router sends 500 rejection to call. [id:5004]


So i think that once the call is getting routed to the agent the call disconnects by whatever reason, but that whatever reason is what I'm unable to find.

This happens just sometimes, I've seen this error before, when the Device Target does not have a label or when SIP trunk have incorrect CSS on the configurations. But on all those cases happens on all calls or exact extensions... this time happens randomly some calls complete on agent and some calls not.

Any experience on issues like this one will be appreciated.


Regards,

Claudio.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
geoff@hp.com Wed, 05/19/2010 - 17:11
User Badges:
  • Red, 2250 points or more

When you see "DIALOGUE_FAILURE from ICM Router sends 500 rejection to call." the troubleshooting guide says:


Comment: Dialog Failure on the ICM script was encountered and B2BUA is ending the call


Resolution: The ICM script returned a dialog failure. If it is a timeout, confirm that the call is able to be sent to the VXML gateway in timely manner. Confirm that the Microapp is fetching correctly with the IVR service.


Yeah, it's not that useful. But it should mean that there is an error somewhere upstream of CVP - in the Call Router or the PG. You should see the Dialog Failure in the Router or in the PIM. I'm sure you have looked for this.


How frequently?


Regards,

Geoff

CLAUDIO RIVAS Thu, 05/20/2010 - 08:29
User Badges:

Thanks Geoff,


I've taked a look at those, i attached the logfiles and what i have found on another response on this same topic. This happen really ofthen, like every 1 or 2 minutes.


Regards,

Claudio.

geoff@hp.com Thu, 05/20/2010 - 08:42
User Badges:
  • Red, 2250 points or more

Clearly this is to do with "Agent Target Rules". Did you configure that style of routing?


It seems like you have configured dynamic device targets but have not supplied an Agent Targeting Rule.


Regards,

Geoff

CLAUDIO RIVAS Thu, 05/20/2010 - 09:09
User Badges:

Thanks for your quick response Geoff,

I don't have any Agent Targeting Rule configured. But i noticed on the Agent Targeting mode is Rule preferred.

I have 3 questions:

Do i need to change the Device Target Prefered on the configuration of the PG?

Is this Rule Prefered the default when you create the PIM?

What will happen if i change it to Device Target Preferred are the agents or calls going to be disconnected?


Regards,

Claudio.

Abu Hadee Wed, 05/19/2010 - 19:51
User Badges:
  • Silver, 250 points or more

Hi Claudio


Looking at the CVP logs,

DLGID = 17453 which is the ivr legs gets disconnected and DLGID = 17452 getting dialog failure.


This could happen when after ICM router finds an agent available, so it disconnect the VRU leg, but unable to find label for that agent for that particular agent. So it send dialog failure on switch leg.


Look at the router log viewer. If you can collect cvp and router logs that will be great




Thanks

- abu

CLAUDIO RIVAS Thu, 05/20/2010 - 08:24
User Badges:

Hi


I've noticed there is a bunch of traces like this:


13:18:37 ra-rtr Trace: Received 3 AgentSkillGroup logout entries from CM_PG_1
13:22:21 ra-rtr Trace: ATR rule not found for agent 5018 at ext 3111. Device target had label 3111 (ID 5035).
13:25:22 ra-rtr Trace: ATR rule not found for agent 5026 at ext 3114. Device target had label 3114 (ID 5038).
13:27:06 ra-rtr Trace: ATR rule not found for agent 5032 at ext 3123. Device target had label 3123 (ID 5056).
13:28:24 ra-rtr Trace: ATR rule not found for agent 5024 at ext 3117. Device target had label 3117 (ID 5048).


I attached the log files on a zip file.

I've noticed this is really ofthen, at less every 1 or 2 minutes.

Any help will be appreciated.


Thank you,

Claudio.

CLAUDIO RIVAS Thu, 05/20/2010 - 09:49
User Badges:

Well, i've changed the Agent targeting mode on the PIM configuration and the ATR trace on router it's gone... but i can still see disconnections on the gateway.


geoff@hp.com Thu, 05/20/2010 - 11:23
User Badges:
  • Red, 2250 points or more

What errors do you see in the Call Router now when these disconnects occur?


(How far away is your target go-live?)


Regards,

Geoff

CLAUDIO RIVAS Thu, 05/20/2010 - 11:38
User Badges:

Agents reported this after go live, since posted the situation, it have 15 days running.

On the ICM Router process i can't see any error or traces, since the change i applyied on the PIM for the ATR i don't see it moving as fast as before.


Regards,

Claudio.

mparra.fusionet Mon, 09/10/2012 - 18:07
User Badges:

I was having the same problem in a new deployment, the problem was that the VRU PG which corresponded to CVP did not have CVP as a Network VRU, once I assigned it in PG Explorer -> VRU PG > Advanced tab the problem was resolved.

Actions

This Discussion

Related Content