Can i forward trafic from a serial interf. to a fasteth. interf. without a routing protocol?

Answered Question
May 19th, 2010

Hy,

I have a 3725 router that i want to connect to another router on a fastethernet interface. Unfortunately i am out of fastethernet interfaces on my 3725 router, but i have a few serial interf. to spare. The other router has no serial interf free.


My solution was to interconnect the two routers via another router (a smaller c1721 with 2 serial and 2 fast interfaces avalable).

So the connections wil be as so: router c3725 - serial link -- router c1721 -- fastethernet link -- the other router (probably c3845).


Now my question is: can i configure the c1721 to forward all the traffic received from the serial interf. to the fastethernet interf., and vice-versa, without enabling the routing protocol??

Static routes are out of the question due to the complicate ip address design behind these routers.(I don't want to enable the routing protocol because the routing table is very large and i don't think that the small c1721 can handle it without introducing a  significant delay).

thanks in advance.

I have this problem too.
0 votes
Correct Answer by Nagendra Kumar ... about 6 years 8 months ago

Hi,

To my knowledge, number of prefix on routing table limitation depends on the memory installed. I guess 1721 supports upto 64 MB which is more than enough to handle 500 entries.

But you may have to take other factors (like volume of traffic/routing protocol/stability) into consideration while positioning 1721.

Regards,

Nagendra

Correct Answer by Nagendra Kumar ... about 6 years 8 months ago

Hi,

You can use bridging concept to acheive your goal. For example, consider the below topology,

R7-----------------R1-------------------R3

  E0/1        F0/1  S2/2          S2/2

13.1.1.1/24                        13.1.1.3/24

I have enabled CRB bridging on R1 and have both F0/1 and S2/2 on bridge-group 1. On R7 and R3, I have IRB enabled and have E0/1 of R7 and S2/2 of R3 on bridge-group 1. With this config, I can reach between E0/1 of R7 and S2/2 of R3.

Configs:

R1_Config:

========

!

no ip routing

!

bridge crb

!

interface FastEthernet0/1
no ip address
bridge-group 1

!

interface Serial2/2
no ip address
no ip directed-broadcast
no ip route-cache
serial restart-delay 0
bridge-group 1
!

bridge 1 protocol ieee

R3_Config:

========

!
ip cef

!
bridge irb
!
!
interface Serial2/2
no ip address
serial restart-delay 0
bridge-group 1
!
interface BVI1
ip address 13.1.1.3 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip

end

R7_Config:

========


!
ip cef
!
bridge irb
!
interface Ethernet0/1
no ip address
half-duplex
bridge-group 1
!
interface BVI1
ip address 13.1.1.1 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
!
end

Please try the same and let us know if it solves your issue.

Regards,

Nagendra

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
r-godden Wed, 05/19/2010 - 17:09

policy route

interface serial 0

ip policy route-map testing

route-map testing

match ip address 10

set interface ethernet 0

access-list 10 perm any

narcis antonie Thu, 05/20/2010 - 04:58

hy r-godden thanks for your reply but it did't work (for what i needed - i wanted the c1721 router to act like a "media convertor" from serial to ethernet if this is even posible)

I think i will enable the routing protocol on the c1721. I don't have a general view of the c1721. Is a "500 entries routing table" a large routing table for the c1721??? can the router handle it??

Correct Answer
Nagendra Kumar ... Thu, 05/20/2010 - 11:22

Hi,

You can use bridging concept to acheive your goal. For example, consider the below topology,

R7-----------------R1-------------------R3

  E0/1        F0/1  S2/2          S2/2

13.1.1.1/24                        13.1.1.3/24

I have enabled CRB bridging on R1 and have both F0/1 and S2/2 on bridge-group 1. On R7 and R3, I have IRB enabled and have E0/1 of R7 and S2/2 of R3 on bridge-group 1. With this config, I can reach between E0/1 of R7 and S2/2 of R3.

Configs:

R1_Config:

========

!

no ip routing

!

bridge crb

!

interface FastEthernet0/1
no ip address
bridge-group 1

!

interface Serial2/2
no ip address
no ip directed-broadcast
no ip route-cache
serial restart-delay 0
bridge-group 1
!

bridge 1 protocol ieee

R3_Config:

========

!
ip cef

!
bridge irb
!
!
interface Serial2/2
no ip address
serial restart-delay 0
bridge-group 1
!
interface BVI1
ip address 13.1.1.3 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip

end

R7_Config:

========


!
ip cef
!
bridge irb
!
interface Ethernet0/1
no ip address
half-duplex
bridge-group 1
!
interface BVI1
ip address 13.1.1.1 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
!
end

Please try the same and let us know if it solves your issue.

Regards,

Nagendra

narcis antonie Thu, 05/20/2010 - 14:36

hy naikumar,

IT WORKED!! thanks a lot.

regarding my last question (just curious): 500 entries in a routing table are too much for a c1721?? can this router handle it well (regarding the delay)??

Correct Answer
Nagendra Kumar ... Thu, 05/20/2010 - 20:37

Hi,

To my knowledge, number of prefix on routing table limitation depends on the memory installed. I guess 1721 supports upto 64 MB which is more than enough to handle 500 entries.

But you may have to take other factors (like volume of traffic/routing protocol/stability) into consideration while positioning 1721.

Regards,

Nagendra

narcis antonie Fri, 05/21/2010 - 05:29

aha ... I thought so... i was just curious for more opinions...

thank a lot again...

the solution presented by you above is just what i needed

best regards

Actions

This Discussion