Error launching ASDM

Unanswered Question
May 19th, 2010

I'm getting an error when I try to launch ASDM via java.

The details of the error are:

Under Launch File tab-

The flash device is in use by another task.
The flash device is in use by another task.
HTTP/1.1 404 Not Found
Date: Thu, 10 Dec 2009 13:10:49 UTC
Connection: close
Content-Type: text/html

<HEAD><TITLE>404 Not Found</TITLE></HEAD><BODY BGCOLOR=#FFFFFF><H1>404 Not Found</H1>The requested URL /admin/public/asdm.jnlp was not found on this server. </BODY>

Exception tab-

MissingFieldException[ The following required field is missing from the launch file: <jnlp>]
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I would tend to think this is just a java issue, but I can connect to an identical 5520 with java from the same machine and it works fine.  I removed and re-uploaded the bin image for ASDM to the ASA just to be sure it wasn't corrupted.  Still get the same result.  I'm running 8.2(2)12 on both.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jennifer Halim Thu, 05/20/2010 - 00:54

1) What version of ASDM do you upload to the ASA? and what is the version of ASDM on the other ASA that also runs version 8.2.2(12) which is working just fine.

2) and also, can you try to access the ASA via ASDM from a different PC and see if you have the same issue.

David Niemann Thu, 05/20/2010 - 04:54

Both are running 6.3.1.  I just tried from another system and it works fine.  Some kind of java

caching issue causing the one to fail from that machine?

Jennifer Halim Thu, 05/20/2010 - 05:24

Sounds like issue with that particular machine's Java.

Are you able to ASDM via the ASDM launcher instead of running it directly via Java?

David Niemann Thu, 05/20/2010 - 12:50

Actually I don't have ASDM launcher installed because I connect to other devices running various versions of ASDM including Pix and FWSM

so I pretty much stick to the java version.  I favor CLI, but ASDM definitely has some nice benefits.

Actions

This Discussion