VLAN 3750 Switch

Unanswered Question
May 20th, 2010

Hi

I have currently setup several Vlans and connected this to other switch,s and all the Vlans are working except 1 which is specific only to this switch.

the Vlan is vlan14 and I can ping 172.16.0.1 from any computer including the devices plugged into the ports.

if I ping from the device to the rest of the network i get a no reply

if I plug 2 devices into the ports i can't ping from one device to the other

I am trying to get devices plugged into Vlan 14 to talk to the rest of the network and also to each other, can someone point something out that i have missed please

PBSWITCH01#sh run
Building configuration...

Current configuration : 8111 bytes
!
! Last configuration change at 13:15:32 Sydney Wed Mar 3 2010 by admin
! NVRAM config last updated at 13:16:44 Sydney Wed Mar 3 2010 by admin
!
version 12.2
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
no service dhcp
!
hostname PBSWITCH01
!
boot-start-marker
boot-end-marker
!
logging buffered 16384 informational
enable secret 5 XXXXXXXXXXXXX
!
username admin password 7 XXXXXXXXXXXXX
!
!
aaa new-model
!
!
aaa authentication login CONSOLE local
aaa authentication login VTY local
!
!
!
aaa session-id common
clock timezone Sydney 10
clock summer-time Sydney recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
vtp mode transparent
authentication mac-move permit
ip subnet-zero
no ip source-route
no ip gratuitous-arps
no ip domain-lookup
ip domain-name XXXXXXXX
!
!
!
!
!
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig (STP)
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
errdisable recovery cause l2ptguard
errdisable recovery cause psecure-violation
errdisable recovery cause port-mode-failure
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause pppoe-ia-rate-limit
errdisable recovery cause mac-limit
errdisable recovery cause vmps
errdisable recovery cause storm-control
errdisable recovery cause inline-power
errdisable recovery cause arp-inspection
errdisable recovery cause loopback
errdisable recovery cause small-frame
errdisable recovery interval 180
!
spanning-tree mode pvst
spanning-tree loopguard default
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree vlan 1-1000 priority 0
!
vlan internal allocation policy ascending
!
vlan 10
name Internal
!
vlan 11
name Servers
!
vlan 13
name Prevision
!
vlan 666
name UnusedPorts
!
vlan 14
name San initiators
!
ip tcp synwait-time 10
!
!
interface Port-channel10
description PBORHV01 HyperV server
switchport access vlan 11
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/1
description to DELL switch Stack 2 port 44
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,11,13
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/0/2
description Prevision transparent bridge
switchport access vlan 13
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/3
description PBORHV01 HyperV server - ChannelGroup Members
switchport access vlan 11
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet1/0/4
description PBORHV01 HyperV server - ChannelGroup Members
switchport access vlan 11
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet1/0/5
description PBORHV01 HyperV server - ChannelGroup Members
switchport access vlan 11
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet1/0/6
description PBORHV01 HyperV server - ChannelGroup Members
switchport access vlan 11
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet1/0/7
description San Port
switchport access vlan 14
switchport mode access
speed 1000
spanning-tree portfast
!
interface GigabitEthernet1/0/8
description San Port
switchport access vlan 14
switchport mode access
speed 1000
spanning-tree portfast
!
interface GigabitEthernet1/0/9
description Broadcom 1
switchport access vlan 14
switchport mode access
speed 1000
spanning-tree portfast
!
interface GigabitEthernet1/0/10
description Broadcom 2
switchport access vlan 14
switchport mode access
speed 1000
spanning-tree portfast
!
interface GigabitEthernet1/0/11
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/12
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/13
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/14
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/15
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/16
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/17
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/18
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/19
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/20
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/21
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/22
description Server Port
switchport access vlan 117
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/23
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!        
interface GigabitEthernet1/0/24
description Server Port
switchport access vlan 11
switchport mode access
storm-control broadcast level 20.00
spanning-tree portfast
!
interface GigabitEthernet1/0/25
description Unused Port
switchport access vlan 666
switchport mode access
shutdown
!
interface GigabitEthernet1/0/26
description Unused Port
switchport access vlan 666
switchport mode access
shutdown
!
interface GigabitEthernet1/0/27
description Unused Port
switchport access vlan 666
switchport mode access
shutdown
!
interface GigabitEthernet1/0/28
description Unused Port
switchport access vlan 666
switchport mode access
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan11
ip address 10.4.0.230 255.255.255.0
!
interface Vlan14
ip address 172.16.0.1 255.255.255.0
!
ip default-gateway 10.4.0.1
ip classless
no ip http server
!
ip sla enable reaction-alerts
access-list 10 permit any log
no cdp run
!
banner login ^C
*********************************************************************
Pybar - PBSWITCH01.
ALL ACCESS IS LOGGED!
*********************************************************************
^C
!
line con 0
exec-timeout 15 0
logging synchronous
login authentication CONSOLE
line vty 0 4
access-class 10 in
exec-timeout 15 0
logging synchronous
login authentication VTY
width 0
history size 256
transport preferred none
transport input telnet
transport output none
line vty 5 15
access-class 10 in
exec-timeout 15 0
logging synchronous
width 0
history size 256
transport preferred none
transport input telnet
transport output none
!
scheduler interval 500
ntp clock-period 36028807
ntp source Vlan11
ntp server 10.4.0.3 prefer
end

PBSWITCH01#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
10   Internal                         active
11   Servers                          active    Gi1/0/11, Gi1/0/12, Gi1/0/13
                                                Gi1/0/14, Gi1/0/15, Gi1/0/16
                                                Gi1/0/17, Gi1/0/18, Gi1/0/19
                                                Gi1/0/20, Gi1/0/21, Gi1/0/22
                                                Gi1/0/23, Gi1/0/24, Po10
13   Prevision                        active    Gi1/0/2
14   SAN_Network                      active    Gi1/0/7, Gi1/0/8, Gi1/0/9
                                                Gi1/0/10
666  UnusedPorts                      active    Gi1/0/25, Gi1/0/26, Gi1/0/27
                                                Gi1/0/28
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
10   enet  100010     1500  -      -      -        -    -        0      0
11   enet  100011     1500  -      -      -        -    -        0      0
13   enet  100013     1500  -      -      -        -    -        0      0
14   enet  100014     9000  -      -      -        -    -        0      0
666  enet  100666     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Thu, 05/20/2010 - 23:49

Can you configure ip routing in the switch and check are you able to ping between the vlans and can you also clear your query from where you are not able to ping the vlan 14 ip address.

Hope to Help !!

Ganesh.H

joedyfrape Thu, 05/20/2010 - 23:55

hi

I can ping between the Vlans fine from the switch or from my own terminal only the vlan ip for vlan14

but as you can see i have a vlan 14 on port gi 07/08/09/10 and if i plug a device into gi 1/0/7 i can ping the vlan 172.16.0.1 but can't ping past it

if i ping 10.0.4.1 source 172.16.0.1 it gives 0 success rate

ip routing does not work

Ganesh Hariharan Fri, 05/21/2010 - 00:04

hi

I can ping between the Vlans fine from the switch or from my own terminal only the vlan ip for vlan14

but as you can see i have a vlan 14 on port gi 07/08/09/10 and if i plug a device into gi 1/0/7 i can ping the vlan 172.16.0.1 but can't ping past it

if i ping 10.0.4.1 source 172.16.0.1 it gives 0 success rate

ip routing does not work


Is the reverse route is configured for vlan 14 subnet in 10.0.4.1

Hope to help !!

Ganesh.H

joedyfrape Fri, 05/21/2010 - 06:41

if I plug a device into port 7 and 8 I cannot pint to the other device on vlan

14 when they are on the same subnet and vlan

Jon Marshall Fri, 05/21/2010 - 07:01

Jody

Have you actually enabled "ip routing" ie.

3750(config)# ip routing

Also you should not have a default-gateway if this switch is meant to be routing ie.

3750(config)# ip route 0.0.0.0 0.0.0.0 10.4.0.1

3750(config)# no ip default-gateway 10.4.0.1

Edit - just to clarify, do you want this switch to do L3 routing between it's vlans or  does another switch do that ?

Jon

Actions

This Discussion