Cisco VPN Client Installation Hangs

Unanswered Question
May 21st, 2010


I'm trying to install Cisco VPN Client and the installation hangs at the end while the message "Installing Cisco Systems Virtual Adapter" appears on the installation progress window. I used to have version and I was trying to upgrade to (which first uninstalls the previous version) when it all started to go wrong. I even tried with the latest VPN client available from Cisco (

After the installation hangs I have to manually kill the process which sometimes leaves a corrupted TCP/IP stack which I have to rebuild. I've tried many times and lately I have been trying with every single non-microsoft service deisabled and no startup programs running to no avail. Inmstallation still hangs at the same place.

How do I get back my VPN Client?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
lewislampkin Tue, 05/25/2010 - 04:58

I've had this type of issue before.

This is what you need to do

1.  Locate the documentation for manually uninstalling your VPN client software

2.  Manually uninstall the VPN client software

3.  Install the VPN client software

If this does not help, please reply, and someone should assist.

wpimentel Wed, 05/26/2010 - 13:09

Thanks for your reply. Unfortunately it turned out to be harder that expected. I tried to follow these instructions. But i never got to delete the files from C:\Program Files\Cisco Systems\VPN Client\Languages. I get an access denied error for every single file on that folder (I can delete everything else, though).

And also after deleting the registry keys as instructed I still see lots of references to the Cisco VPN Service, especially in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001. For instance I tried to delete HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CISCOVPNINSTALLSERVICE and it doesn't let me. Same thing for LEGACY_CVPNDRVA.

wpimentel Thu, 05/27/2010 - 12:05

It didn't help. The MS cleanup utility seems to be designed to remove only Office 2003 (i never got prompted for what i wanted to remove). At first it detected a pending installation for Cisco VPN and the (Cisco) installation started to rollback. I performed the same steps for manually removing the VPN client . Ran the Windows Installer Cleanup utility one more time to be sure (still no prompts it just runs without telling me what it did). Rebooted and started the installation again: it tells me something like it cannot control the windows networking and starts rolling back. I remove manually again and launch one more time (million th time!!) and it hangs at the exact same place while creating the Cisco VPN Adapter.

I can't beleive how bad a product this software is. A simple upgrade left me with no VPN software!!!! all signs point to a total system reinstall in order to be able to install  the vpn client from scratch.


This Discussion