RV 120W port forwarding problem

Unanswered Question
May 21st, 2010

I created 5 firewall->port forwarding->rules...

What I wanted was to forward a particular port from the WAN to a particular LAN IP

All 5 showed up in the IPv4 Firewall rules, but only the first line that is enabled works.

If I disable the first line, the 2nd line works...

If I disable the first and 2nd line, then the 3rd line works...

I have tried cycling power and re-booting...no change...

Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Te-Kai Liu Sun, 05/23/2010 - 08:46

The reason is that the Service parameter was set to ANY in the forwarding rules. It should be the specific service that you want to forward to the particular host in the LAN.

m-costello Mon, 05/24/2010 - 12:29

tekliu,

Thanks again for the quick response....it is getting closer!!

The first line is a Windows remote desktop path.  I have not found any service that works except "any".

Right now if I disable the first line, the 2nd line (now HTTP) for the website works! and the final line "any" works!!

Is there a service that should work for windows remote desktop besides "any"?

Lines 3 and 4 are for the FTP server, I have not verified the FTP functionality yet.

Attached is the latest setup that almost works....

Next suggestion?

Is there a reason the "any" service type doesn't work? Let the port number decide destination?

m-costello Mon, 05/24/2010 - 12:40

i just tried the FTP port forwarding lines, and they do not work either.

we just replaced our old Linksys WRT54GX4 with this new RV 120W

all of these port forwarding rules worked prior to the RV switch...

so maybe it is just me trying to configure it properly...

Te-Kai Liu Mon, 05/24/2010 - 16:03

I suggest removing the last rule that forward ANY Service to a specify LAN IP address. That rule could have caused all services forwarded to the given LAN IP address. You could define Custom Service under the Firewall>Access Control>Custom Services tab.

m-costello Mon, 05/24/2010 - 16:14

Thanks..., I will disable or delete the last rule and see if FTP is working.

Can you suggest a service type that I should select for Windows remote desktop?

m-costello Mon, 05/24/2010 - 16:44

I do not see a RDP service type in the rv 120w port forwarding rules.  How do you suggest fill out the port forwarding rule for RDP service?

Te-Kai Liu Mon, 05/24/2010 - 17:03

On RV 120W, you could add a Custom Service for RDP under the Firewall>Access Control>Custom Services page,

Click on Add button, and define a RDP service as TCP Port 3389. Save it and you could see the RDP service when you go back to the Port Forwarding page.

m-costello Mon, 05/24/2010 - 18:01

Thanks, I did not know how the custom service worked.

I added 2 custom services as you suggested...attached file custom.jpg

Then I added them as the service type on the port forwarding page.

It looks nice, but now neither one works in any order..."rvcustomer.jpg"

What should I try next?

Attachment: 
Te-Kai Liu Mon, 05/24/2010 - 21:40

If forwarding TCP Port 3389 does not work as expected, please contact Small Business Support Center so they can offer additioanl help.

m-costello Tue, 05/25/2010 - 06:51

I see that this is the small business support community.

Can you point me to the small business support center?

I did not know there was a difference, sorry for wasting our time.

Maybe it's time to look at a Juniper solution.

dliberty82 Tue, 05/25/2010 - 06:10

I believe the RV 120W is just another low quality Linksys product disguised as a Cisco router. I've had terrible experience with Linksys - unstable for business usage and trying to use anything other than the very basic features of the router causes reboots / lock ups / severe performance drops.

AXIOMSOFTWARE Sat, 06/26/2010 - 13:36

I am also having issues configuring my RV 120W using Port Forwarding.  We have 5 public IP addresses, and multiple private IP addresses.  I need to accept incoming connections to the different public addresses and depending on the address and port (service) direct the connection to the proper server IP address and port.  I setup the Firewall Rules for the services, but when I tried accessing one of our HTTP servers (which happens to be "mapped" with the public address on the router), I received the administration utility.  This same route works on the Netopia router I am replacing.  I figure that it must be a configuration issue, but I do not see what is wrong.  I do not have screen shots right now, but I can post them if this would help.

Actions

This Discussion