CUBE and SIP Trunk

Unanswered Question
May 22nd, 2010
User Badges:

Hi all,


This my first attempt to integrate CUBE and Telco using SIP protocol.


I have CUCM >> H323 GW >> Telco.


now I will configure the GW to work as CUBE. I asked the Telco for the parameters and I have this issue:


they gave me two IPs for SIP one for Signaling and one for Media. How I can distinguish the traffic.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Abu Hadee Sat, 05/22/2010 - 02:39
User Badges:
  • Silver, 250 points or more

Hi


What you mean they gave you two ip address? Are those ip addresses to use on your gateway or you need to point to them?


If you need to point to them, then you need to use the Signalling only. The RTP address will be negotiated during the signalling. So you do not need to configure anything for it. But if you have any firewall or ACL, make sure you permit udp traffic from the media ip.


But if those IP address to use for your gateway. Then you can use sip bind command.


voice service voip

sip

  bind {control | all} source-  interface interface-id


!


Let me know if this helps


Thanks

- abu

JustForVoice_2 Sat, 05/22/2010 - 04:09
User Badges:

Hi Abu Hadee,


I got two IP address for SIP setting and one for IP address for connectivity,


What I am going to do is to configure the gig interface for P2P connectivity.


but inside the dial-peer shall I use the signaling IP address in session target command.


Do you have sample of the configuration?

Abu Hadee Sat, 05/22/2010 - 18:39
User Badges:
  • Silver, 250 points or more

Hi,


I'm still confused if you have to use all these IP address for your gateway or one for your gateway, other two for remote




lets say you've received following IP Address.

1. A.A.A.A for your GW conectivity

2. B.B.B.B for SIP Signalling

3. C.C.C.C for meida


Here is scenario 1, say you've to use one IP for your GW and other two for remote


interface gig0/0

ip address A.A.A.A 255.255.255.0 !

!

voice service voip

sip

bind all gig0/0

!

dial-peer voice 1 voip

destination-patter 9T

incoming called-number .

session-target ipv4:B.B.B.B

codec g711ulaw

no vad

!


C.C.C.C you do not need to configure anything in the voip side. As this one will be media ip and will be negotiated autometically. All if you do permit any UDP sourced from that.


Option two: If you need to configure all three in your gw


interface gig0/0

ip address A.A.A.A 255.255.255.0 !

!

interfae loopback 1

ip address B.B.B.B 255.255.255.255 !

interfae loopback 1

ip address C.C.C.C 255.255.255.255 !



voice service voip

sip

bind control loopback1

bind media lookback2

!


dial-peer voice 1 voip

destination-patter 9T

incoming  called-number .

session-target dns:

codec  g711ulaw

no vad

JustForVoice_2 Sat, 05/22/2010 - 23:04
User Badges:

Thank you too much Abu Hadee,


I will test it and if I have any problemI will return to you.

JustForVoice_2 Wed, 07/14/2010 - 00:08
User Badges:

I tried the configuration above, I can now place calls but I have some issues:


1- When somebody call from outside to IP phone ( one of the DID extension) the calling party always hear ringing even if I pick up the phone and answer the call. I contacted the provider regarding this and they said we are not receiving any signals that some body answer.


2- It is a DTMF issue. if I called from IP phone to out-side and AA answers the AA does not recognize the DTMF. the provider inform me that they are using in-band signaling, so shall I delete the dtmf command from the dial-peer?

ryanticer Mon, 09/27/2010 - 22:26
User Badges:

Hello,


I'm not sure if you ever figured this out, but the answer is the "dtmf-relay rtp-nte" command, which encapsulates the dtmf signals within RTP. It takes an MTP resource, generally speaking.


Ryan

Actions

This Discussion