Vlan trunk between srw 2024 and Catalyst 3650

Unanswered Question
May 24th, 2010

Hi all

I have problem with correct configuration a trunk link between two switches Linksys SRW2024 abd Cisco 3650.

I have two vlans on both switches vlan: 10 and 20.On cisco i have on port 0/1 and 0/2 Vlan 10 and on port 0/3 0/4 Vlan 20 on port 0/24 i have trunk connection to SRW 2024 see configuration below:

Current configuration : 3428 bytes
!
! Last configuration change at 13:54:55 UTC Mon May 24 2010
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname KN_Cisco3650
!
enable secret 5 $1$plhv$b6E4mlHstMJQWEDaql/VR/
enable password 7 02120B495804062440
!
no aaa new-model
clock timezone UTC 1
clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
system mtu routing 1500
udld aggressive

ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 26 32 46 46 56
!
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0
ip address 10.48.7.10 255.255.248.0
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
ip verify source
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/3
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/4
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport mode trunk
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface TenGigabitEthernet0/1
!
interface TenGigabitEthernet0/2
!
interface Vlan1
no ip address

I think on cisco everything is configured ok.

On SRW 2048 i have also 2 vlans on port 19 and 20 vlan 10(see screen) and on port 22 vlan 20 and port 23 as trunk port. with 10T and 20T

I make uplink on port 23 in linksys and port 24 on cisco site but something is wrong i cant' ping any machines in the sames vlans. Any ideas? Please help...

Regards

Tomasz

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

If I were you I would narrow the trunk interface configuration to the following:

[quote]

interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
[/quote]

The line I suspect that is causing you trouble is:

[quote]

spanning-tree  bpduguard enable

[/quote]

That's probably the culprit because your Linksys switch is running the Spanning Tree Protocol which runs on all interface. The Cisco switch receives it, and because of the "spanning-tree  bpduguard enable" it then disables it.

Oh, and I wouldn't run a "macro  description cisco-desktop" on a switch<>switch connection..

Actions

This Discussion