Netflow on catalyst sw

Answered Question
May 24th, 2010

I saw an oldest thread that netflow is not supported on any of catalyst 2960/3560/3750. Has there been any change today?.

What about 4510 with 6-E supervisor?.

Thanks.

I have this problem too.
0 votes
Correct Answer by Don Jacob about 6 years 6 months ago

Yes, Cisco has still not introduced NetFlow support on the old Catalyst models like 2950, 3560 or 3750. The best option you have is to mirror the port on these devices and connect that port to a NetFlow supported device and export NetFlow from that device. You can then monitor this NetFlow data to get reports on the traffic through the unsupported device.

If you cannot afford another device just for this, you can add a server and install some open source flow generators like nProbe or fProbe. These tools will generate and export NetFlow data to any analyzer tool which can then generate reports. I have seen a number of people use nProbe or fProbe in such a setup with ManageEngine NetFlow Analyzer.

As far as I have heard, SUP 6-E does not have NetFlow support. You either need to add a NetFlow daughter card or move to SUP 10-GE which has NetFlow support by default.

Regards,

Jacob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Don Jacob Tue, 05/25/2010 - 04:33

Yes, Cisco has still not introduced NetFlow support on the old Catalyst models like 2950, 3560 or 3750. The best option you have is to mirror the port on these devices and connect that port to a NetFlow supported device and export NetFlow from that device. You can then monitor this NetFlow data to get reports on the traffic through the unsupported device.

If you cannot afford another device just for this, you can add a server and install some open source flow generators like nProbe or fProbe. These tools will generate and export NetFlow data to any analyzer tool which can then generate reports. I have seen a number of people use nProbe or fProbe in such a setup with ManageEngine NetFlow Analyzer.

As far as I have heard, SUP 6-E does not have NetFlow support. You either need to add a NetFlow daughter card or move to SUP 10-GE which has NetFlow support by default.

Regards,

Jacob

Rafael Jimenez Tue, 05/25/2010 - 06:55

The "Installation Note for the Catalyst 4500 Family NetFlow Services Card" said:

Hardware and Software Requirements

To install and use the NetFlow Services Card, you need the following:

Catalyst 4500 series switch (Catalyst 4503, 4506, 4507R, or Catalyst 4006)

Supervisor Engine IV or Supervisor Engine V running Cisco IOS Version 12.1(13)EW or greater

Now I have a doubt about the 4510R-E:

Can I install a WS-F4531= daughter card on a 6-E supervisor ?

thanks

Don Jacob Tue, 05/25/2010 - 11:31

Hi,

Yes. It seems WS-F4531can work only with SUP IV / V. I was unable to find any information of SUP 6E supporting the services card mentioned.

Regards,

Jacob

Actions

This Discussion