SRP521W shuts down fxs ports when GSM disconnects

Unanswered Question
May 25th, 2010


I have a brand new SRP521W that has a 3G wireless USB modem connected to it.

It has an asterisk system on the "inside", and port 1 of the FXS is configured as an extension

to the asterisk.  Port 2 of the FXS is configured as an extension to an internet VOIP provider, for

a fax (T38, seems to work well).  Internal network is connected to switch port 1.

This is where I start to get confused.  If I power up the SRP without plugging in the 3G modem,

the FXS ports are NEVER enabled - the lights never come on, and they do not register, even on

the internal lan.  But the ports show as enabled in the GUI.

When I plug in the 3G modem, and it connects, the FXS ports come live after about 30 seconds.

When I unplug the 3G modem, the FXS ports die again.

Is this a perverse design decision - you must have an active WAN connection before the local

FXS ports come up?

Firmware version is 1.1.1(03), despite being a brand new unit out of the box.  I have just bought

support so I can get up to 09 and see if that helps.

Anyone have any ideas about the FXS issue?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Andrew Hickman Tue, 05/25/2010 - 05:55


Thanks for your feedback.

Firstly, there is no design feature / constraint that implies that a 3G connection has to be in place to enable the voice ports - so we need to consider other explanations here.

Please give me a little while to take a look at this for you.  In the mean time, I wonder if you might try something?  Could you swap the voice port configurations, so that port 1 is associated with the ITSP and port 2 with Astrisk?

As you have purchased support, I would certainly recommend upgrading to 1.1.9.  This was only posted earlier this month, and is the only firmware release that we have posted since 1.1.1 (so the device was as up to date as it could have been at the time of shipping).



rwakelin Tue, 06/01/2010 - 03:43

I still haven't managed to get the latest firmware, either through TAC as a warranty call or via the support package,

but I have an update.

The FXS ports don't shut down, they loose their registration to the asterisk server!

When the GSM/WAN port disconnects, the "external" IP of the router goes to, and

the router uses this address in its SIP registration messages.  Of course, the asterisk box

can't reply to this address, so the registration fails, and the FXS ports fall off the network.

When the GSM/WAN port comes back up, it gets a  dynamic IP address, and this address

is then used by the SIP registration, and it all comes back up again.

For some reason, the router uses its EXTERNAL IP address as the registration address, not

its INTERNAL IP address.  I can see the use in this, if the SIP server is EXTERNAL to the router,

but not if the SIP server is INTERNAL to the router.  There needs to be an option to specify which

IP address (internal or external) to used in the registration, on a per FXS port basis.

Hope this helps someone..

Andrew Hickman Tue, 06/01/2010 - 08:45


This helps a lot.  I'm on leave at the moment, but will look in to this for you when I get back.




This Discussion