Upgrading SDM in the 871W Router Fails, leaving only CLI

Unanswered Question
May 25th, 2010
User Badges:

I have an 871W Router which is configured and working correctly. I used the menu selection in SDM on the router (original 2.1.1) to download a newer version of SDM (2.3.3 in SDM-V233.zip). After unzipping the file, I ran setup. I was prompted to install a newer version of Java on the host PC, and after doing that setup then ran. I installed SDM 2.3.3 on both the host PC as well as (hopefully) on the 871W router.


The SDM software installed fine on the PC, but on the router there was a problem. First, it performed a backup of the existing router files to the PC. Second it deleted the old (2.1.1) version of SDM from the router. Third, when it started copying the new (2.3.3) SDM files to the router, after a short time it returned an error dialog box reading "Cisco SDM - File copy operation failed" and then finished.


Now, when I try to access the router directly from a web browser, it only returns a "web" version of the CLI interface, since SDM is no longer installed on the router.


If I run the local SDM version on the host PC, it gets as far as prompting me for the user name and password, but then hangs while displaying the Cisco logo (at the entry to SDM).


I have tried doing the installation of SDM 2.3.3 from several different host PC's (Windows XP, Vista and Windows 7) and the result is the same. I have tried rebooting the router, both with CLI commands, as well as a physical unplugging (a very cold start) and the result is the same.


When I look at the router files, it is not surprising that SDM is not present, since the files for SDM are not shown.


Does anyone know how to restore a version of SDM, any version really, to the router? I have a copy of the current config so if necessary the router can be configured again. I have so far avoided a hard reset of the router to the factory settings, but I am not certain that would fix the issue. Is the original SDM version stored in ROM on the router to be able to be restored?


If anyone has an answer I appreciate the feedback.


Sincerely,

John Baker

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Tue, 05/25/2010 - 22:02
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

I have an 871W Router which is configured and working correctly. I used the menu selection in SDM on the router (original 2.1.1) to download a newer version of SDM (2.3.3 in SDM-V233.zip). After unzipping the file, I ran setup. I was prompted to install a newer version of Java on the host PC, and after doing that setup then ran. I installed SDM 2.3.3 on both the host PC as well as (hopefully) on the 871W router.


The SDM software installed fine on the PC, but on the router there was a problem. First, it performed a backup of the existing router files to the PC. Second it deleted the old (2.1.1) version of SDM from the router. Third, when it started copying the new (2.3.3) SDM files to the router, after a short time it returned an error dialog box reading "Cisco SDM - File copy operation failed" and then finished.


Now, when I try to access the router directly from a web browser, it only returns a "web" version of the CLI interface, since SDM is no longer installed on the router.


If I run the local SDM version on the host PC, it gets as far as prompting me for the user name and password, but then hangs while displaying the Cisco logo (at the entry to SDM).


I have tried doing the installation of SDM 2.3.3 from several different host PC's (Windows XP, Vista and Windows 7) and the result is the same. I have tried rebooting the router, both with CLI commands, as well as a physical unplugging (a very cold start) and the result is the same.


When I look at the router files, it is not surprising that SDM is not present, since the files for SDM are not shown.


Does anyone know how to restore a version of SDM, any version really, to the router? I have a copy of the current config so if necessary the router can be configured again. I have so far avoided a hard reset of the router to the factory settings, but I am not certain that would fix the issue. Is the original SDM version stored in ROM on the router to be able to be restored?


If anyone has an answer I appreciate the feedback.


Sincerely,

John Bake


Hi John,


To restore the SDM file from router i dont think with existing you can do , always a recommended practice to have backup of the old one before upgarding with the new one or yuo can do one more thing if you have another router with insatalled old sdm file just copy the sdm file from that router and then tftp to this router using normal procedure.


Hope to Help !!


Ganesh.H


Remember to rate the helpful post

Actions

This Discussion