RTP compression enabled, but not?

Unanswered Question
May 26th, 2010

All,

I've enabled rtp compression on my serial interface, but it doesn't show to be enabled:

interface Serial0/0/0:1
ip address x.x.x.x x.x.x.x
encapsulation ppp
ip tcp header-compression iphc-format
no cdp enable
service-policy output OUTBOUND
ip rtp header-compression iphc-format
end

sh ip rtp header-compression s0/0/0:1
RTP/UDP/IP header compression statistics:
Interface Serial0/0/0:1 (compression off, IPHC, NON TCP)
    Rcvd:    0 total, 0 compressed, 0 errors, 0 status msgs
             0 dropped, 0 buffer copies, 0 buffer failures
    Sent:    0 total, 0 compressed, 0 status msgs, 0 not predicted
             0 bytes saved, 0 bytes sent
    Connect: 16 rx slots, 16 tx slots,
             0 misses, 0 collisions, 0 negative cache hits, 16 free contexts

Why is it doing this?

Thanks,

John

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Wed, 05/26/2010 - 07:55

Okay,

I took off the header compression config from the serial interface, and I applied it in the policy-map under the class VOICE. I get the same thing though. Is it working the way it's expected?

Service-policy output: OUTBOUND

    Class-map: VOICE (match-all)
      57752 packets, 7203296 bytes
      5 minute offered rate 32000 bps, drop rate 0 bps
      Match: access-group name VOICE
      Queueing
        Strict Priority
        Output Queue: Conversation 264
        Bandwidth 768 (kbps) Burst 19200 (Bytes)
        (pkts matched/bytes matched) 5556/689952
        (total drops/bytes drops) 0/0
      compress:
          header ip rtp
          UDP/RTP (compression off, IPHC, NON TCP)
            Sent:    0 total, 0 compressed,
                     0 bytes saved, 0 bytes sent
                     rate 0 bps

      QoS Set
        dscp ef
          Packets marked 902       <---- It's matching the source traffic and applying the tag

Thanks,

John

John Blakley Wed, 05/26/2010 - 08:11

I scratched it....I read that on T1 lines and over it's generally not recommended to enable anyway

Actions

This Discussion