2960 Config

Unanswered Question
May 26th, 2010

Can I use a config from one of our other 3560 or 3750 for a 2960?  We have some older 2950s that are not in production any longer, could I use that config on a 2960?  This is our first 2960 in our environment.  It will be used as an edge switch and will be directly connected to a 3750 stack in a closet.

Thanks.

-Ed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 05/26/2010 - 07:50

Ed

You can use some of the config such as the L2 vlan database although you could just as easily pick up the vlans by using VTP. The 3560 is a L3 switch and the 2960 is a L2 switch so if you had multiple L3 vlan interfaces on the 3560 then you can't have the same on the 2960. If you were using the 3560 as a L2 switch and only had one L3 SVI up/up then you can copy that config if you want.

It really depends on exactly what config you had on your 3560.

Jon

fasteddye Wed, 05/26/2010 - 07:56

Thanks for the reply Jon.

All of our 3560 and 3750 switches are used as L2 switches.  We use trunk port access to connect.  Our VTP is in transparent mode so we manually config the necessary vlans on each switch.  Hope that helps some.

-Ed

Jon Marshall Wed, 05/26/2010 - 07:58

fasteddye wrote:

Thanks for the reply Jon.

All of our 3560 and 3750 switches are used as L2 switches.  We use trunk port access to connect.  Our VTP is in transparent mode so we manually config the necessary vlans on each switch.  Hope that helps some.

-Ed

Ed

Then if you don't have any detailed QOS policies etc.. then you should be fine apart from the interface naming which may well be different.

Jon

fasteddye Wed, 05/26/2010 - 08:04

I have pasted a few config examples.

Here is a sample of our normal QoS config on all switches.

mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos

Here is a sample of our normal switch port config

switchport access vlan XXX
switchport mode access
switchport voice vlan XXXX
switchport port-security maximum 2
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
queue-set 2
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone | cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable

glen.grant Wed, 05/26/2010 - 09:06

  I would venture to guess that the 2960 QOS parameters are not the same  as a 3560 or 3750 so you would probably have to figure that out for a 2960 .  Haven't dealt much with 2960's though .

fasteddye Wed, 05/26/2010 - 11:07

When I entered the auto qos voip cisco-phone command, it generated some lines that I am not sure about.  These lines of code are not on any of our 3560 or 3750.

class-map match-all AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-all AutoQoS-VoIP-Control-Trust
match ip dscp cs3  af31
!
!
policy-map AutoQoS-Police-CiscoPhone
class AutoQoS-VoIP-RTP-Trust
  set dscp ef
  police 1000000 8000 exceed-action policed-dscp-transmit
class AutoQoS-VoIP-Control-Trust
  set dscp cs3
  police 1000000 8000 exceed-action policed-dscp-transmit
!

Leo Laohoo Wed, 05/26/2010 - 15:31

Depends on the IOS (if you are using 2960S) or the exact model.  If you are using the 2960/2960G then the QoS commands you've posted will work.  Not all of the QoS is supported if you have the LanLite model 2960 or the IOS feature set (if you have the 2960S).

Hope this helps.

Please don't forget to rate useful posts.  Thanks.

Actions

This Discussion