Oracle&&IVR CISCO

Unanswered Question
May 26th, 2010

Hi,

I am  working with IVR CISCO Callcenter, and our custom has an Oracle Database. We  know that when you want to insert some data in database, you must to do “insert”  and then “commit”. IVR doesn’t allow us insert nothing, because we don’t know  how to do “Commit”.

I hope you  could help us.

Thanks  very much

Best  regards  

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Natalia474 Thu, 05/27/2010 - 02:19

Thanks!

Now i dont have the applilcation here, but...

Which is the way to import Oracle Jar?

Do you know which is the java's version CIsco IVR has?

Maybe it is a very stupid question.

Thanks very much!

Regards

Natalia

Now i dont have the applilcation here, but...


Expression Editor? Yes you do.

Which is the way to import Oracle Jar?

The same way that any JAR is imported. Described in the Cisco documents - you need to add it to the document repository and change the CLASSPATH so that the JAR is referred to. CRS needs to see the classes in the JAR through reflection so the Expression Editor can display the classes and the methods therein. If you haven't set it up correctly, you will know immediately - because the Expression Editor will not be able to show the methods of the class when you  set it.

This takes a little experimentation, but it's worthwhile. There is a document on the Expression Editor.

Regards,

Geoff

Gergely Szabo Thu, 05/27/2010 - 13:48

Now wait a second. Why commit?

The ODBC driver for Oracle has got AutoCommit enabled. Did you change it?

Is it a special requirement of the database?

What version of Oracle are you using? Did you try to run the update query against the database using a different tool, over JDBC or you-name-it (for example their sql CLI)? Were the table(s) not updated without explicitly saying COMMIT TRANSACTION?

G.

Natalia474 Fri, 05/28/2010 - 00:23

HI!!!!!

The problem was that It had 10 conection to oracle database.Sometimes these conections block themselves.

We solved this problem yesterday with a procedure.

Thanks very much for all!

Regards

Natalia

Actions

This Discussion