UCCX 7.0(1) Jtapi resync

Answered Question
May 26th, 2010

Hi,

I'm getting a prompt when I try to resync the jatpi in UCCX 7.0(1).

When I click on  Subsystems -> Cisco Unified CM Telephone -> Cisco JTAPI Resync I get the following prompt :

"Please disable the Cisco Security Agent on the server Running the Cisco Unified CCX software (all servers in case of a high availablility setup) before you proceed with the Cisco JTAPI Resnc"

I can't this service anywhere in control centre, or in the list of processes in the serviceablitly tool. Where do I disable this?

Regards,

Brian

I have this problem too.
0 votes
Correct Answer by Kevin Przybylowski about 6 years 6 months ago

Yes - it's just a warning like Peter said.

If you don't see the "Cisco Security Agent" service in Administrative Tools > Service, then it's a safe bet whoever configured it didn't install it.

Correct Answer by Peter Gale about 6 years 6 months ago

Hi Guys

The "Please disable CSA..." message is a 'warning' only, it does NOT check the UCCX or IPIVR box, just click OK if you are SURE that CSA is either disabled or not running !

cheers

Peter


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Peter  Gale
CCSI# 22524
Systems Instructor, AsiaPac Training
Housley Computer  Communications Pty Limited
Level 13, 132 Arthur Street
NORTH SYDNEY   NSW   2060
AUSTRALIA
Tel:  + 61 2 9954  4055
Mob: +61 (0) 413 44 99 70
http://www.housley.com.au
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ABN  60 001 422 724

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Phuong Hoai Huynh Wed, 05/26/2010 - 08:48

Hi Brian


What you want to do is look on the bottom right of your windows tool bar for a waving red flag.

Or go into the windows service and stop the Cisco Security Agent which will prompt you for a code to shut down.

Perform the Jtapi resync should go through smoothly once you do that.

brian1mcc Wed, 05/26/2010 - 08:54

Strange, I'm not seeing the red flag, or the Cisco Security Agent in the list of services. Is this installed by default in UCCX 7?

Phuong Hoai Huynh Wed, 05/26/2010 - 09:10

CSA is not installed by default onto the UCCX systems.

However that does sound unusual that your getting this prompt if you don't have the software at all.

Can you have a look under your add remove programs if there is a Cisco Security Agent there or in your msconfig

brian1mcc Wed, 05/26/2010 - 09:15

Thanks for your replies ...

I am not seeing CSA in add / remove programs or in msconfig.

Correct Answer
Peter Gale Wed, 05/26/2010 - 17:00

Hi Guys

The "Please disable CSA..." message is a 'warning' only, it does NOT check the UCCX or IPIVR box, just click OK if you are SURE that CSA is either disabled or not running !

cheers

Peter


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Peter  Gale
CCSI# 22524
Systems Instructor, AsiaPac Training
Housley Computer  Communications Pty Limited
Level 13, 132 Arthur Street
NORTH SYDNEY   NSW   2060
AUSTRALIA
Tel:  + 61 2 9954  4055
Mob: +61 (0) 413 44 99 70
http://www.housley.com.au
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ABN  60 001 422 724

Correct Answer
Kevin Przybylowski Wed, 05/26/2010 - 17:39

Yes - it's just a warning like Peter said.

If you don't see the "Cisco Security Agent" service in Administrative Tools > Service, then it's a safe bet whoever configured it didn't install it.

brian1mcc Thu, 05/27/2010 - 01:01

Thanks everyone for the replies .. resync worked perfectly.

Brian

antonio.fragoso Thu, 09/16/2010 - 05:56

Hi Bryan

Maby You can help me to sync the Jtapi

I am having the foolowing messag:

Cisco JTAPI Client
An error has occurred while trying to resynchronize the Cisco JTAPI Client. Please try Cisco JTAPI Resync in CRS Administration again.

brian1mcc Thu, 09/16/2010 - 06:45

Have you tried doing a data resync? If there are any errors post them here.

Brian

antonio.fragoso Thu, 09/16/2010 - 08:43

I receive the following

Unified CM Telephony Users
jtapi_1 -- Ok


Unified CM Telephony Port Groups

No Port Groups found


Unified CM Telephony Triggers

No Triggers found

Pablo Leiva Thu, 09/16/2010 - 09:36

Hello Antonio,

Could you let us know the exact UCCX version, 7.0(1) including any SR or ES?

Also please navigate in CUCM to the Cisco Unified Reporting (drop-down menu where you select CM Administration, serviceability, OS, etc). Please select the Unified CM Cluster Overview report.

- Please go into Unified CM Version and View Details. Please look for the CUCM Version on all servers

- Please go for the Unified CM Component Version and View Details. Please look for the cm-jtapi-plugin version for all the servers

Pablo

antonio.fragoso Thu, 09/16/2010 - 11:46

Hi Pablo

UCCX Cisco Application Administration - 5.0(2)_Build064

CUCM System version: 6.0.1.3000-7

Also please navigate in CUCM to the Cisco Unified Reporting (drop-down menu where you select CM Administration, serviceability, OS, etc). Please select the Unified CM Cluster Overview report.

  - I have only  CM Administration, serviceability, OS and Desater Recovery Sytem

Pablo Leiva Thu, 09/16/2010 - 12:35

Hello Antonio,

As per the compatibilty matrix, CUCM 6.0.1.3000-7 is not explicitely supported for 5.0(2):
http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_device_support_tables_list.html

If upgrades are possible, I think you can try running compatible software.

Before that, by any chance you have McAfee VirusScan installed on this CRS? If it's installed, make sure that On-Access Scan is enabled while trying the JTAPI ReSync. If there's another AV software, make sure it's listed in the comp matrix.

Please open cmd and type CET.
- Look for the ClusterDependentConfig; double click on the first entry of the right side. From the second tab, please let me know the value of JTAPI Version.

We can try to manually download and install the JTAPI plug-in from CUCM.
1) Login into CUCM
2) Navigate to Application -> Plugins
3) Search for the plug-in that contains jtapi, download Cisco JTAPI for Windows
4) Install the plugin on the CRS server (Restart of CRS engine or CRS node manager is required).

Please check the version on CET again afterwards.

Hope that helps!

Pablo

antonio.fragoso Thu, 09/16/2010 - 19:06

HI Pablo

I follow you advice but it still apear like that:

"ClusterDependentConfig[schema=ClusterDependentConfig,time=Fri Sep 17 00:50:02 GMT-01:00 2010,recordId=492980589,desc=,node id=1,db version=8.00.2156,db edition=MSDE,crs service release=,crs release=5.0(2)_Build064,crs engineering special release=,icd language=Portuguese,jtapi client version=unknown,hd size=2048,rd size=2048]"

Pablo Leiva Fri, 09/17/2010 - 06:46

Hello Antonio,

If the manual JTAPI installation works without an error it might be that the registry entry is not being updated, although the JTAPI has been updated succesfully.

If you are running CUCM version 6.0.1.3000-7 = 6.0(1b), then the Cisco Unified Communications Manager JTAPI version is 6.0(1.1000)-5.

Please enter this value like that "6.0(1.1000)-5" (without the quotes) in CET> ClusterDependentConfig> JTAPI Version and try the JTAPI re-sync again.

Pablo

Pablo Leiva Fri, 09/17/2010 - 09:47

Antonio, another thing... did you installed this UCCX over a regular Windows 2003 server or using Cisco-provided OS? check if you have a C:\WINDOWS or a C:\WINNT ?

Pablo Leiva Mon, 09/20/2010 - 05:11

yeap, that should do it.

The Cisco-provided disc creates different folders than the standard Windows 2003 SW disc., like the WINNT folder.The system looking to

verify configuration data under the Java folder and cannot find it.

bvanbenschoten Sat, 08/24/2013 - 18:54

This worked for me.  I built a lab UCCX 7 system to test migration for a customer.  I didn't use the Cisco provided OS image.  Just a standard windows image.

Thanks for the tip.

Actions

This Discussion

Related Content