CUPC IM not working

Answered Question
May 26th, 2010

Hi fellow Cisco Support Community

I have a problem I am trying to work out here. I saw a similar discussion however that fix did not work for me. So right now I have deployed CUPS v7.07 and have integrated it with CUCM v7.1. Everything seems to be working on all the Diagnostics tests I have run so far. Server Health on IM clients seems to be all good.


I have integrated CUPS with LDAP but CUCM is NOT integrated with LDAP which is okay since as I understand it LDAP is used to add and find the contacts for the CUPC.

Status changes work good, calls work etc. When I add a contact or just attempt to IM a contact from the search pane the contact name shows but next to the name is a little gray circle that to me should be green.

I type a message and when I hit enter I get
"John Doe did not recieve your message because it could not be delivered"

Things I have checked

1. Incoming and Outgoing ACL's both set to ALL

2. I was not sure of DNS at the time of deployment so my server name is actually the IP address

3. Under SIP Proxy Domain I have XXXX.local under the federation routing paramters I have CUPS1.XXXX..local- since the name was initially CUPS1

4. I do not have any type of client firewalls running.

A similar post suggested that under the Proxy Domain Field that the user actually just put the FQDN of the server with as in MISD1. but when I try that it does not allow me to.

Any help would be appreciated!

I have this problem too.
0 votes
Correct Answer by htluo about 6 years 6 months ago

When you have LDAP integrated with one system but not integrated with another system, that's where you usually saw the problem.

When you add contacts to CUPC by LDAP search, it's the sAMAccountName in Active Directory (assuming your LDAP is Active Directory) being used to form the SIP URI.

When you enable a user to use CUP/CUPC from CUCM > System > Licensing > Capability Assignment, it's the CUCM user ID being used to form the SIP URI.

SIP URI is case sensitive.  If the user ID in CUCM is jdoe while the sAMAccountName in AD is JDoe, you won't be able to see user's availability presence.  Thus you won't be able to send IM.

Michael

http://htluo.blogspot.com

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
htluo Wed, 05/26/2010 - 17:04

When you have LDAP integrated with one system but not integrated with another system, that's where you usually saw the problem.

When you add contacts to CUPC by LDAP search, it's the sAMAccountName in Active Directory (assuming your LDAP is Active Directory) being used to form the SIP URI.

When you enable a user to use CUP/CUPC from CUCM > System > Licensing > Capability Assignment, it's the CUCM user ID being used to form the SIP URI.

SIP URI is case sensitive.  If the user ID in CUCM is jdoe while the sAMAccountName in AD is JDoe, you won't be able to see user's availability presence.  Thus you won't be able to send IM.

Michael

http://htluo.blogspot.com

zamora0800 Wed, 05/26/2010 - 17:41

Michael..

I guess that's why I bought your book

So here was the fix.

I changed the username in UCM to match the case (lower case) in Active Directory and what do you know...it works now.

Thank you !

e.parsonage Thu, 11/18/2010 - 08:55

I'm having an issue similar to this however I believe the problem is to do with the fact the usernames are configured as 'joe bloggs' with the space, apparently this is a valid character with in AD and seems to be causing problems with IM's.

Would this be a correct assumption?

Thanks

DOUG DAVIDSON Thu, 11/18/2010 - 11:40

I had the same issue with version 8 of CUPS/CUPC. I removed the " " from the user, "john smith" to "johnsmith" and it resolved the problem.

HTH,

DOug

luirodr2 Fri, 03/25/2011 - 11:23

Hello Experts,

I`m having the same issue as the one listed here, in CUPS 7.0.5, when the users try to send a message to eachother they get the response:  [Person] did not receive your message because the message could not be sent. We are running CUCM 7.1.3 and both CUP and CUCM are sync with LDAP. I have checked all the suggestions listed here and everything seems to be properly configured do you guys have any other suggestion?

Thanks

Actions

This Discussion