Synchronizing IPCC server's time with an external time source

Unanswered Question
May 26th, 2010

We have a IPCC server (CRS 4.0.3) running on a Windows Server 2000 SP4 platform. The server is working along with a Callmanager 4.1(3) in a WORKGROUP environment and there’s no domain. The clock on the IPCC server is recently acting very weirdly (back and forth by 10 - 30 minutes!) and I was wondering how can i change the time source provider for IPCC server to use a reliable external time server available on internet (or even use our local router).

Any input on this issue is appreciated in advance!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ehsan M. Wed, 05/26/2010 - 13:52

I see the server is configured to pick up time for it's local router as indicated in ntp.conf file according to the document. Is it possible that router is not configured to provide time? The router itself is using NTP:

!
scheduler allocate 20000 1000
ntp clock-period 17180556
ntp master
ntp update-calendar
ntp server 131.107.13.100
!

Brandon Buffin Wed, 05/26/2010 - 13:54

Does "show ntp status" on the router show that it is synchronized? Is the NTP service started on the server?

Brandon

Ehsan M. Wed, 05/26/2010 - 14:35

Yes, it does show it's synchronized:

2821VG#show ntp status
Clock is synchronized, stratum 2, reference is 131.107.13.100
nominal freq is 250.0000 Hz, actual freq is 249.9890 Hz, precision is 2**18
reference time is CFA8119E.6A682D5F (14:31:10.415 PDT Wed May 26 2010)
clock offset is -3.0165 msec, root delay is 29.39 msec
root dispersion is 8.22 msec, peer dispersion is 5.20 msec
2821VG#

Also the NTP service is started on the server.

Ehsan M. Wed, 05/26/2010 - 15:34

I think I found the problem. The IPCC server was set to syncronize time with Callmanager as I found in it's "ntp.conf" file. This should not be like that as the document points out: Note: You cannot use NTP to synchronize between two Cisco CallManagers. The NTP that is installed in Cisco CallManager is a client NTP service and only synchronizes to an NTP server.

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008009470f.shtml

So I just changed it to point to it's local router IP address (Which is itself is syncronizing with external source) and then restarted NTP service on the server. This should hopefully resolve the issue

One thing that I'm not still sure of, is the router which is syncing with an external source, providing time to internal source with no extra configuration needed? Should I use "ntp master" command on the router to enable such functionality? take a look at this doc:

http://oreilly.com/catalog/hardcisco/chapter/ch10.html

Ehsan M. Wed, 05/26/2010 - 16:56

Alright. After almost 10 minutes, NTP service automatically stopped with logging bellow error in windows event viewer:

"Time correction of -3659 seconds exceeds sanity limit (1000); set clock manually to the correct UTC time"

The server is configured to use it's local router as it's time server (using ntp.conf file as indicated in http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008009470f.shtml) while the time on the router is correct and also showing it's syncronized:

2821VG#show ntp status
Clock is synchronized, stratum 2, reference is 131.107.13.100
nominal freq is 250.0000 Hz, actual freq is 249.9893 Hz, precision is 2**18
reference time is CFA82D3D.B1C0B6C2 (16:29:01.694 PDT Wed May 26 2010)
clock offset is -9.5469 msec, root delay is 26.95 msec
root dispersion is 17.91 msec, peer dispersion is 8.36 msec

Any idea why I cannot get the server' time Synced with the router?

Brandon Buffin Thu, 05/27/2010 - 05:09

There is a limit to the time difference between the client and server. Try setting the time manually on the server and then restart the NTP client. Regarding your earlier post, yes, you will need "ntp master", but it looks like from the config you posted that this command is already configured.

Hope this helps.

Brandon

Ehsan M. Thu, 05/27/2010 - 11:54

Ok. Let's clear things up.

Problem:

Network Time Protocol service stops in Callmanager 4.1.3 (Windows Server 2000 SP4) after configured to use it's local router as it's upstream time provider as indicated in this document (by configuring "ntp.conf" file): http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008009470f.shtml

Here is the error which is loged in windows event viwer:

Time correction of -3619 seconds exceeds sanity limit (1000); set clock manually to the correct UTC time.

Why? 3619 seconds is almost 1 hour but the time on the server and on the router is correct! Could it be something related to DST problem with this box?

Note: DST is not working correctly on this machine and whenever it starts or ends we manually set the clock ahead or behind. We've also left "Automatically adjust clock for daylight saving changes" unchecked due to this problem.

This beahvir of callmanager is causing trouble for our contact center as well because IPCC server is configured to sync it's time from Callmanager using it's own "ntp.conf" file

Any idea?

  

Actions

This Discussion