Cisco IOS and CME Version for Cisco 3845

Unanswered Question
May 27th, 2010

Hi,

We are planning to install Call Manager Express on our Cisco 3845 router. However, I do not know which version to install and which IOS. I tried to check the Cisco IOS and CME Compatibility Matrix page and saw that version 4.1 is the recommended version and it is supported starting 12.4(15)T7 IOS. I already downloaded CME 4.1 but I can't choose which IOS to install. I'm trying to download 12.4(15)T7 but Cisco warned me that it has a problem (you know when Cisco warns you whenever you are downloading a broken IOS). So I planned to choose other version but I'm having a hard time choosing which IOS will fit both IOS and CME on a 128MB flashcard.  I am now downloading 12.4(11)XW7 IP Voice but I'm not 100% sure if CME 4.1 will work on this platform. Can anyone help me choose the right IOS? Thanks.

John

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Md. Mijanur Rahman Fri, 05/28/2010 - 05:46

You can run the version 12.4(15)T7, see every IOS has some issues more or less, every IOS has some known issues, and Cisco warns about those before you download it, read the defects before downloading it for that particular IOS and try to match your requirement, if any serious issue is there then look for next version like 12.4(15)T8 and so on.... I am using 12.5(20)T10 for long days and didn't find any issue so far. Also i'm not sure the version 12.4(11)XW7 supports CME 4.1 or not, check the compatibility matrix and that's the best practice.

John Patrick Lopez Sun, 05/30/2010 - 18:37

Thanks for the reply. I checked the software feature tool of Cisco but I cannot find version 4.1 Instead, I found 4.0(1). Base from there, the IOS that I downloaded supports version 4.0(1).

How do i determine if the CME version that the IOS is running? Thanks.

John Patrick Lopez Sun, 05/30/2010 - 18:45

I think I'm using 4.2.

PHKPTGTW001#sh version | i IOS
Cisco IOS Software, 3800 Software (C3845-IPVOICEK9-M), Version 12.4(11)XW7, RELEASE SOFTWARE (fc2)
PHKPTGTW001#sh telephony-service | i Express|Version
CONFIG (Version=4.2(0))
Version 4.2(0)
Cisco Unified Communications Manager Express
PHKPTGTW001#

So I guess I should upload the correct phone firmwares on the router. I uploaded the following files from the 4.1 zip file. Well is it backward compatible? Thanks.

PHKPTGTW001#sh flash:

System CompactFlash directory:
File  Length   Name/status
  1   42912332  c3845-ipvoicek9-mz.124-11.XW7.bin 
  2   129828   P00308000400.bin 
  3   461      P00308000400.loads 
  4   701768   P00308000400.sb2 
  5   130232   P00308000400.sbn 
  6   2759     Readme7960-40.txt 
  7   4802     admin_user.html 
  8   672015   admin_user.js 
  9   1602     CiscoLogo.gif 
10   716      CME_GUI_README.TXT 
11   953      Delete.gif 
12   16344    dom.js 
13   864      downarrow.gif 
14   6146     ephone_admin.html 
15   4658     logohome.gif 
16   3724     normal_user.html 
17   81443    normal_user.js 
18   1347     Plus.gif 
19   843      sxiconad.gif 
20   174      Tab.gif 
21   2431     telephony_service.html 
22   870      uparrow.gif 
23   9968     xml-test.html 
24   3412     xml.template 
[44691252 bytes used, 83759304 available, 128450556 total]
125440K bytes of ATA System CompactFlash (Read/Write)

PHKPTGTW001#

John

Actions

This Discussion