Exchange 2010 and Unity 4

Unanswered Question
May 27th, 2010

I have been tasked with attempting to get Unity 4 to work with Exchange 2010. I know that this configuration is currently not and will not be supported; however, I wanted to see if anyone else had attempted.



So far, I have gotten most everything operational except for playing back the actual message through the phone. My test user can log into their voicemail, get number of messages, types (read, saved, etc.) and can play back individual messages and hear the timestamp and so forth, only a "that message is no longer available" message is played instead of the actual message. Messages can be played back no problem through email.


Going off memory and what I had jotted down, there are the changes I made:

- Manually set permissions in Exchange 2010 for Unity service accounts.

- Set RPC throttling policy for Unity service account.

- Uninstall 2003 ESM tools.

- Manually install and move around updated MAPI version.

- Customize Exchange 2010 mailbox quotas.

- Create transport policy to mark vm's with MAPI class type.


I was able to do a similar change to get 4.0 to work with Exchange 2007, but haven't quite gotten there yet with 2010. I wanted to help anyone else out who may need info as well as see if anyone had any ideas as to why Unity can't play back the message. I suspect is has to do with the .wav attachment, perhaps some Exchange 2010 feature that is preventing Unity from accessing it through a user inbox. Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chireader Wed, 06/02/2010 - 14:13

First, thanks for passing on the info.


Have you made any more discoveries on making this work?


Thanks.

CHARLES HEUPEL Tue, 06/15/2010 - 05:37

Joseph,


Good info....I'm currently trying to get Exchange 2010 to work with Unity 5.0, which is supposably supported according to this link.


http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity/7x/using_exch2010/usingex2010withcu7x5x.html


However, when I get to step 14 (installing ExchangeMapiCdo.exe), it gives me an error saying it can't be installed with this version of Exchange even though Exchagne is not running on the box and I have uninstalled the 2003 Management tools.  I would like to know how you got this to work on your 4.0 box?  Also, when you re-run the Unity Installation wizard to select your partner exchage server, there is no option for exchage 2010.  Did you just select 2007 and make it work?


bryantwalley Tue, 06/15/2010 - 10:38

Joseph,


Is there a step by step that I could use to get to where you are now.


My company has Unity 4.0 and we want to move from Exchange 2003 to 2010.  We cannot move until we get this working.


Thanks

Actions

This Discussion

Related Content