cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1153
Views
0
Helpful
1
Replies

Help troubleshoot output queue discards in QoS traffic

gregokada
Level 1
Level 1

We are having problems identifying the discarded packets on a 9MB multilink ppp interface which has 6 serial T1 interfaces binded into a single multilink interface.  Here are the configurations:


controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
class-map match-any Business-Critical
match access-group 145
class-map match-any Best-Effort
match access-group 146
class-map match-any Voice-RTP
match ip dscp ef
match ip dscp cs3
match ip dscp af31
match access-group 148
class-map match-any Priority-Data
match access-group 141
class-map match-any Mission-Critical
match access-group 143
!
!
policy-map queuing-policies
class Voice-RTP
  set ip dscp ef
  priority percent 50
class Priority-Data
  set ip dscp af41
  bandwidth remaining percent 15
class Mission-Critical
  set ip dscp af31
  bandwidth remaining percent 20
class Business-Critical
  set ip dscp af21
  bandwidth remaining percent 25
class Best-Effort
  set ip dscp default
  bandwidth remaining percent 40

interface Multilink2
description MPLS to Sprint PE DS-3
bandwidth 9216
ip address 10.130.7.42 255.255.255.252
ip accounting output-packets
ip flow ingress
no peer neighbor-route
no cdp enable
ppp multilink
ppp multilink fragment disable
ppp multilink group 2
service-policy output queuing-policies

interface Serial0/0/0:0
bandwidth 1544
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 2
!
interface Serial0/0/1:0
bandwidth 1544
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 2
!
interface Serial0/1/0:0
bandwidth 1544
no ip address
encapsulation ppp
ip route-cache flow
ppp multilink
ppp multilink group 2
!
interface Serial0/1/1:0
bandwidth 1544
no ip address
encapsulation ppp
ip route-cache flow
ppp multilink
ppp multilink group 2
!
interface Serial0/2/0:0

bandwidth 1544
no ip address
encapsulation ppp
ip route-cache flow
ppp multilink
ppp multilink group 2
!
interface Serial0/2/1:0
bandwidth 1544
no ip address
encapsulation ppp
ip route-cache flow
ppp multilink
ppp multilink group 2

access-list 148 remark Voice Queue 50 percent
access-list 148 permit udp any host 10.130.19.228 range 1719 1720
access-list 148 permit tcp any host 10.130.19.228 range 1719 1720
access-list 148 permit udp any host 10.130.19.225 range 1719 1720
access-list 148 permit tcp any host 10.130.19.225 range 1719 1720
access-list 148 permit udp any host 10.130.33.132 range 1719 1720
access-list 148 permit tcp any host 10.130.33.132 range 1719 1720
access-list 148 permit udp any host 10.130.33.133 range 1719 1720
access-list 148 permit tcp any host 10.130.33.133 range 1719 1720
access-list 148 permit udp any 10.235.1.128 0.0.0.31
access-list 148 permit udp any 10.235.1.192 0.0.0.31
access-list 148 deny   ip any any

ROS-W2#sho int multilink2
Multilink2 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 207.130.7.42/30
  MTU 1500 bytes, BW 9216 Kbit, DLY 100000 usec,
     reliability 255/255, txload 8/255, rxload 13/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 1d01h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 325487
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/325487 (size/max total/threshold/drops)
     Conversations  0/7/16 (active/max active/max total)
     Reserved Conversations 4/4 (allocated/max allocated)
     Available Bandwidth 2304 kilobits/sec
  5 minute input rate 484000 bits/sec, 63 packets/sec
  5 minute output rate 302000 bits/sec, 72 packets/sec
     6261395 packets input, 3525337169 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4922917 packets output, 1719617769 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

The problem is trying to correct the output drops in the configuration as these are voice grade packets.  Please advise....

1 Reply 1

Ganesh Hariharan
VIP Alumni
VIP Alumni

We are having problems identifying the discarded packets on a 9MB multilink ppp interface which has 6 serial T1 interfaces binded into a single multilink interface.  Here are the configurations:


controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/1/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-

Hi,

Check out the below link :-

http://www-au.cisco.com/en/US/docs/ios/12_3t/12_3t7/feature/guide/gttrbmlp.html

Hope to Help !!

Ganesh.H

Review Cisco Networking products for a $25 gift card