Media Master will not install after ES35 Unity upgrade

Answered Question
May 27th, 2010

I have a Unity server version 7.02 that I recently upgraded with service patch 35.  Prior to the patch everything was working correctly.  After the patch the media master control on the subscriber web sa page asks to re-install the active x add on.  Selecting install shows as completing, but a red x appears where the box should be.  Refreshing the page results in the request to install the active x add on again.  After installing it again the same issue comes up.  This happens indefinitely with no error messages.  I have tried this from ie on the server and on my own pc using unityadmin and unityinstall accounts.

I have tried to replace the MediaMasENU.cab from multiple sources on the server, from the install disks and from another Unity server that is working correctly.

I have tried various security settings in ie to no avail.

I have tried installing from the ciscopca website with similar results.  I do get an error box that pops up saying it couldn't find the media master so log out and log back in and follow the steps to install.  But even after installing this still occurs.

I have manually removed the class and re-installed the applicable files and registering the add-on with no change.  The class in the c:\Windows\Downloaded Program Files shows as a registry key name instead of the media master name and the status shows unknown.

I was hoping somebody else has run into this and had some more insight or things to try.

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 6 months ago

Hi

Sounds a lot like this:

CSCtd99678 Bug Details

Unity ES patch application may not update MedaiMasENU.cab.
Symptom:
We have seen in multiple customer deployments that the application of certain Unity Engineering Special patches may not properly update CommServer\Web\MediaMasENU.cab and cause the Media Master bar to fail to install when accessing Web/SA or PCA. In that situation, the Media Master bar is replaced with a red "X".

Conditions:
Seen with Unity 7.0(2) ES 31, 29, and 25.

Workaround:
Copy MediaMasENU.cab from CommServer\cscoserv\ciscopca\controls to CommServer\Web, replacing the version of that file already present in that destination directory.

Regards

Aaron

Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (4 ratings)
Loading.
Correct Answer
Aaron Harrison Fri, 05/28/2010 - 01:55

Hi

Sounds a lot like this:

CSCtd99678 Bug Details

Unity ES patch application may not update MedaiMasENU.cab.
Symptom:
We have seen in multiple customer deployments that the application of certain Unity Engineering Special patches may not properly update CommServer\Web\MediaMasENU.cab and cause the Media Master bar to fail to install when accessing Web/SA or PCA. In that situation, the Media Master bar is replaced with a red "X".

Conditions:
Seen with Unity 7.0(2) ES 31, 29, and 25.

Workaround:
Copy MediaMasENU.cab from CommServer\cscoserv\ciscopca\controls to CommServer\Web, replacing the version of that file already present in that destination directory.

Regards

Aaron

Please rate helpful posts...

grundle1322 Fri, 05/28/2010 - 05:54

Yes it does sound like that, and that was my initial thought also.  Unfortunately the work around had no effect on the problem.

grundle1322 Fri, 05/28/2010 - 07:38

Alright, for anyone out there that runs into this.  I ended up having to pull the MediaMasENU.cab file from another Unity server that was correctly running with ES35 on it.  It would not work with any .cab file from a Unity server that was not running ES35.

jasondrisc Fri, 06/04/2010 - 05:22

Aaron, thanks for the post.  I ran into this issue

while upgrading my test failover pair to Unity 7 and then installing ES

35.  The workaround resolved the issue.  I can now move forward on production boxes.

Thanks,

Jason

Actions

This Discussion