LMS 3.2 Campus 5.2.0 new devices not in campus

Unanswered Question
May 28th, 2010


I have discovered a new part of the network of my customer. The discovery went fine adding 28 new devices, the policy to add the credentials worked so I assumes the other applications would have no problem with the new devices.

All application are in auto allocation taking in all devices, so I expect to see 98 devices in all applications

CS has 95, RME has 95, DFM has 95but Campus shows 69 devices.

I selected include devices in Campus and was able to add 28 devices, this also launched again the data collection.

To my big suprise the campus homepage still shows 69 devices

I removed the devices and had them rediscovered, still only 65 devices after running  the data collection.

I re-inited the campus database and re-run  the data collection.  Still 65 devices.

I've turned on debugging for the data collection and saw that campus sees very well the difference in number of devices in DCR and Campus.

How can I troubleshoot this?

I don't see in the ani.log why it won't insert the new devices in campus.

I'm not after the accespoint, I want to see just the switches for now.

Thanks for any clue on this



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Joe Clarke Sun, 05/30/2010 - 10:45

Looks like you may have some duplicate devices.  It would be helpful if you list a set of devices missing from Campus so each one can be analyzed.

Michel Hegeraat Sun, 05/30/2010 - 11:30

Thanks Joe,

Duplicates? What message do you see in the logs that indicates a duplicate?

I see "Caught exception" but as many for devices that made it in to campus as for other devices and even phones an accessspoints we don't try to manage yet.

The devices that got into campus alright are installed and configured by my company. Their device names start of with "knt-".

The other devices have a variety of names based on their location "MAR_", "SAP_", "HOP_", "SAM_" and "GDS_"

These devices should have been discovered but some community)strings and ACL's are not yet updated. Most of them are discovered and in the DCR now


Should more debugging modules be turned on?

I do see a lot of

      SMFContainer: bind: _officialName changed from to null

for the devices I try to add.

But I don't understand why it does that.



Message was edited by: Michel Hegeraat

Joe Clarke Sun, 05/30/2010 - 14:09

I need a list of the devices' IPs as well.  I do see that DCR does have 95 devices, and ANI is only managing 69.  Why, I cannot say just yet.

Michel Hegeraat Mon, 05/31/2010 - 00:41

That is indeed the problem.

I noticed before that the Campus home page doesn't show the correct number of devices until the data collection has run, but after that first run all was OK Until now.

Here are the devices as they are in the hostfile    GDS_2950-24_A101_4077    GDS_C2960TCL-24_A101_7362    GDS_C2960TCL-24_C0_4076    HOP_2960GTC-24_A003_7370    HOP_2960GTC-48_B109_4073    HOP_2960PCL-24_A203_8444    HOP_3500GXL-48_A003_3773    HOP_3750GTS-24_B109_5617-5618_3    HOP_3750GTS-24_B109_5619-5620_5    HOP_3750GTS-24_B109-5615-5616_1    MAR_2960GTC-24_H13_4086     MAR_2960GTC-24_H23_4084     MAR_2960GTC-24_H23_4085     MAR_2960GTC-24_KAST_5580    MAR_2960GTC-24_SERVER_4083    MAR_2960GTC-24_SERVER_7365    MAR_2960GTC-48_H13_8610     MAR_2960GTC-48_MED_4071     MAR_2960GTC-48_W53_4072     MAR_2960GTC-48_w57_4074     MAR_2960GTC-48_W57_4088     SAM_2950-24_GANG2_1572       SAM_2960GTC-24-SERVER_7361    SAM_2960GTC-48_KELDER_7374    SAM_2960GTC-48_KELDER_7375    SAM_2960GTC-48_KELDER_7376    SAP_2950-24_031_1             SAP_2950-24_031_2             SAP_2950-24_2_1-ster1c     SAP_2950G-24_SERVER_4694     SAP_2950G-48_2_1_1-ster1a    SAP_2960GTC-48_2_1_5599    SAP_2960GTC-48_MEDIAT_7377    SAP_2960GTC-48_SERVER_5600        



Joe Clarke Mon, 05/31/2010 - 19:06

It looks like some of these devices may be switch cluster nodes.  Is that correct?

Michel Hegeraat Mon, 05/31/2010 - 23:21

Indeed they are.

Some clusters, some stacks.

These devices are currently managed using cisco netmanager my customer says.

I asume if netmanager can discover these devices, campus should be able to do even better



Joe Clarke Tue, 06/01/2010 - 08:52

By default, Campus does not manage switch cluster members directly.  It will instead use the IP address of the cluster commander.  The cluster members will be managed through that IP using community string indexing.  This means that your community strings cannot include '@' characters.  To disable cluster management, edit NMSROOT/campus/etc/cwsi/ANIServer.properties, and change Discovery.Cluster to OFF.  Then restart Daemon Manager, and run another Data Collection.

Switch stacks, on the other hand are managed as one physical device.  Only the one IP for the stack should be added to DCR, and all switches in the stack will be managed through that IP (as if you had one physical switch chassis).  Which devices are stacks in your list?

Michel Hegeraat Tue, 06/01/2010 - 23:20

But Campus should be able to discover clusters right?

Even if Campus manages the devices through the cluster commander, the topology will be shown, as it is I assume?

Or would it be better to turn this cluster discovery feature off?

Most of the "knt-" devices in the topology are stacks. They were discovered fine.

I only entered a few seed devices.

I want Campus to tell me what the topology looks like, not the other way arround.



Joe Clarke Tue, 06/01/2010 - 23:29

Have you added your cluster members as cluster-managed devices in DCR?  If so, then Campus will discover those members as cluster members, and they will appear with special notation on the topology map.  If, however, each cluster member is added as a standard device to DCR, then you should disable cluster management in Campus, and all your members will show up as regular devices on the topology map.

Seed devices don't matter to Campus.  Campus doesn't do new device discovery anymore.  It will use whatever devices are in DCR provided they are allowed by the configured Data Collection filters.

Michel Hegeraat Tue, 06/01/2010 - 23:53

I haven't added anything to the DCR

CS Discovery has done that. Doesn't it understand clusters?.

Are you saying I should change the DCR before Campus can handle the clusters?

What should I change?

If CS discovery doesn't understand clusters, will it do so in the future?  (LMS 4)



Joe Clarke Wed, 06/02/2010 - 00:03

CSDiscovery does understand clusters provided you have enabled the cluster Discovery module.  Without actually seeing how these devices are configured in DCR, I've been making assumptions.  Post a complete DCR export, and it will help to clarify some of this for me.

Michel Hegeraat Wed, 06/02/2010 - 00:25

Thanks Joe,

It makes sense now.

This module is not selected

I will have the discovered devices removed and a new discovery run with this module turned on.




This Discussion