Dynamic VLAN-Assignment from RADIUS with Aironet 1242AG doesn't work properly

Unanswered Question
May 28th, 2010
User Badges:

Hello All,


our setting is to assign VLANs dynamically from RADIUS (freeradius) to Clients connected to the 1242 Access-Points with one SSID. We have Firmware

12.4(10b)JA/JDA on the Aironet 1242.

The clients should be connected to one of three VLANs - one for staff, one for students and one for guests. I use the Web-Interface of

the 1242, because I'm not very familiar with IOS cli.


After assigning the first VLAN to the SSID -> click Accept, assigning the second VLAN to the SSID (overwriting the previous one) -> click Accept,

assigning the third VLAN to SSID (overwriting again) -> click Accept,  the assignment of VLANs works really fine,

(the only thing i change on the page is VLAN, the SSID is set to mandatory WPAv2)

BUT...

when the 1242 is rebooted (due a building power off or similar) it doesn't work anymore. Clients end up in an endless authentication loop.

After doing the procedure again from above - assigning all VLANs sequently once, it works fine again !  till next reboot...


All VLANs have same encryption, cypher, TKIP+AES CCM. On the Cisco-Site I found a command, which i also tried with no success:

'aaa authorization network default group radius'.

I also tried to save the working config and load it into the 1242 again, this also did not work.


It seems that i'm doing something wrong, but what ?


Thanks for some help,

Frank

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dancampb Fri, 05/28/2010 - 11:16
User Badges:
  • Cisco Employee,

All you really need to do is make sure the subinterfaces/vlans are created for each VLAN you need, then have radius push down IETF attributes 64, 65, and 81.

Actions

This Discussion

 

 

Trending Topics - Security & Network