cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
671
Views
4
Helpful
2
Replies

QoS for Internet Link (DSL)

kayocisco
Level 1
Level 1

Dears;

we have an internet link 2 Mbps and i want to do a QoS for the email traffic, so i want to reserve 1 Mbps from the incoming and outgoing emails. please advice with the configuration lines. the email servers are 172.16.20.20 and 172.16.20.21 the current configuration of the router as the following:

!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description Connected to LAN
ip address 172.16.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description connected to the modem (ISP)
bandwidth 2048
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1

!
interface Dialer1
bandwidth 2048
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp chap refuse
ppp ms-chap refuse
ppp pap sent-username sss@ssss.com password 7 101F5B4A5142
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Dialer1 overload

//natting for the email servers
ip nat inside source static 172.16.20.20 83.101.100.101

ip nat inside source static 172.16.20.21 83.101.100.102

!
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!

Message was edited by: kayocisco

2 Replies 2

Ganesh Hariharan
VIP Alumni
VIP Alumni

Dears;

we have an internet link 2 Mbps and i want to do a QoS for the email traffic, so i want to reserve 1 Mbps from the incoming and outgoing emails. please advice with the configuration lines. the email servers are 172.16.20.20 and 172.16.20.21 the current configuration of the router as the following:

!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description Connected to LAN
ip address 172.16.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description connected to the modem (ISP)
bandwidth 2048
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1

Hi,

For your information QoS doesn't interact unless there is congestion on the link,First Define the classes (for mail use the protocols like pop3 or smtp)

class-map match-any mail
match protocol pop3
match protocol smtp
match protocol imap
match protocol secure-pop3
match protocol secure-imap
match protocol exchange
match protocol ldap

Assign each traffic class the appropriate bw:
policy-map qos
class mail
bandwidth percent 50
class class-default
fair-queue


Apply the policy under each interface in the output direction:
interface serial 0/0
bandwidth 2048
service-policy output qos

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Dears;

this is about outgoing emails, what about the incoming email? can i do QoS for incoming emails too?

Thanks;

Kayo

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card