7921G firmware upgrade

Unanswered Question
May 30th, 2010

Hello,

         I have recently upgraded the firmware on our 7921G wifi phones, from 1.1(1) to 1.3(3). To authenticate against the correct wlan we import a backup.cfg file and it imports the correct ssid and key etc. The issue is that after the import and phone reset it then tries to download the firmware again and fails. And if the phone is turned off or restarted it looses all it's settings from the backup.cfg file and we have to go through the importing all over again. The hardware revision of the phones is 1.5. Any help is appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ajay-raval Fri, 09/24/2010 - 16:19

Hello,

Your are lucky, you were able to upgrade your firmware to 1.3.  I am trying to upgrade my 7921Gs from 1.0.3 to 1.3.4, but am unable to do so.

  • I have tried over WLAN,
  • Using USB connection

but no luck. It says image download failed, when I try using USB method. I used all three browsers, IE, Chrome and FireFox.

I tired using the recovery method as well (holding the ... and speakerphone buttons while powering up.

Any help will be appreciated.

Thanks.

Zachariah Stewart Sun, 09/26/2010 - 16:38

Hi Ajay,

            I ran into this issue as well. To upgrade the firmware from 1.0.3 to 1.3.4 you will have to do a 2 part upgrade. Upgrade it to 1.1.1 and then to 1.3.4. That should work fine. It is common for a lot of phones when making big jumps in updates to firmware.

           regards,

                        Zachariah J Stewart

Actions

This Discussion